mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > YAFU

Reply
 
Thread Tools
Old 2016-01-01, 22:04   #1
jux
 
jux's Avatar
 
Aug 2015

2×33 Posts
Default Starting NFS skipping poly select

After msieve was taking too long in poly select (it suggested 28 hours for a c134! There must be a way to reduce this limit...) I decided to try to skip the remaining poly select and continue factorization.

I pasted this into my ggnfs.job
Code:
n: 54924630630496187046668371273222397725206189899297615388925385635035571650502651626948202319614694312654201876877038310590170823254001
skew: 1690270.78
c0: -15305201708300775228557787741164385
c1: -165318285868635772787959977207
c2:  106151669952841815430851
c3:  325771522196209143
c4: -29833205554
c5:  3120
Y0: -111975992242728408345401284
Y1:  324838456418611
YAFU gave me after trying nfs()
Code:
Please set all bounds to reasonable values!
and
Code:
cat rels0.dat: No such file or directory
could not open rels0.dat for reading
Any ideas on what I can do? I copied the info from the last polynomial in msieve.dat.p (I don't remember if YAFU uses msieve.fb, but that file wasn't there)
jux is offline   Reply With Quote
Old 2016-01-01, 22:32   #2
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×29×83 Posts
Default

What's your yafu command?

There are several other parameters besides the polynomial that the siever needs, and I believe it was the siever that printed that message, not YAFU.

Anyways, by passing the -ns argument to yafu, it should skip poly select and also be smart enough to fill in reasonable selections for those other parameters before calling the sievers again.
Dubslow is offline   Reply With Quote
Old 2016-01-01, 23:09   #3
jux
 
jux's Avatar
 
Aug 2015

1101102 Posts
Default

Right now I'm using
Code:
yafu-64k-x64.exe nfs(54924630630496187046668371273222397725206189899297615388925385635035571650502651626948202319614694312654201876877038310590170823254001) -ns -v -threads 8
I'm probably doing it wrong, as -ns isn't recognized. Couldn't find -ns anywhere in the docfile either

Last fiddled with by jux on 2016-01-01 at 23:10
jux is offline   Reply With Quote
Old 2016-01-01, 23:45   #4
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3·29·83 Posts
Default

I'm not sure why it wouldn't work -- some vagary with cmd.exe perhaps? -- but -ns is very certainly in the docfile, in plain sight too I should think. What's the exact error message? Post all the output from the command, not just the command itself please.

Quote:
NFS BEHAVIOR OPTIONS - configuring phases to run
general info: if none of these options are specified, yafu will perform all of
them in order (poly search, sieving, filter, LA, sqrt). On restarts, the set
of phases performed is automatically determined by yafu and depends on the state
of one or more saved files associated with the input number. If any of the
following 5 options are specified, only those phases will be performed; checks
against saved files will still be in place (i.e., refusal to overwrite data files)

-np [X,Y] Perform poly search step within nfs(). NOTE: any existing
poly files will be overwritten. Optionally, provide a range of
leading coefficients over which to search in the format: start,stop
-ns [X,Y] Perform sieving step within nfs() if a valid job file exists
for the input number and if the input number is the same as
that specified in an existing data file. Optionally, provide
a range of special Q over which to sieve in the format: start,stop
-nc Perform postprocessing step within nfs(), starting with
filtering
-nc2 Perform postprocessing step within nfs(), starting with
linear algebra
-nc3 Perform postprocessing step within nfs(), starting with sqrt

NFS BEHAVIOR OPTIONS - general
-lathreads <num> Use specified number of threads for linear algebra only. If
not specified, 'threads' threads are used (which defaults to 1).
-a Use special Q on the algebraic side within nfs()
-r Use special Q on the rational side within nfs()
-job <name> Name of input file in nfs - use a file other than ggnfs.job
as the input job file.
-o <name> Name of output file in nfs() - use a file other than
msieve.dat as the output data file
-ggnfsT <num> Timeout to apply to nfs() command, in seconds (default = infinity)
-psearch <name> Specify method of parallel polynomial selection with N threads:
'fast' - divides the search time by N (default)
'wide' - normal time deadline, search N times the
leading coefficient range
'deep' - normal time deadline, search every leading
coefficient with N threads
Note that when N = 1, this option has no effect.
-pbatch <num> Size of blocks of leading coefficients to distribute during
NFS polynomial selection. Default is 250.
-R Must specify in order to restart when a previous savefile exists
-siever <num> Specify the ggnfs siever version to use, where <num> is
the integer in the default ggnfs siever name. I.e,
ggnfs-lasieve4I<num>e.exe
-nt <file1>,<file2>... Perform automated trial sieving of the listed job files (then exit)
(yafu will fill any missing ggnfs parameters as necessary)
-testsieve <num> Number of digits beyond which yafu will test sieve the top
3 polynomials discovered by snfs (default: 140)



These flags are ignored when redirecting input to yafu.

These same flags can be specified in a file named yafu.ini in the same
directory as the executable. Put <flag>=<value> pairs on single lines
of the file to override default values. Command line arguments will override
both default values and anything in the .ini file. An example yafu.ini
should have been included along with the binary in the downloadable package.

Last fiddled with by Dubslow on 2016-01-01 at 23:49
Dubslow is offline   Reply With Quote
Old 2016-01-02, 00:30   #5
swellman
 
swellman's Avatar
 
Jun 2012

23×33×13 Posts
Default

Quote:
Originally Posted by jux View Post
Right now I'm using
Code:
yafu-64k-x64.exe nfs(54924630630496187046668371273222397725206189899297615388925385635035571650502651626948202319614694312654201876877038310590170823254001) -ns -v -threads 8
I'm probably doing it wrong, as -ns isn't recognized. Couldn't find -ns anywhere in the docfile either
I always use quotation marks. For your example, try the following

Code:
yafu-64k-x64.exe "nfs(54924630630496187046668371273222397725206189899297615388925385635035571650502651626948202319614694312654201876877038310590170823254001)" -v -ns -threads 8
swellman is online now   Reply With Quote
Old 2016-01-02, 01:01   #6
jux
 
jux's Avatar
 
Aug 2015

2·33 Posts
Default

I must have been using an old version... I was using yafu-1.24 and the help file lists yafu 1.23. I just downloaded the newest version and I see it now.
jux is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
YAFU Poly Select Deadline amphoria YAFU 22 2016-09-17 09:47
msieve poly select: choosing Stage1norm VBCurtis Msieve 0 2016-04-11 21:33
mfaktc not starting in Mac OSX bayanne GPU Computing 0 2014-05-10 14:38
Disk starting to go Chuck Hardware 8 2013-05-20 06:40
Time it takes to select polynomials for 154 digits John5788 Factoring 23 2008-08-27 07:54

All times are UTC. The time now is 23:02.

Sun Jul 12 23:02:30 UTC 2020 up 109 days, 20:35, 1 user, load averages: 2.67, 2.21, 1.77

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.