mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware > GPU Computing

Reply
 
Thread Tools
Old 2017-12-22, 16:04   #1
MacFactor
 
Dec 2010

2×13 Posts
Default ERROR: cudaGetLastError() returned 4: unspecified launch failure

I've been running mfaktc on a couple of old graphics cards under Manjaro Linux for quite a while now, but I've had a lot of trouble getting it to run on Tesla GPU cards. I finally got an M2050 running under OS X 10.9.5 (recompiled using makefile.osx from dozba) to work (turned out that indicator LEDs on card turn green when connected, NOT necessarily adequately powered!) to the extent that it completed the extended test suite of more than 2800 tests without problems. I tried running the test cases provided with the README file -- even tweaked them to find three known factors in one case -- and those ran incredibly fast. Problem is, when I try to run exponents in the working range I keep getting the error message in the title. "Unspecified" indeed. There are other puzzling errors, like the same, WRONG, 95-bit factor showing up for multiple exponents:

Mx has a factor: 38814612911305349835664385407

This always prints out just before the ERROR message, but not every time.

Also, the values of kmin and kmax are not making any sense -- way too small to be the "k" in 2kp + 1, and kmin sometimes being larger than kmax.

Any ideas ? Any similar experiences ? I suspect maybe I need to recompile 32-bit for these older cards. BTW, I got no *errors* when compiling, but oodles of *warnings* -- mostly about unused functions, which seems odd. I may have a redundancy in this statement, but since I have no idea how it works, I don't know:

# Linker
LD = gcc
LDFLAGS = -fPIC $(CUDA_LIB)/libcudart.7.5.dylib -lm -rpath /Developer/NVIDIA/CUDA-7.5/lib/

The original in makefile.osx was

# Linker
LD = gcc
LDFLAGS = -fPIC $(CUDA_LIB) -lcudart -lm

I made the changes because Apple introduced something called rpaths, but I don't really understand why it doesn't seem to compile without the changes, or if some part of the changes isn't redundant.

Any help would be much appreciated; I'm going to figure out how to recompile in 32-bit mode and see what that does. Other than that, I'm out of ideas.

Last fiddled with by MacFactor on 2017-12-22 at 16:05
MacFactor is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error returned on P95 submission kladner PrimeNet 4 2017-09-30 19:49
ERROR: cudaGetLastError() returned 30: unknown error garo GPU Computing 10 2013-04-27 19:01
No Exponents returned for TF to Low Limits gjmccrac PrimeNet 14 2012-01-10 17:31
Prime fatal error on 3D launch kaeptn_kork Hardware 11 2009-03-17 01:58
Unspecified machine type schneelocke PrimeNet 14 2004-09-27 12:49

All times are UTC. The time now is 11:44.

Tue Oct 27 11:44:14 UTC 2020 up 47 days, 8:55, 0 users, load averages: 1.92, 1.75, 1.59

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.