mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware

Closed Thread
 
Thread Tools
Old 2004-05-31, 02:24   #1
Unregistered
 

22×29×67 Posts
Default amd athlon 64 bug?

i have an amd athlon 64 3400+ and for some reason under the torture test it wont stay at ~99% it goes down and hovers at oh ~5% for some reason it seems to be random. i have laptop pentium-m 1.6 running the torture test and it stays pegged at 99%. what is wrong?
 
Old 2004-05-31, 04:22   #2
Unregistered
 

10010011100002 Posts
Default

right now it seems the slowdown is specific to the 400 lucas-lehmer iterations. the 1000s went fast and used full cpu.

http://img16.imageshack.us/img16/6074/rargh.PNG

heres a picture of the program and cpu usage is that normal?? my laptop is constantly at 100% basically
 
Old 2004-05-31, 07:30   #3
sdbardwick
 
sdbardwick's Avatar
 
Aug 2002
North San Diego County

2·11·31 Posts
Default

From your screenshot it looks like a program is using all available physical RAM, and forcing Win to page active memory to disk. This means the processor spends most of its time waiting for memory accesses, so it can't be busier than 7% or so. The 10K FFT can probably execute entirely within the processor cache, so it doesn't take the hit like the 896K FFT. What program is using all of the RAM (just curious)?
sdbardwick is offline  
Old 2004-05-31, 17:17   #4
Unregistered
 

1,879 Posts
Default

if anything was using the memory it was prime95

i just restarted the computer and started a prime95 torture test

http://img17.imageshack.us/img17/5983/stats1.PNG
thats what test it was running

http://img17.imageshack.us/my.php?lo...image=proc.PNG
as soon as i start prime95 torture test the pf usage jumps to a gig and stays there till i stop it. the cpu usage hovers at ~16%

http://img17.imageshack.us/img17/8638/mem.PNG
not was using a lot of ram but prime95 had ~900MB in virtual memory for some reason

i left my laptop and athlon64 on overnight

http://img5.imageshack.us/img5/9153/laptop.PNG
laptop stats the times are consistent

http://img10.imageshack.us/img10/2419/desktop1.PNG
sort of consistent with the 4000sec abnormality then the 7500 and 22000 something went horribly wrong

the laptop did almost 15% more over night something is horribly wrong
 
Old 2004-05-31, 17:18   #5
Unregistered
 

22×3×17×23 Posts
Default

this morning i opened up taskmanager and let it collect stats from the desktop for a bit
http://img1.imageshack.us/img1/9666/desktop_stats.PNG
so it was using the cpu it just wasnt doing much or something
 
Old 2004-05-31, 17:21   #6
Unregistered
 

10111000112 Posts
Default

well i just went to download the source code thinking maybe i could find the problem and saw "highly optimized Intel assembly language" could that be the problem?
 
Old 2004-05-31, 17:34   #7
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

225528 Posts
Default

Quote:
Originally Posted by Unregistered
well i just went to download the source code thinking maybe i could find the problem and saw "highly optimized Intel assembly language" could that be the problem?
There are various code paths and switches based upon the CPU type. So it won't try to make the Ath64 follow the same work cycle as a Pentium1.
Uncwilly is online now  
Old 2004-05-31, 19:33   #8
M29
 
M29's Avatar
 
Dec 2003

16410 Posts
Default

Quote:
Originally Posted by Unregistered
well i just went to download the source code thinking maybe i could find the problem and saw "highly optimized Intel assembly language" could that be the problem?
I highly recommend Igor Arsenin's ( ) powerful system utility, TaskInfo: http://www.iarsn.com/taskinfo.html

I believe that some other process is consuming too many of your system resources, and TaskInfo will clearly show you where all of your resources have been allocated.

(Do you have a ramdisk mounted?)
M29 is offline  
Old 2004-05-31, 20:25   #9
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

22·1,873 Posts
Default

From the screenshot, it looks like an old prime95 version. Grab version 23.8. Several torture test bugs have been fixed.
Prime95 is offline  
Old 2004-05-31, 20:49   #10
Mike
 
May 2004
Vancouver, Canada

11001002 Posts
Default

Quote:
Originally Posted by Prime95
From the screenshot, it looks like an old prime95 version. Grab version 23.8. Several torture test bugs have been fixed.
It says it's 23.8 on this screenshot...

http://img17.imageshack.us/img17/5983/stats1.PNG
Mike is offline  
Old 2004-05-31, 21:16   #11
Unregistered
 

9,923 Posts
Default

i have no ram disk.

the problem seems to be on the athlon windows is putting all the memory in the page file while on the laptop it splits it 400 and 400 and i have no idea why. ive tried changing page file size on the desktop to none which causes the program to crash. i then tried system manged and 256 mb which didnt help at all. i originally had it at a min of 1.5gig and max 4gigs.
 
Closed Thread

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Athlon II 620 x4 henryzz Hardware 5 2009-10-28 03:25
Athlon 64 Benchmark(s) GSV3MiaC Hardware 4 2004-01-26 10:43
Athlon 64 ThomRuley Hardware 7 2003-09-28 13:31
Athlon vs. P4 ThomRuley Lone Mersenne Hunters 1 2003-07-11 23:15
Optimizing for Athlon?? Paulie Software 6 2002-09-13 23:01

All times are UTC. The time now is 16:48.

Sat May 15 16:48:48 UTC 2021 up 37 days, 11:29, 0 users, load averages: 1.89, 1.77, 1.86

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.