mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2005-08-19, 18:07   #1
HiddenWarrior
 
HiddenWarrior's Avatar
 
Jun 2003
Russia, Novosibirsk

D616 Posts
Default Strange bug

Not so long time ago I met a bug. I have 2 comps at home, one of which connected to internet. So, the first one is workin' damn good and every day sends stats to Primenet. Other thing with another one. It was originaly got factoring task through first one computer for 90 days and works over factorization all day long without any way out to internet. Once a week I copy it's content to the comp 1 (that has access to inet) and send work currently done to PrimeNet... Now all the hell broken lose... Online stats goes to minuses and no work that were done won't be taken. Tested expos still holds in stats as uncomplished with minuses in 'to go' section. The mystery - why is my originaly (on the first basic computer) running Prime95 send good response, and the downloaded from brothers comp other one always tries to say that server is returning error (oftenly but not all the tries)?

Strange thing, ah?

Last fiddled with by HiddenWarrior on 2005-08-19 at 18:09
HiddenWarrior is offline   Reply With Quote
Old 2005-08-19, 22:56   #2
lycorn
 
lycorn's Avatar
 
Sep 2002
Oeiras, Portugal

101011111102 Posts
Default

When you say you copy the content of computer 2 to computer 1, what do you mean exactly? Just the save files or the prime.spl, or also other files in the Prime95 directory?
Are you sure the name of the computers, or at least the user name, in the Primenet server is the same? If you have reserved the exponents under a different user name from the one you use to check results in, the server won´t accept it.
lycorn is offline   Reply With Quote
Old 2005-08-20, 03:08   #3
HiddenWarrior
 
HiddenWarrior's Avatar
 
Jun 2003
Russia, Novosibirsk

2·107 Posts
Default

Quote:
Originally Posted by lycorn
When you say you copy the content of computer 2 to computer 1, what do you mean exactly? Just the save files or the prime.spl, or also other files in the Prime95 directory?
Are you sure the name of the computers, or at least the user name, in the Primenet server is the same? If you have reserved the exponents under a different user name from the one you use to check results in, the server won´t accept it.
I copy all the folder with Prime95 (all files) from comp2 to comp1. Then I just stop my running Prime95 and shell the copied one. Prime.spl and all other files are good, but the prog sends only times when the rest expos will be finished, not any results currently done...
HiddenWarrior is offline   Reply With Quote
Old 2005-08-20, 15:01   #4
lycorn
 
lycorn's Avatar
 
Sep 2002
Oeiras, Portugal

2×19×37 Posts
Default

If you want to report work completed in computer 2, just copy prime.spl from 2 to 1. That´s what we call sometimes "sneakernet". Then force a manual communication with the server. That should work without any problem, specially because you said that all the work has been reserved through computer 1.
lycorn is offline   Reply With Quote
Old 2005-08-20, 19:28   #5
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
República de California

9,791 Posts
Default

Quote:
Originally Posted by lycorn
If you want to report work completed in computer 2, just copy prime.spl from 2 to 1. That´s what we call sometimes "sneakernet". Then force a manual communication with the server. That should work without any problem, specially because you said that all the work has been reserved through computer 1.
Should one back up the machine-1 .spl file first? If that's an issue, I suggest simply *appending* the machine-2 spl-file data to machine 1's .spl file.
ewmayer is offline   Reply With Quote
Old 2005-08-22, 08:34   #6
lycorn
 
lycorn's Avatar
 
Sep 2002
Oeiras, Portugal

57E16 Posts
Default

Well, .spl files are "volatile", in the sense that they are immediately erased by the client upon a successful communication with the server. So just start by checking whether a .spl file exists in computer 1, and if that is the case force a communication with the server before copying .spl from computer 2. That´s a clean way of avoiding problems.
lycorn is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Something strange ... bayanne Software 6 2016-04-06 04:33
Something *really* strange schickel FactorDB 7 2012-02-02 00:10
A strange applet: 3.14159 Miscellaneous Math 7 2010-06-01 01:29
A strange RSA key siew Factoring 70 2010-05-31 22:31
Strange bug with GMP-ECM MatWur-S530113 GMP-ECM 2 2007-11-19 00:01

All times are UTC. The time now is 18:57.

Mon Oct 26 18:57:29 UTC 2020 up 46 days, 16:08, 0 users, load averages: 1.82, 1.91, 2.01

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.