mersenneforum.org  

Go Back   mersenneforum.org > New To GIMPS? Start Here! > Information & Answers

Reply
 
Thread Tools
Old 2012-08-23, 21:50   #1
markdjonson
 
May 2012
Wisconsin

11 Posts
Angry 2 of 4 cores slow down significantly when I turn main monitor off

I am seeing some strange behavior when I turn my main monitor off - Prime95 threads on cores 2 and 4 slow down - per iteration times increase by 50% or more. The threads on cores 1 and 3 remain unchanged. Sometimes I have to stop the workers on 2 and 4 and restart them in order to make them resume at "normal" speeds. This is with v. 27.7 build 2 on Win7 Home Premium 64-bit, Core i7 3770S processor. Anyone have any ideas what could be causing this and how to prevent it from happening? I have Power Options set for the computer to never sleep - that's the only thing I could think of to check.
markdjonson is offline   Reply With Quote
Old 2012-08-24, 07:13   #2
aketilander
 
aketilander's Avatar
 
"Åke Tilander"
Apr 2011
Sandviken, Sweden

2×283 Posts
Default

Prime95 is at the lowest possible priority. I would guess that there are some processes which start when your computer is in "idle" state, that is main monitor turned off. So first thing I would do is to go into Task Manager and look which program/process is using your cycles, maybe an anti-virus program, maybe automatic upgrade.
aketilander is offline   Reply With Quote
Old 2012-08-24, 08:55   #3
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
Jun 2011
Thailand

23×11×97 Posts
Default

Additional to what Ake said, The "S" processors may have the particularly fancy habit to reduce the power (they are low power versions of the "K" processors) - and therefore the clock - when parts of the chips are not used. This is (partially, beside of lower default clock, etc) how they get the lower TDP. If you are using HD4000 integrated graphic to drive that monitor, you may want to look for this cause too. I may talking rubbish here (this mean take it with a big dose of skepticism) but I saw something similar long ago with a 2600S compared with a 2600K, that time I didn't care about, but now I remember it.
LaurV is offline   Reply With Quote
Old 2012-08-24, 19:18   #4
markdjonson
 
May 2012
Wisconsin

11 Posts
Default

Quote:
Originally Posted by aketilander View Post
Prime95 is at the lowest possible priority. I would guess that there are some processes which start when your computer is in "idle" state, that is main monitor turned off. So first thing I would do is to go into Task Manager and look which program/process is using your cycles, maybe an anti-virus program, maybe automatic upgrade.
Thank you for the idea - however, it's a bit tricky since I can't access Task Manager when the monitors are off. It seems to resolve itself when the main monitor is turned back on, and AFAIK there is no way in Task Manager to log status of CPU usage.
markdjonson is offline   Reply With Quote
Old 2012-08-24, 19:32   #5
markdjonson
 
May 2012
Wisconsin

11 Posts
Default

Quote:
Originally Posted by LaurV View Post
...If you are using HD4000 integrated graphic to drive that monitor, you may want to look for this cause too. I may talking rubbish here (this mean take it with a big dose of skepticism) but I saw something similar long ago with a 2600S compared with a 2600K, that time I didn't care about, but now I remember it.
Thank you for your input. I was using discrete graphics (HD 7750) when I first noticed this problem. Now I have switched to integrated graphics to see what would happen. Now only one core (core 2) is affected, but the effect is far worse on that core (upwards of .5 sec per iteration time as opposed to "normal" of .027. With discrete graphics I was seeing something like .037 on core 2 and .045 on core 4. So I will switch back to HD 7750 now.
markdjonson is offline   Reply With Quote
Old 2012-08-24, 21:03   #6
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

23·73 Posts
Default

Do you have a screensaver? Switch to "Blank Screen".
garo is online now   Reply With Quote
Old 2012-08-24, 23:27   #7
markdjonson
 
May 2012
Wisconsin

10112 Posts
Angry

Quote:
Originally Posted by garo View Post
Do you have a screensaver? Switch to "Blank Screen".
No, haven't seen the need for that for a long time now. Just to be clear, I only see this when I switch the last monitor off, not when the monitors go into standby mode. I guess I should test that, too, just to see what happens.

I have switched back to the HD 7750 discrete graphics now, and now it is worker 3 (only) that is exhibiting this behavior. I tried moving the Task Manager window and the Prime 95 window to the secondary monitor and then switching off the primary monitor while leaving the second monitor on. However, the slowdown only occurs when both monitors are switched off, so it looks like Task Manager will not help in diagnosing this.
markdjonson is offline   Reply With Quote
Old 2012-08-24, 23:32   #8
fivemack
(loop (#_fork))
 
fivemack's Avatar
 
Feb 2006
Cambridge, England

18CC16 Posts
Default

Could you try opening a console window, typing 'tasklist /v' to get the list of running tasks, then turning the monitors off and pressing up-arrow return to get the list of running tasks with the monitors off? See if any new task starts up when the last monitor goes off.
fivemack is offline   Reply With Quote
Old 2012-08-26, 01:18   #9
markdjonson
 
May 2012
Wisconsin

11 Posts
Smile 2 of 4 cores slow down significantly when I turn main monitor off - SOLVED

Quote:
Originally Posted by fivemack View Post
Could you try opening a console window, typing 'tasklist /v' to get the list of running tasks, then turning the monitors off and pressing up-arrow return to get the list of running tasks with the monitors off? See if any new task starts up when the last monitor goes off.
Thank you for this suggestion - it worked perfectly. The culprit was Windows Indexing (SearchIndexer.exe in the task list). So once the initial index is built, it should return to normal.
markdjonson is offline   Reply With Quote
Old 2012-12-31, 15:34   #10
Unregistered
 

26·113 Posts
Default drive indexing

fyi: since you said you have a 3xxx intel processor you may have a Solid State Drive.

If you do have a SSD you should turn off drive indexing all together to increase drive life with no performance decrease.
  Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off GCC sse-using optimizations? ewmayer Programming 3 2016-09-30 07:15
USB Monitor TheMawn Information & Answers 3 2015-02-09 15:40
MPrime Significantly Faster than P95 Dubslow Software 8 2011-12-06 15:44
Is mprime significantly slower than Prime95? abcd Linux 9 2007-08-31 14:26
One monitor for the whole farm ThomRuley Hardware 14 2003-08-03 06:12

All times are UTC. The time now is 18:37.

Thu May 28 18:37:22 UTC 2020 up 64 days, 16:10, 0 users, load averages: 2.02, 1.67, 1.50

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.