mersenneforum.org  

Go Back   mersenneforum.org > New To GIMPS? Start Here! > Information & Answers

Reply
 
Thread Tools
Old 2005-10-19, 10:33   #1
ppo
 
ppo's Avatar
 
Aug 2004
italy

113 Posts
Default running two copies of prime95 in the same machine

I am currently running two copies of Prime95 in one PentiumIV machine , one for LL and the second one for TF, or both for TF.
What I did was to copy all prime95 folder into a new one, changing nothing,
then I pulled some TF exponent from the first worktodo.ini into the second.
The problem is that when a TF is complete the server accepts such information, but the exponent remains assigned to me, and never goes in the cleared list.
It seems that the server get confused by having two copies with the same computer name. What am I doing wrong ?
ppo is offline   Reply With Quote
Old 2005-10-19, 13:16   #2
Cruelty
 
Cruelty's Avatar
 
May 2005

2·809 Posts
Default

You should change your name for the second instance of Prime95 - every instance is treated as a separate computer so you should not assign the same name to them...
Cruelty is offline   Reply With Quote
Old 2005-10-19, 15:14   #3
ppo
 
ppo's Avatar
 
Aug 2004
italy

113 Posts
Default

Quote:
Originally Posted by Cruelty
You should change your name for the second instance of Prime95 - every instance is treated as a separate computer so you should not assign the same name to them...
how silly of me.... Thanks a lot
ppo is offline   Reply With Quote
Old 2005-10-19, 20:54   #4
endless mike
 
endless mike's Avatar
 
Jan 2004
Milwaukee, WI

32×17 Posts
Default

You could have, instead of making a new directory, opened up a command prompt, cd into your prime95 directory, and started a second instance with the -A1 switch.

eg
cd \Program Files\Prime95 <return>
Prime95 -A1 <return>

Doing so will start a new instance of Prime95, which you then put in all your information just like a new install. If you turn on the start at bootup option in both instances of Prime95, both will automatically start whenever you restart your computer.

I don't know if setting the affinity is necessary with hyperthreaded machines, but it might also be worth a try.

This is what I have done on my dual processor box, and on my hyperthreaded boxes.

Last fiddled with by endless mike on 2005-10-19 at 21:01 Reason: looks like the A should be A instead of a
endless mike is online now   Reply With Quote
Old 2005-10-20, 08:03   #5
ppo
 
ppo's Avatar
 
Aug 2004
italy

113 Posts
Default

Quote:
Originally Posted by endless mike

I don't know if setting the affinity is necessary with hyperthreaded machines, but it might also be worth a try.
I tried a little using affinity, but I did not notice a real difference.

I am looking for tips on how to quicky evaluate throughput gain for the case LL-TF

shall I also try a P-1 test togheter with TF ?

Last fiddled with by ppo on 2005-10-20 at 08:09
ppo is offline   Reply With Quote
Old 2005-10-25, 16:29   #6
ppo
 
ppo's Avatar
 
Aug 2004
italy

113 Posts
Default

I did some quick raw timing to evaluate throughput, not very accurate, and it seems to me that two TF are better than 1 TF and 1 LL. Is that reasonable or am I too much off track ? My computer is a P4, 512 Mb in only 1 bank, 2.8 MHz.

Last fiddled with by ppo on 2005-10-25 at 16:30
ppo is offline   Reply With Quote
Old 2005-11-24, 15:41   #7
Unregistered
 

24·3·127 Posts
Default using dual core cpus

Can you run two copies of Prime on a dual core machine and actually get twice the work done?

I noticed in the benchmark section that the athalon X2 processors are not twice as fast as single core.
  Reply With Quote
Old 2006-01-20, 00:24   #8
Drooling_Sheep
 
Aug 2003

2×3 Posts
Default Installing 2 Copies of Prime95?

I recently upgraded to an Athlon 64 X2 4400+ and I'm trying to use both cores for Prime95, but when I run the install program again, it just asks me if I want to install the copy that's already there and doesn't permit me to install a second one. Is there a way around this?
Drooling_Sheep is offline   Reply With Quote
Old 2006-01-20, 00:38   #9
Unregistered
 

33·132 Posts
Default

Quote:
Originally Posted by Drooling_Sheep
I recently upgraded to an Athlon 64 X2 4400+ and I'm trying to use both cores for Prime95, but when I run the install program again, it just asks me if I want to install the copy that's already there and doesn't permit me to install a second one. Is there a way around this?
Sure. The extra copy has to be installed in a new directory- create one, and copy and paste the Prime95.exe file into it. No need to run the installer again.

Be sure to set the afinity settings- one copy for CPU 0 and one for CPU 1. (Under the Advanced Menu= password 9876)
  Reply With Quote
Old 2006-01-20, 00:38   #10
thechickenman
 
thechickenman's Avatar
 
Nov 2005
South Carolina

7×11 Posts
Default

Quote:
Originally Posted by Unregistered
Sure. The extra copy has to be installed in a new directory- create one, and copy and paste the Prime95.exe file into it. No need to run the installer again.

Be sure to set the afinity settings- one copy for CPU 0 and one for CPU 1. (Under the Advanced Menu= password 9876)
Now, why did I show up as unregistered? Strange.
thechickenman is offline   Reply With Quote
Old 2006-01-20, 01:26   #11
endless mike
 
endless mike's Avatar
 
Jan 2004
Milwaukee, WI

9916 Posts
Default

You could have, instead of making a new directory, opened up a command prompt, cd into your prime95 directory, and started a second instance with the -A1 switch.

eg
cd \Program Files\Prime95 <return>
Prime95 -A1 <return>

Doing so will start a new instance of Prime95, which you then put in all your information just like a new install. If you turn on the start at bootup option in both instances of Prime95, both will automatically start whenever you restart your computer.

This is what I have done on my dual processor box.
endless mike is online now   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running a Windows machine at the end of a wire fivemack Programming 2 2015-06-30 18:02
running gimps on a virtual machine sixblueboxes Hardware 2 2013-03-31 22:14
mfaktO and mfaktC running on same machine. Proof! swl551 GPU Computing 2 2012-08-19 13:37
Running multiple copies of mprime on Linux hc_grove Software 3 2004-10-10 15:34
Prime95 takes over machine???!!! kwstone Software 4 2003-08-10 22:46

All times are UTC. The time now is 09:34.

Sat Sep 19 09:34:14 UTC 2020 up 9 days, 6:45, 0 users, load averages: 1.59, 1.83, 1.77

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.