mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware

Reply
 
Thread Tools
Old 2020-11-04, 07:02   #1
jiangv
 
Jul 2019

2·7 Posts
Default unnormal temp readings from linux when running p95

Hi

I was running p95 on linux centos 7.6, my pc build on 10900k + z490 board, when I install win10 and running p95 for stress testing, second option, maximum temp test, the highest core temp I saw is about 73 degrees, which seems fine.

once I switch to linux, with the same hardware config and bios config, running the same tests, the highest core temp only reach to 62 degreed, I checked cpu usage, it was running 100% and everything seems ok.

so I was wondering, what could be the problem?
jiangv is offline   Reply With Quote
Old 2020-11-04, 08:59   #2
Viliam Furik
 
"Viliam Furík"
Jul 2018
Martin, Slovakia

3·151 Posts
Default

Quote:
Originally Posted by jiangv View Post
...so I was wondering, what could be the problem?
Your Intel 14nm+++... oven (10900K) is running 11 degrees cooler and you call that a problem? Wow. I would say it's more of a good thing, maybe even a miracle.
Viliam Furik is online now   Reply With Quote
Old 2020-11-04, 09:05   #3
retina
Undefined
 
retina's Avatar
 
"The unspeakable one"
Jun 2006
My evil lair

22·5·307 Posts
Default

Quote:
Originally Posted by jiangv View Post
so I was wondering, what could be the problem?
Linux isn't as good as Windows at scheduling threads. Unless you are keen to try different schedulers in Linux then there isn't much you can do.

However, if you do try a bunch of different schedulers please let us know which works the best with P95.
retina is online now   Reply With Quote
Old 2020-11-04, 10:32   #4
kruoli
 
kruoli's Avatar
 
"Oliver"
Sep 2017
Porta Westfalica, DE

49410 Posts
Default

Quote:
Originally Posted by retina View Post
Unless you are keen to try different schedulers in Linux then there isn't much you can do.
I do not recall having such a massive delta between Linux and Windows. Especially, since Prime95 resp. mprime sets it affinity to specific cores, so there should not be so much difference.

Quote:
Originally Posted by Viliam Furik View Post
Your Intel 14nm+++... oven (10900K) is running 11 degrees cooler and you call that a problem? Wow. I would say it's more of a good thing, maybe even a miracle.
It's the same chip, so that should not happen, normally. If anything is.

Quote:
Originally Posted by jiangv View Post
Hi [...]
Would you mind doing a benchmark?
kruoli is online now   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows running Linux Cuda ? tServo GPU Computing 31 2020-05-25 16:44
Running LLR on GPU (linux)? carpetpool Information & Answers 1 2019-05-18 22:48
problem running 64-bit Linux version ssybesma Linux 26 2019-04-11 04:32
Running octoproth program in Linux jasong Octoproth Search 9 2007-12-27 02:44
running linux version Unregistered Information & Answers 1 2007-09-08 17:59

All times are UTC. The time now is 14:24.

Fri May 7 14:24:33 UTC 2021 up 29 days, 9:05, 0 users, load averages: 3.42, 3.62, 3.24

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.