mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2011-05-19, 00:49   #1
Freightyard
 
Nov 2008
San Luis Obispo CA

8016 Posts
Default Limit/throttle CPU usage (110% is too much!)

How to limit CPU % usage?

After running ntprime64 for a few years, I've only run into a couple conflicts with other software. Photoshop CS4/5 is one; I have to stop the ntprime service to use Photoshop. Maybe this is a low priority background service that Adobe added... who knows...

NOW, I've hit a wall with Win2K8 Server running IIS. I realized recently that IIS was not compressing the web pages it serves (everything was being served uncompressed).

After some investigation, I realized the IIS configuration TURNS OFF compression when CPU utilization is above 90%. Theoretically, this prevents compression from stealing CPU cycles when the machine is very busy.

Even though ntprime/prime95 runs at lowest priority, it still ALWAYS pins the CPU utilization to 100%. Thus, IIS compression never kicks-in.

Looking for suggestions...

Options I know of:

(1) Disable ntprime on one or more cores (dual quad-core Xeon).
(2) Stop using ntprime altogether.

The machine in question is a production web server (mine). It serves a couple dozen web sites and runs SQL as well. I pay colo fees for power whether I use it or not--so why not use it?

FEATURE REQUEST IDEA??? -- Setting to cause prime95 to "give up" some CPU time?
Freightyard is offline   Reply With Quote
Old 2011-05-19, 03:36   #2
gjmccrac
 
gjmccrac's Avatar
 
Aug 2009
Ontario, Canada

131 Posts
Default

See Throttle in undoc.txt

You would put

Throttle=90

in Prime.txt

This will use only 90% of the CPU.
gjmccrac is offline   Reply With Quote
Old 2011-05-19, 19:01   #3
Freightyard
 
Nov 2008
San Luis Obispo CA

12810 Posts
Default "Throttle" option FAILS

Thanks! However, it appears the "Throttle" option is a giant FAIL for my predicament.

The CPU graph, below, indicates Throttle=100, 85 and 50. As you can see, Throttle does not limit CPU utilization--instead, Throttle performs duty cycling.

The only option it appears I have is to reduce the number of worker processes. Other thoughts?

Click image for larger version

Name:	gimps-throttle.png
Views:	626
Size:	28.7 KB
ID:	6615
Freightyard is offline   Reply With Quote
Old 2011-05-19, 20:18   #4
Freightyard
 
Nov 2008
San Luis Obispo CA

8016 Posts
Default

The best solution I could come up with was to eliminate two worker processes. I'm hoping I removed one from each CPU (dual quad-core) to spread the load out, but I'm not certain exactly how the logical cores and physical cores map to each other.

My present CPU utilization (75%) looks like this:

Click image for larger version

Name:	gimps-cpu6.png
Views:	273
Size:	18.6 KB
ID:	6616
Freightyard is offline   Reply With Quote
Old 2011-05-21, 18:32   #5
lavalamp
 
lavalamp's Avatar
 
Oct 2007
Manchester, UK

25228 Posts
Default

If you only need to be below 90%, then you could put one worker process back on and use 7 out of 8 cores, 7/8 * 100 = 87.5%.

Alternatively, could you not change the value for dynamicCompressionDisableCpuUsage from the default 90 to some other value (like 100)? Or perhaps a value of 101 or -1 would prevent it from ever disabling compression. You may also need to tweak dynamicCompressionEnableCpuUsage.

Last fiddled with by lavalamp on 2011-05-21 at 18:41
lavalamp is offline   Reply With Quote
Old 2011-05-25, 12:37   #6
lorgix
 
lorgix's Avatar
 
Sep 2010
Scandinavia

61510 Posts
Default

Quote:
Originally Posted by Freightyard View Post
Thanks! However, it appears the "Throttle" option is a giant FAIL for my predicament.

The CPU graph, below, indicates Throttle=100, 85 and 50. As you can see, Throttle does not limit CPU utilization--instead, Throttle performs duty cycling.

...

Other thoughts?
I guess it should depend on how IIS determines CPU utilization, and how long the cycles are.

Anyone know about those things?
lorgix is offline   Reply With Quote
Old 2011-05-26, 00:42   #7
Christenson
 
Christenson's Avatar
 
Dec 2010
Monticello

5×359 Posts
Default

It's windows....which is the first problem....
Christenson is offline   Reply With Quote
Old 2011-07-05, 05:44   #8
imwithid
 
imwithid's Avatar
 
Apr 2009
Venice, Chased by Jaws

1278 Posts
Default

In an odd way, this thread has helped bring back to life my laptop. I throttled it to 75% so far which has fooled my oven (an HP DV4) to run the fan at full speed (without having to install supplementary fan control software); now it doesn't get as hot and some extra work gets done.

@ Freightyard re:Christenson

I think he's right.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-System Monitor.png
Views:	418
Size:	61.2 KB
ID:	6784  
imwithid is offline   Reply With Quote
Old 2011-07-05, 15:57   #9
Xyzzy
 
Xyzzy's Avatar
 
Aug 2002

2×3×5×277 Posts
Default

http://www.mersenneforum.org/showthread.php?t=12286
Xyzzy is offline   Reply With Quote
Old 2011-07-06, 05:01   #10
imwithid
 
imwithid's Avatar
 
Apr 2009
Venice, Chased by Jaws

10101112 Posts
Default

Quote:
Originally Posted by Xyzzy View Post
Thanks for clarifying, Xyzzy.
imwithid is offline   Reply With Quote
Old 2011-10-05, 15:41   #11
kladner
 
kladner's Avatar
 
"Kieren"
Jul 2011
In My Own Galaxy!

236568 Posts
Default

Quote:
Originally Posted by Freightyard View Post
How to limit CPU % usage?

After running ntprime64 for a few years, I've only run into a couple conflicts with other software. Photoshop CS4/5 is one; I have to stop the ntprime service to use Photoshop. Maybe this is a low priority background service that Adobe added... who knows...
Just to add my 2 cents to this well-aged thread.....

Until yesterday, I had been running with the onboard ATI graphics on an Asus M4A89GTD Pro/USB3 board, PhenomII 1090T, 8GB RAM, etc. I had not encountered the problem mentioned above with PS CS5 in Win7 Pro (edit) 64bit.

Yesterday, I got a Gigabyte GV-N460OC-1GI graphics card, put it in, and disabled the onboard video, uninstalled the driver, etc. Now, with Prime64 running, Photoshop acts really crippled, taking forever to open a file, and even to fully draw the window elements such as borders. This doesn't happen if P64 is stopped. This is with version 26.6.

I have not yet experimented with throttling, though I will. If it resolves the issue I'd rather go that route than shutting P64 off on one core. So far, I have just stopped P64 before starting Photoshop.

I'll post again when I have more to report.

EDIT: I just saw the thread which points out the "PauseWhileRunning=" line for Prime.txt. This seems to be the best solution overall.

Last fiddled with by kladner on 2011-10-05 at 16:11 Reason: Found more info on this issue.
kladner is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Throttle questions lukerichards Software 7 2018-01-16 00:17
How to tell prime95 to throttle down cpu consuming snoopy78 Software 12 2016-12-03 10:16
Prime95 throttle? SkiDragon Software 10 2009-11-08 03:03
Throttle feature request? Xyzzy Software 1 2009-08-16 00:47
P4 Temperature Throttle Axel Fox Software 4 2003-06-25 18:55

All times are UTC. The time now is 06:36.


Thu Oct 21 06:36:40 UTC 2021 up 90 days, 1:05, 1 user, load averages: 1.36, 1.16, 1.05

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.