mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2018-12-28, 05:11   #45
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3·1,087 Posts
Default

Doing a reboot of the server soon - updating the backup software, so that's important.

It's 2018-12-28 @ 5:11 AM with an expected downtime ~ 15 minutes.

EDIT: Back online. Okay, it was more like 18 minutes.

Last fiddled with by Madpoo on 2018-12-28 at 05:29
Madpoo is offline   Reply With Quote
Old 2019-02-04, 03:09   #46
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

62758 Posts
Default Maintenance scheduled - 2019-02-04 @ 03:15 (UTC)

I'm going to go ahead and do some updates on the Primenet server:
2019-02-04 @ 03:15 (UTC)

I noticed a funny period of SQL queries taking long and even though it's stabilized (and only lasted a few minutes about 30 hours ago) I wanted to go ahead and update things.

I'm only doing SQL updates so the downtime should be minimal, ~ 5 minutes.

EDIT: yup, it was about 5 minutes, all done.

Last fiddled with by Madpoo on 2019-02-04 at 03:21
Madpoo is offline   Reply With Quote
Old 2019-03-24, 05:48   #47
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3×1,087 Posts
Default Maintenance about to start

I'm about to do some updating on the server.

It'll be down probably 30 minutes, and I'm starting at 05:50 UTC on 2019-03-24

EDIT: All done

Last fiddled with by Madpoo on 2019-03-24 at 06:32
Madpoo is offline   Reply With Quote
Old 2019-04-20, 16:44   #48
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3×1,087 Posts
Default Maintenance - 2019-04-20 @ 16:40 UTC

I'm taking the server offline for a few minutes for some SQL related maintenance.

I could have done it offline but I'm altering some tables that would make it slow and non-responsive anyway which would only be more frustrating for people.

I expect it to finish in a few more minutes.

EDIT: Back in action. Took longer to update that pesky table than I had hoped... probably would have been faster to drop the indices, alter it, then recreate indices. Oh well. All done.

Last fiddled with by Madpoo on 2019-04-20 at 17:10
Madpoo is offline   Reply With Quote
Old 2019-04-21, 06:58   #49
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3·1,087 Posts
Default More SQL maintenance - 2019-04-21 @ 06:55 UTC

There is more SQL maintenance happening right now. At least this time I waited until later in the evening in the US.

Working on some tables, dropping and adding columns. It affects web visits so I disabled the web service while the work is happening.

ETA about 25 minutes

EDIT: Back online - didn't take as long as I thought.

Last fiddled with by Madpoo on 2019-04-21 at 07:16
Madpoo is offline   Reply With Quote
Old 2019-05-15, 18:04   #50
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

62758 Posts
Default May 2019 maintenance

I'm going to be taking the server offline for a brief period to do some routine maintenance.

I expect to start @ 18:10 UTC (2019-05-15) and it should be ~ 20 minutes (it's now 18:05 UTC, so yeah... 5 minutes from now)

UPDATE: It finished a little ahead of time (by a few minutes). Good to go.

Last fiddled with by Madpoo on 2019-05-15 at 18:38
Madpoo is offline   Reply With Quote
Old 2019-05-15, 22:24   #51
kriesel
 
kriesel's Avatar
 
"TF79LL86GIMPS96gpu17"
Mar 2017
US midwest

43·89 Posts
Default Is this what happens during server maintenance?

In response to <link removed by LaurV>

I got a null page (no assignments, no error message)
Or maybe it relates to my slow but unreliable DSL.
Attached Thumbnails
Click image for larger version

Name:	null assignment returned.png
Views:	45
Size:	46.8 KB
ID:	20352  

Last fiddled with by LaurV on 2019-05-20 at 03:11 Reason: remove link
kriesel is offline   Reply With Quote
Old 2019-05-18, 16:41   #52
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3·1,087 Posts
Default

Quote:
Originally Posted by kriesel View Post
In response to <url removed>

I got a null page (no assignments, no error message)
Or maybe it relates to my slow but unreliable DSL.
It worked for me (for anyone clicking on that original link, just note that you will get an assignment as a result).
Madpoo is offline   Reply With Quote
Old 2019-05-20, 03:15   #53
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
Jun 2011
Thailand

32×13×73 Posts
Default

Worked for me too. I got an assignment (91338227) which I am going to work on. I removed the link from original post however. Curious people will click on it, and this seems to me a way to trick people in getting unwanted assignments, which they will not work, and will stay there and clutter the DB.

(No, it didn't trick me, because I read Madpoo's post first, before clicking, and I needed one new assignment, but it would for sure do trick me, if not for Madpoo's post, because I am a curious monkey!)

Last fiddled with by LaurV on 2019-05-20 at 03:18 Reason: spacing
LaurV is online now   Reply With Quote
Old 2019-05-20, 14:16   #54
kriesel
 
kriesel's Avatar
 
"TF79LL86GIMPS96gpu17"
Mar 2017
US midwest

43·89 Posts
Default

No trick intended. The point was, I went for a manual assignment, and instead of it working as usual, returning one or more assignments with aid(s), it returned an incomplete page as shown in the attached screen capture image, which might have been due to the maintenance going on at the time. It worked for me before that, and after that. It's not at all surprising that it would work days after the maintenance was completed; that is the intended result of maintenance!

Last fiddled with by kriesel on 2019-05-20 at 14:17
kriesel is offline   Reply With Quote
Old 2019-05-21, 04:14   #55
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

3×1,087 Posts
Default

Quote:
Originally Posted by kriesel View Post
No trick intended. The point was, I went for a manual assignment, and instead of it working as usual, returning one or more assignments with aid(s), it returned an incomplete page as shown in the attached screen capture image, which might have been due to the maintenance going on at the time. It worked for me before that, and after that. It's not at all surprising that it would work days after the maintenance was completed; that is the intended result of maintenance!
Just a little behind-the-scenes...

When I'm going to do any maintenance like installing the Microsoft patches, my first step is to stop the web services before installing anything. There's usually a very good chance the patches are going to stop/start web services, especially when doing .NET framework stuff, so I just avoid it and stop it altogether.

I suppose if the timing is just right, I could stop the web services and something that was "in progress" could get killed off prematurely.

Typically though, when you stop the web server, it lets any outstanding requests complete first. The only time it would kill anything is if it took longer than the timeout period to complete (something like 30 seconds... I forget). I don't always pay attention to how long it takes to stop, but it's entirely possible.
Madpoo is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
OFFICIAL "SERVER PROBLEMS" THREAD ewmayer PrimeNet 1838 2020-05-22 06:45
Official AVX-512 programming thread ewmayer Programming 31 2016-10-14 05:49
Primenet maintenance announcements Madpoo PrimeNet 7 2015-11-12 05:50
Official Peeved Pets Thread Prime95 Lounge 32 2015-10-02 04:17
Server maintenance thread Madpoo PrimeNet 9 2015-07-25 07:47

All times are UTC. The time now is 15:38.

Tue Jun 2 15:38:45 UTC 2020 up 69 days, 13:11, 4 users, load averages: 1.84, 2.22, 2.15

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.