mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet > GPU to 72

Reply
 
Thread Tools
Old 2021-10-19, 00:45   #23
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

101001001011002 Posts
Default

Quote:
Originally Posted by firejuggler View Post
This is what I get atm
Shoot... Sorry... Fixed.
chalsall is online now   Reply With Quote
Old 2021-10-19, 00:46   #24
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

1054010 Posts
Default

Quote:
Originally Posted by RichD View Post
I am getting the same assignment over and over again at startup.
Hmmm... Not sure why the system didn't see you complete this. But I've manually set the records to be correct.

Please let me know if you see this again.
chalsall is online now   Reply With Quote
Old 2021-10-19, 02:12   #25
RichD
 
RichD's Avatar
 
Sep 2008
Kansas

1110000010002 Posts
Default

Quote:
Originally Posted by chalsall View Post
Hmmm... Not sure why the system didn't see you complete this. But I've manually set the records to be correct.
Perhaps the "unsuccessful" reporting doesn't clear it but why did the first success not clear it ???

Since my instances are getting shorter and shorter, I am restarting many of them per day. Reported on the 13th but first noticed on the 18th. Oh well, it's corrected.
RichD is offline   Reply With Quote
Old 2022-05-29, 15:13   #26
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
"name field"
Jun 2011
Thailand

997310 Posts
Default

This is on Colab, A100 getting wasted for a while looping forever like shown below.

I get this card once or twice per month, and when I want to try it, it doesn't work... Grrr...

Advice?


(edit: V100 and P100 and T4 work fine!)



Code:
> ./mfaktc
 mfaktc v0.21 (64bit built)

Compiletime options
  THREADS_PER_BLOCK         256
  SIEVE_SIZE_LIMIT          32kiB
  SIEVE_SIZE                193154bits
  SIEVE_SPLIT               250
  MORE_CLASSES              enabled

Runtime options
  SievePrimes               200000
  SievePrimesAdjust         1
  SievePrimesMin            5000
WARNING: Cannot read SievePrimesMax from mfaktc.ini, using max value (200000)
  SievePrimesMax            200000
  NumStreams                10
  CPUStreams                5
  GridSize                  3
  GPU Sieving               enabled
  GPUSievePrimes            82486
  GPUSieveSize              64Mi bits
  GPUSieveProcessSize       16Ki bits
  Checkpoints               enabled
  CheckpointDelay           60s
  WorkFileAddDelay          30s
  Stages                    enabled
  StopAfterFactor           class
  PrintMode                 full
  V5UserID                  (none)
  ComputerID                (none)
  AllowSleep                no
  TimeStampInResults        no

CUDA version info
  binary compiled for CUDA  10.0
  CUDA runtime version      10.0
  CUDA driver version       11.20

CUDA device info
  name                      A100-SXM4-40GB
  compute capability        8.0
  max threads per block     1024
  max shared memory per MP  167936 byte
  number of multiprocessors 108
  clock rate (CUDA cores)   1410MHz
  memory clock rate:        1215MHz
  memory bus width:         5120 bit

Automatic parameters
  threads per grid          884736
  GPUSievePrimes (adjusted) 82486
  GPUsieve minimum exponent 1055144

running a simple selftest...
 ERROR: cudaGetLastError() returned 48: no kernel image is available for execution on the device

Last fiddled with by LaurV on 2022-05-29 at 15:20
LaurV is offline   Reply With Quote
Old 2022-05-29, 16:39   #27
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

22×5×17×31 Posts
Default

Hmmm... OK, clearly this is a case where the distributed mfaktc executable wasn't compiled with the correct kernel.

Any suggestions from anyone as to what flags I should recompile with? Because Google doesn't consider Barbados a worthwhile market, I can't even buy the Colab Pro service to test with.

While I'm writing though... For the last couple of weeks, I have been getting nothing *BUT* T4s! For ~ 3.5 hours per day.
chalsall is online now   Reply With Quote
Old 2022-05-29, 17:00   #28
slandrum
 
Jan 2021
California

1A616 Posts
Default

Yes, lately the free accounts have been getting nothing but T4's for the last week or so. If you are averaging 3.5 hours/day consider that good - right now I'm averaging about 2.5 hours/day/gpu session.
slandrum is offline   Reply With Quote
Old 2022-05-29, 20:23   #29
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

296F16 Posts
Default

Quote:
Originally Posted by chalsall View Post
While I'm writing though... For the last couple of weeks, I have been getting nothing *BUT* T4s! For ~ 3.5 hours per day.
Quote:
Originally Posted by slandrum View Post
right now I'm averaging about 2.5 hours/day/gpu session.
On my the account associated with my phone I am getting ~3.5. On the other account I use it has been about 2:40.
Uncwilly is online now   Reply With Quote
Old 2022-05-30, 11:52   #30
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
"name field"
Jun 2011
Thailand

9,973 Posts
Default

OK, so, does anybody have a mfaktc compiled for linux, that works with A100? I may try an adaptation for it outside of Chris' box, and if it works, we see later how we can integrate it.
LaurV is offline   Reply With Quote
Old 2022-05-30, 14:25   #31
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

22×5×17×31 Posts
Default

Quote:
Originally Posted by LaurV View Post
OK, so, does anybody have a mfaktc compiled for linux, that works with A100? I may try an adaptation for it outside of Chris' box, and if it works, we see later how we can integrate it.
Thanks; that would be great. Either an executable (from a trusted player here) or even just the compiler flags which works with all the current Colab GPU types.
chalsall is online now   Reply With Quote
Old 2022-05-30, 15:52   #32
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
"name field"
Jun 2011
Thailand

9,973 Posts
Default

I PM-ed Oliver, I know he plays A100, but don't know if he plays linux.. for sure he is too busy to read all threads here.

Last fiddled with by LaurV on 2022-05-30 at 15:53
LaurV is offline   Reply With Quote
Old 2022-05-30, 21:27   #33
TheJudger
 
TheJudger's Avatar
 
"Oliver"
Mar 2005
Germany

23×139 Posts
Default

Hi,

do you have CUDA toolkit 11.x installed on that system? If so just grab the code, perhaps adjust some pathes in the makefile and run make. That is the prefered way.

Oliver

P.S. this isn't specific to A100 cards, every Ampere card needs a CUDA 11 compiled binary of mfaktc.
TheJudger is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Colab question David703 GPU to 72 299 2022-03-15 19:29
Revisiting msieve GPU with Colab EdH Msieve 4 2020-08-24 02:22
GPU72 + Colab multiple assignments windowfrog GPU to 72 2 2020-07-07 19:47
Alternatives to Google Colab kriesel Cloud Computing 11 2020-01-14 18:45
AVX2 Troubles with Colab Instance EdH YAFU 5 2019-11-12 01:49

All times are UTC. The time now is 20:42.


Thu Jun 30 20:42:58 UTC 2022 up 77 days, 18:44, 0 users, load averages: 1.82, 1.42, 1.39

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.

≠ ± ∓ ÷ × · − √ ‰ ⊗ ⊕ ⊖ ⊘ ⊙ ≤ ≥ ≦ ≧ ≨ ≩ ≺ ≻ ≼ ≽ ⊏ ⊐ ⊑ ⊒ ² ³ °
∠ ∟ ° ≅ ~ ‖ ⟂ ⫛
≡ ≜ ≈ ∝ ∞ ≪ ≫ ⌊⌋ ⌈⌉ ∘ ∏ ∐ ∑ ∧ ∨ ∩ ∪ ⨀ ⊕ ⊗ 𝖕 𝖖 𝖗 ⊲ ⊳
∅ ∖ ∁ ↦ ↣ ∩ ∪ ⊆ ⊂ ⊄ ⊊ ⊇ ⊃ ⊅ ⊋ ⊖ ∈ ∉ ∋ ∌ ℕ ℤ ℚ ℝ ℂ ℵ ℶ ℷ ℸ 𝓟
¬ ∨ ∧ ⊕ → ← ⇒ ⇐ ⇔ ∀ ∃ ∄ ∴ ∵ ⊤ ⊥ ⊢ ⊨ ⫤ ⊣ … ⋯ ⋮ ⋰ ⋱
∫ ∬ ∭ ∮ ∯ ∰ ∇ ∆ δ ∂ ℱ ℒ ℓ
𝛢𝛼 𝛣𝛽 𝛤𝛾 𝛥𝛿 𝛦𝜀𝜖 𝛧𝜁 𝛨𝜂 𝛩𝜃𝜗 𝛪𝜄 𝛫𝜅 𝛬𝜆 𝛭𝜇 𝛮𝜈 𝛯𝜉 𝛰𝜊 𝛱𝜋 𝛲𝜌 𝛴𝜎𝜍 𝛵𝜏 𝛶𝜐 𝛷𝜙𝜑 𝛸𝜒 𝛹𝜓 𝛺𝜔