mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware > Cloud Computing

Reply
 
Thread Tools
Old 2020-04-08, 14:55   #12
kuratkull
 
kuratkull's Avatar
 
Mar 2007
Estonia

2·67 Posts
Default

Quote:
Originally Posted by linament View Post
For the first time, I received this message on Colab when attempting to run without a GPU: "Sorry, no backends available. Please try again later."

Just happened to both of my accounts. Got backends again a short time later.

Last fiddled with by kuratkull on 2020-04-08 at 15:08 Reason: add quote
kuratkull is offline   Reply With Quote
Old 2020-04-08, 14:57   #13
PhilF
 
PhilF's Avatar
 
Feb 2005
Colorado

46910 Posts
Default

Quote:
Originally Posted by linament View Post
For the first time, I received this message on Colab when attempting to run without a GPU: "Sorry, no backends available. Please try again later."
I had 2 CPU only sessions running which ended early. I think they are in the middle of making changes.
PhilF is offline   Reply With Quote
Old 2020-04-12, 16:23   #14
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

10E016 Posts
Default

Quote:
Originally Posted by linament View Post
For the first time, I received this message on Colab when attempting to run without a GPU: "Sorry, no backends available. Please try again later."
Same for me for the last few days.
petrw1 is offline   Reply With Quote
Old 2020-04-12, 16:45   #15
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

52·192 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Same for me for the last few days.
Hmmm... I have /never/ not received a CPU. And the daily GPU allotment has been running for ten hours more often than seven the last couple of days.
chalsall is online now   Reply With Quote
Old 2020-04-13, 00:36   #16
Chuck
 
Chuck's Avatar
 
May 2011
Orange Park, FL

83610 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Same for me for the last few days.
Did you try the trick of changing the runtime type to TPU and attempting restart?
Chuck is offline   Reply With Quote
Old 2020-04-13, 06:32   #17
kuratkull
 
kuratkull's Avatar
 
Mar 2007
Estonia

100001102 Posts
Default

Quote:
Originally Posted by chalsall View Post
Hmmm... I have /never/ not received a CPU. And the daily GPU allotment has been running for ten hours more often than seven the last couple of days.

I am sure Google tries its best so that users wouldn't see that. But I can see how instances could be unavailable for a short time in times of congestion. Other than that one brief time when it happened a few days ago, Google is pretty regular in letting 1 instance run always, and the others are time limited. (CPU only.)
kuratkull is offline   Reply With Quote
Old 2020-04-20, 16:10   #18
kladner
 
kladner's Avatar
 
"Kieren"
Jul 2011
In My Own Galaxy!

100110101100012 Posts
Default

As expected this morning my 4 instances were shut down. Just now, a couple of hours later, I got 1 CPU-only worker to start. A second one refused to start. Getting to see all the P-1 startup was enlightening. With 10,240MB allowed only 192 relative primes are being processed. Optimal bounds are B1=720,000, B2=1,332,0000. Meanwhile, Prime95, on a 32GB machine is setting 765,000 and 13,593,750, and running 480 RPs. High memory notebooks have about 25.5GB available. Wouldn't it improve results to let mfaktc use more of the available RAM?
kladner is offline   Reply With Quote
Old 2020-04-20, 16:38   #19
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

52×192 Posts
Default

Quote:
Originally Posted by kladner View Post
High memory notebooks have about 25.5GB available. Wouldn't it improve results to let mfaktc use more of the available RAM?
Hmmm... (And I presume you mean mprime using the RAM.)

To the best of my knowledge, only you and Chuck are running the paid tier. So such high-memory instances wouldn't be that common.

There's also the issue of assignment reissuing. If a high-memory instance got an assignment and started working with really high bounds, what would happen if it then was reassigned to a standard memory sized instance? mprime will still work at the already worked B1/B2 bounds, but at what efficiency? Perhaps George can weigh in on this.

I guess I could have my server code-path make assignment decisions based on the memory available at request time (the telemetry sent back does include this information).

Let me meditate on this a bit, and see if I can come to sane convergence in my head (can be a somewhat painful exercise -- arguing with myself)...
chalsall is online now   Reply With Quote
Old 2020-04-20, 18:03   #20
kladner
 
kladner's Avatar
 
"Kieren"
Jul 2011
In My Own Galaxy!

5·7·283 Posts
Default

OK. Thanks Chris. I had not thought of the possibility of High RAM not being available on subsequent launches. The whole thing is mostly curiosity based. Good thing I am not a cat.
kladner is offline   Reply With Quote
Old 2020-04-20, 18:15   #21
Chuck
 
Chuck's Avatar
 
May 2011
Orange Park, FL

22·11·19 Posts
Default

Quote:
Originally Posted by kladner View Post
As expected this morning my 4 instances were shut down. Just now, a couple of hours later, I got 1 CPU-only worker to start. A second one refused to start.
My quota has settled into four 19-hour GPU sessions each day. After six hours I can restart them. I have only ever received P100s on the paid tier.
Chuck is offline   Reply With Quote
Old 2020-04-20, 18:27   #22
kladner
 
kladner's Avatar
 
"Kieren"
Jul 2011
In My Own Galaxy!

5×7×283 Posts
Default

Quote:
Originally Posted by Chuck View Post
My quota has settled into four 19-hour GPU sessions each day. After six hours I can restart them. I have only ever received P100s on the paid tier.
Same here. I wonder if having multiple instances causes this, even if one is only using one at a particular time. I guess I could delete three of the four and mess around for a while to see if anything changes.
kladner is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
"CUDA runtime version 0.0" when running mfaktc.exe froderik GPU Computing 4 2016-10-30 15:29
"connect client to account" christine Information & Answers 6 2016-02-06 18:09
Aouessare-El Haddouchi-Essaaidi "test": "if Mp has no factor, it is prime!" wildrabbitt Miscellaneous Math 11 2015-03-06 08:17
"ERROR: Unable to open spool file." no1hasdisid Software 1 2013-05-06 05:24
Would Minimizing "iterations between results file" may reveal "is not prime" earlier? nitai1999 Software 7 2004-08-26 18:12

All times are UTC. The time now is 15:37.

Sat Jul 11 15:37:58 UTC 2020 up 108 days, 13:11, 1 user, load averages: 1.31, 1.53, 1.46

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.