mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > GMP-ECM

Reply
 
Thread Tools
Old 2012-01-07, 14:56   #1
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

2,833 Posts
Default latest SVN 1677

There is no "build.vc9" folder when I get the latest svn? and the required Makefile.in is not in the build.vc10 folder.

"Autoreconf -i" fails:
Code:
configure.in:623: required file `build.vc9/Makefile.in' not found
configure.in:623: required file `build.vc9/assembler/Makefile.in' not found
configure.in:623: required file `build.vc9/ecm/Makefile.in' not found
configure.in:623: required file `build.vc9/libecm/Makefile.in' not found
configure.in:623: required file `build.vc9/tune/Makefile.in' not found
Makefile.am: installing `./depcomp'
autoreconf: automake failed with exit status: 1

Last fiddled with by ATH on 2012-01-07 at 14:57
ATH is offline   Reply With Quote
Old 2012-01-07, 15:45   #2
WraithX
 
WraithX's Avatar
 
Mar 2006

23·59 Posts
Default

Quote:
Originally Posted by ATH View Post
There is no "build.vc9" folder when I get the latest svn? and the required Makefile.in is not in the build.vc10 folder.

"Autoreconf -i" fails:
Hi ATH, I have sent an email to Paul and Alex about this. In the mean time, you can either edit files in your svn 1677, or download the official ecm-6.4 source.

The files to edit are Makefile.am and configure.in. Remove the references to build.vc9 in both of those files, then 'autoreconf -i' will succeed.

Or you can download the 6.4 source file ecm-6.4.tar.gz from here:
https://gforge.inria.fr/frs/?group_i...elease_id=6762

This way you can bypass the autoreconf step. :) Let me know how it goes and I'll talk with you later.
WraithX is offline   Reply With Quote
Old 2012-01-07, 15:48   #3
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

2,833 Posts
Default

Thank you.

I was considering getting the 6.4 source, but wasn't sure if it was the same as the latest SVN 1677. So I wanted to ask first to get the latest SVN.
ATH is offline   Reply With Quote
Old 2012-01-07, 16:03   #4
WraithX
 
WraithX's Avatar
 
Mar 2006

23×59 Posts
Default

Yeah, there are only a few minor changes between ecm-6.4 and svn 1677, so there shouldn't be any worry about missing features.

Actually, Paul has already updated the svn. It is now at 1678. 'autoreconf -i', 'make', and 'make check' all complete successfully for me. Hopefully they will for you too.
WraithX is offline   Reply With Quote
Old 2012-01-07, 16:35   #5
fivemack
(loop (#_fork))
 
fivemack's Avatar
 
Feb 2006
Cambridge, England

11000110011002 Posts
Default

I am probably missing something obvious in the documentation, but I can't see how to compile ecm-6.4 against mpir. Compiling it against gmp-4.3.2 gives me an executable which runs more slowly than ecm-6.2 as shipped by ubuntu.
fivemack is offline   Reply With Quote
Old 2012-01-07, 16:45   #6
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

54218 Posts
Default

It was already at SVN 1681 when I got it now :)

Maybe you should post which SVN the official "ecm-6.4.tar.gz" release is (and future releases): https://gforge.inria.fr/frs/?group_i...elease_id=6762
Just a suggestion, it would be nice to know.

Fivemack:

Compile MPIR with:
./configure --enable-gmpcompat
make
make install
make check

then compile GMP-ECM same way as with GMP.

Last fiddled with by ATH on 2012-01-07 at 16:47
ATH is offline   Reply With Quote
Old 2012-01-07, 17:41   #7
jasonp
Tribal Bullet
 
jasonp's Avatar
 
Oct 2004

2×3×587 Posts
Default

Alex and I are updating the stage 2 code for P+-1 in a separate branch, you won't see any of that in the upcoming release (but the repository version number increments all the same)
jasonp is offline   Reply With Quote
Old 2012-01-07, 18:34   #8
WraithX
 
WraithX's Avatar
 
Mar 2006

47210 Posts
Default

Quote:
Originally Posted by ATH View Post
It was already at SVN 1681 when I got it now :)

Maybe you should post which SVN the official "ecm-6.4.tar.gz" release is (and future releases): https://gforge.inria.fr/frs/?group_i...elease_id=6762
Just a suggestion, it would be nice to know.
I asked Paul which SVN version each release was based on. He let me know that the information is in the file README.dev.

It currently has the following information:

Version 6.2 is r1290, 6.2.1 is r1307, 6.3 is r1501, 6.4 is r1672.
WraithX is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel's latest problem... science_man_88 Hardware 19 2018-01-25 01:06
Latest msieve - GPU for LA? david314 Msieve 1 2013-07-01 16:45
Error in GMP-ECM 6.4.3 and latest svn ATH GMP-ECM 10 2012-07-29 17:15
Has anyone seen my latest treatise? davieddy Lounge 0 2011-01-21 19:29
Latest version? [CZ]Pegas Software 3 2002-08-23 17:05

All times are UTC. The time now is 12:57.

Tue May 26 12:57:06 UTC 2020 up 62 days, 10:30, 1 user, load averages: 1.51, 1.55, 1.54

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.