mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Closed Thread
 
Thread Tools
Old 2004-05-05, 03:44   #1
Unregistered
 

32×5×167 Posts
Default ./mprime: Permission denied.

So I've been running Prime95 under XP for a couple'a weeks, time to get it running in Linux. I boot into linux and put the 'mprime' binary into the same directory as the Win-client as indicated in the FAQ. Like this:

Code:
[20:31] Dude > pwd
/mnt/shared/Prime95
[20:31] Dude > grep /mnt/shared /etc/fstab
/dev/hda6   /mnt/shared  vfat user,rw,uid=500,gid=100,umask=000  0   0
[20:31] Dude > grep dude /etc/passwd
dude:x:500:100:Dude Dudesky,,,:/home/dude:/bin/tcsh
[20:32] Dude > ls -l mprime
-rwxrwxrwx    1 dude     users     2128340 Jul  3  2003 mprime
[20:32] Dude > ./mprime
./mprime: Permission denied.
[20:32] Dude > su
Password:
[20:32] Root > ./mprime
./mprime: Permission denied.
[20:33] Root >
Alright, I'm stumped. I admit it. I have no idea what's going on here. I own the file, I have 777 permissions on it and yet I cannot run it.

I'd like to add that the exact same binary runs just fine when I copy it into any other directory. Just not there.
 
Old 2004-05-05, 04:00   #2
Unregistered
 

9,811 Posts
Default

Clarification: the ">" symbol is part of the prompt. I'm not trying to run a command "Dude" and redirect the output ...
 
Old 2004-05-05, 04:03   #3
geoff
 
geoff's Avatar
 
Mar 2003
New Zealand

22058 Posts
Default

It is not necessary to put the mprime binary in the work directory, just put it in /usr/local/bin and then either cd to the work directory before running it, or use the -W/mnt/shared/Prime95 command line option.

The reason for the 'permission denied' is that you have mprime on a FAT filesystem. You could to mount it with the 'exec' option, though that is not really a good habit to get into.
geoff is offline  
Old 2004-05-07, 08:20   #4
geoff
 
geoff's Avatar
 
Mar 2003
New Zealand

13·89 Posts
Default

Actually, the real reason for the permission denied is the 'user' option in the fstab entry. exec is normally the default for any filesystem, user causes noexec to become the default. Mounting with 'user,exec' will fix it. (but putting mprime somewhere like /usr/local/bin is still better).
geoff is offline  
Closed Thread

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
requesting permission from George to release Prime95 screenshot under GPL ixfd64 Software 13 2021-06-17 07:48
Permission denied on ecm Romuald YAFU 21 2016-08-27 06:36
PrimeNet error 9: Access denied under FreeBSD aevernon Information & Answers 5 2016-01-21 14:57
Asking permission of the company sixblueboxes Information & Answers 32 2015-12-10 19:36
PrimeNet error 9: Access denied? mike12166 Information & Answers 7 2009-06-20 08:54

All times are UTC. The time now is 01:30.


Sun Oct 17 01:30:21 UTC 2021 up 85 days, 19:59, 0 users, load averages: 2.80, 2.84, 2.24

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.