mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2006-04-26, 01:06   #1
kdelisle2005
 
Mar 2006
Michigan

11 Posts
Default Exponent not Checked In

This issue is with a laptop at work which is not always connected to the interent.

PRIME95 completed it's work over the weekend (4/22-23) and tried many times to contact PrimeNet. When I got to work on Monday, 1) I plugged in the network cable, 2) initiated a manual communication, 3) messages passed back and forth and 4) I started with another exponent.

When I reviewed my Individual Account Report a day later, I noticed that the old exponent did not check in and the last update was on April 10.

How do I check in the old exponent?? Do I alter worktodo.ini and restart PRIME95?? What would I enter??


thanks
kevin

~~~~~

Individual Account Report 25 Apr 2006 23:36

------ Exponents Assigned -------

prime fact current days
exponent bits iteration run / to go / exp date updated date assigned computer ID Mhz Ver
-------- -- ---- --------- ----------------- --------------- --------------- ------------ ---- ---
16006951 D 66 256 1.1 35.9 95.9 24-Apr-06 20:15 24-Apr-06 20:14 C520C5430 1002 v19/v20 (new)
16802839 D 66 11120537 42.5 -1.5 58.5 10-Apr-06 10:26 14-Mar-06 12:09 C520C5430 1002 v19/v20 (old)
kdelisle2005 is offline   Reply With Quote
Old 2006-04-26, 01:41   #2
JHagerson
 
JHagerson's Avatar
 
May 2005
Naperville, IL, USA

22×72 Posts
Default

Did the first exponent finish? You can look at the most recent entries in RESULTS.TXT and see if it did. If so, you can copy the entry, starting with the time stamp in [square brackets] and send that through e-mail to woltman _at_ alum.mit.edu. Include a little note stating that you need to have the exponent cleared from the PrimeNet server and he will take care of it.

If the first exponent did not finish, you can look in your Prime95 directory to see if you have the calculation save files from the earlier run. They have names starting with "p" and "q" that are unique for each exponent. Yours would be something like pxxx2839 and qxxx2839 (where "xxx" here is a placeholder for other characters). If you have these files, then Prime95 can continue where it left off. You would need to pause and close Prime95. Then open WorkToDo.INI and add this entry to the top:

DoubleCheck=16802839,66,1

Make sure that you don't overwrite the entry for your new assignment. Then, when you restart Prime95, it will go back to working on the old assignment. A manual communication with PrimeNet should put everything back into order.

I also had server communications problems this past weekend, so you are not alone.

Good luck! If you have any questions, please post them here or send me a private message.

John

[Edit: Fix typo.]

Last fiddled with by JHagerson on 2006-04-26 at 01:42
JHagerson is offline   Reply With Quote
Old 2006-04-26, 03:17   #3
kdelisle2005
 
Mar 2006
Michigan

11 Posts
Default Exponent Checkin

PRIME95 did complete the task all the way to 100%;

prime.log and results.txt reflect that completion.

it is just a little strange that the results were not uploaded to PrimeNet.

I may take your suggestion and update worktodo.ini and have PRIME95 re-do the upload steps.


kevin
kdelisle2005 is offline   Reply With Quote
Old 2006-04-26, 05:00   #4
markr
 
markr's Avatar
 
"Mark"
Feb 2003
Sydney

13×43 Posts
Default

Also check if you still have the prime.spl file. It's probabaly not there, but it's worth a look. If it is there, and is >1 byte, it will have results to send. A manual communication will resend them, without needing to do any more computations.

If that and John's suggestion won't work, you should email the results.txt to George and explain what happened. You will only get GIMPS credit (ie no primenet credit) for this exponent, but at least he can clear it from primenet.

BTW, maybe you could think about setting that laptop to manual communication only?
markr is offline   Reply With Quote
Old 2006-04-26, 16:05   #5
kdelisle2005
 
Mar 2006
Michigan

11 Posts
Default PrimeNet Checkin

I don't have a PRIME.SPL file, maybe that is with an older version.

I did update worktodo.ini with the exponent but PRIME95 just started from the beginning (0.00%) instead of at the very end.

I still have the qG802839 and pG802839, so I am surprised PRIME95 did not access those files.

Any other suggestions so that PRIME95 will automatically upload to PrimeNet so that I get CPU time credit??


thanks
kevin
kdelisle2005 is offline   Reply With Quote
Old 2006-04-26, 18:05   #6
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
Rep├║blica de California

264216 Posts
Default

In future, instead of starting a new thread, please post stuff like this here.
ewmayer is online now   Reply With Quote
Old 2006-04-27, 07:23   #7
markr
 
markr's Avatar
 
"Mark"
Feb 2003
Sydney

13×43 Posts
Default

Prime95 makes the prime.spl file to hold results until it sends them to primenet, then it deletes it.

Like you, I'm surprised prime95 didn't start from where the save file was up to. I can't think of anything you probably haven't thought of already. Just remember that once prime95 started again on 16802839 it will overwrite the "original" pG802839 file every so often & when it exits, so you may want to go back to the copy I hope you you made before you started changing things. (Experience speaking - I recently wiped out all progress on a TF.)

As I said, you can email the results to George. He can give you gimps credit & remove the exponent from primenet.

The only other suggestion I have to submit the result directly to primenet is a bit extreme, and I'm not absolutely sure the current version still works like this. (Backup your prime95 folder if you haven't already.) Change your prime95 to not use primenet (using the menus: Test / PrimeNet... / Use PrimeNet to get work and report results ), then change it back to using primenet. Prime95 will send everything in results.txt to primenet.

Good luck!
markr is offline   Reply With Quote
Old 2006-05-23, 02:21   #8
Yxine
 
Yxine's Avatar
 
"Aleksandr"
Nov 2005
Russia

9010 Posts
Default

The same problem:

Two of my computers that are not connected to internet did some work, and I submit it through the third one which is interneted. The data goes to the server as usual, but the exponents is still in the list.

Here is the results:

[Wed May 17 08:31:37 2006]
UID: ComputerraRU/Yxine, M37889897 no factor to 2^68, Wc1: 6BACFC25
[Thu May 18 05:38:14 2006]
UID: ComputerraRU/Yxine, M36905171 no factor to 2^67, Wc1: 6237F59C
[Fri May 19 02:56:33 2006]
UID: ComputerraRU/Yxine, M36925957 no factor to 2^67, Wc1: 6280F5BC

[Mon May 22 20:56:04 2006]
UID: ComputerraRU/Dima, M36562727 no factor to 2^69, WZ1: 5EFEF352
Yxine is offline   Reply With Quote
Old 2006-10-06, 14:54   #9
Aillas
 
Aillas's Avatar
 
Oct 2002
France

27 Posts
Default Submit result not took into account

I use a computer to get all the work (Chimera) and distribute it to another one (Taz)

Taz has just finished this one.

UID: Aillas/Taz, M23905039 is not prime. Res64: 22281EBF4F7B1897. Wc2: 4217FC61,9669143,00000000

When I do a manual communication, the result was sent without problem.
When I check my account, 23905039 was still assigned to Chimera. I try with the Manual Form. Same result.

I checked also the cleared file (http://mersenne.org/primenet/cleared.txt). The exponent is not listed.

How to get this exponent cleared in my account?

Thanks

Ludo

PS: I assigned a new exponent to Taz and perform a manual communication after few iteration. It's now appears in my account as assigned to Taz. Maybe the problem came because I submit the result while the exponent was still assigned to another computer?
Aillas is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are Facts Double Checked? TheMawn GPU Computing 10 2013-08-28 10:13
Merge checked CPUs DigbyAllen PrimeNet 0 2011-02-10 22:26
Double checked exponent does not show as completed Daffy PrimeNet 6 2008-02-13 05:14
Why so many assignments checked out? JHagerson PrimeNet 38 2006-11-24 10:48
All exponents below 13,000,000 double-checked. Aillas Lounge 5 2006-06-30 07:27

All times are UTC. The time now is 21:57.

Tue Oct 27 21:57:27 UTC 2020 up 47 days, 19:08, 2 users, load averages: 1.92, 1.97, 1.98

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.