mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2005-10-27, 14:03   #1
Stalvros
 

380310 Posts
Default Proxy

I have got a proxy behind my server~
I've read the readme.txt and it did specifically say that

==========================================================
SETTING UP A PROXY SERVER
-------------------------

For the latest information on this and other networking issues visit
the FAQ at http://mersenne.org/ips/faq.html

Create a file in the same local folder as Prime95.exe, called "primenet.ini".
Add these text lines, substituting the appropriate proxy server URL and port:

[PrimeNet Proxy]
ProxyHost=http://proxy.megacorp.com:8080

If the proxy is secured by a userid/password, add the following two text
lines, substituting the appropriate values:

ProxyUser=whatever_the_userid_is
ProxyPass=whatever_the_password_is

After the first time PrimeNet is contacted through a secure proxy, the proxy
password is encoded and a new parameter 'ProxyMask=1' set. To change the
password, simply change the ProxyPass= value, and either delete the ProxyMask
text line or set ProxyMask=0.
==========================================================

I did all of that but I still can't log in -_-
I wonder if I did it wrongly though~
All I did was just copy the 'prime.ini' and rename that copied file 'primenet.ini' as i erased the content and just add whatever's required~

So yeah~
Could anyone help me on this?
  Reply With Quote
Old 2005-10-27, 16:45   #2
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

2×5×251 Posts
Default

Can you post the content of your primenet.ini file (with the password blanked out of course)?
garo is offline   Reply With Quote
Old 2005-10-28, 03:12   #3
Unregistered
 

8D716 Posts
Default

[PrimeNet Proxy]
ProxyHost=proxy.newcastle.edu.au:8080
ProxyUser=XXXXXX
ProxyPass=XXXXXX
ProxyMask=1
  Reply With Quote
Old 2005-10-28, 09:39   #4
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

2·5·251 Posts
Default

Try deleting the file and creating a fresh one without copy and paste. Sometimes unprintable characters that get left behind can cause problems.
garo is offline   Reply With Quote
Old 2005-10-28, 14:04   #5
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

112×59 Posts
Default

Add "Debug=1" to primenet.ini to get a more detailed report on the communication with the server
Prime95 is online now   Reply With Quote
Old 2005-10-28, 14:15   #6
Unregistered
 

5·103 Posts
Default

How do you create an .ini file though?
Right click > New > ?

Quote:
Originally Posted by garo
Try deleting the file and creating a fresh one without copy and paste. Sometimes unprintable characters that get left behind can cause problems.
  Reply With Quote
Old 2005-10-28, 14:47   #7
Unregistered
 

10001101100102 Posts
Default

Open microsoft note pad
Next go to save as
select were you want to save it and then chose a name we will call it primenet.ini
next under there there is a setting called save as type change it to all files
  Reply With Quote
Old 2005-10-29, 03:11   #8
Unregistered
 

25·7·31 Posts
Default

Yeah already did that.
Says that;

Return code is not 200
ERROR: Primenet error1
  Reply With Quote
Old 2005-10-29, 03:58   #9
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

713910 Posts
Default

The prime.log file should have all the http data sent and received. That may have more helpful error information.
Prime95 is online now   Reply With Quote
Old 2005-10-29, 14:34   #10
Unregistered
 

32×157 Posts
Default

<p>Sorry, you are not currently allowed to request:
<PRE> http://mersenne.org/cgi-bin/pnHttp.exe?</PRE>
from this cache until you have authenticated yourself.
<p></p>

<p>
You need to be using Netscape version 2.0 or greater, or Microsoft
Internet Explorer 3.0, or an HTTP/1.1 compliant browser for this to work.
</p>

<br clear="all">
<hr noshade size=1>
Generated Sat, 29 Oct 2005 14:33:04 GMT by proxy.newcastle.edu.au (Squid/2.4.STABLE7)
</BODY></HTML>

Return code is not 200
ERROR: Primenet error 1

(It says that)
(Strange though, I am using the latest IE)
  Reply With Quote
Old 2005-10-29, 19:27   #11
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

112×59 Posts
Default

Quote:
Originally Posted by Unregistered
(Strange though, I am using the latest IE)
Yes, but prime95 does not use IE.

The problem is either 1) squid doesn't like the fact that prime95 is passing an HTTP/1.0 request. or 2) You've entered the wrong proxy user name or password.

The next version of prime95 will use HTTP/1.1 requests. That is quite a ways off.

In the meantime, grab a few exponents from http://mersenne.org/range2.htm
Prime95 is online now   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
OK now I know the proxy REALLY works Chuck GPU to 72 12 2012-08-15 13:21
LLRnet over proxy? Bananeweizen Sierpinski/Riesel Base 5 4 2006-10-14 07:51
Proxy Help Prime95 Software 1 2006-03-22 01:33
Prime95 proxy PrimeCruncher Software 4 2003-10-09 22:51
Proxy Servers and 22.8 Prime95 Software 1 2002-09-07 19:01

All times are UTC. The time now is 21:21.

Tue Oct 27 21:21:05 UTC 2020 up 47 days, 18:32, 2 users, load averages: 1.86, 1.83, 1.91

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.