mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2006-02-14, 13:22   #1
rx7350
 
rx7350's Avatar
 
Feb 2006
AR, US

24×32 Posts
Default Errors accessing files after system reload

I recently formatted my hard drives and reloaded my system after completing a new build. Before doing that I backed up the Prime95 folder with all the files in it. After reloading and re-installing Prime95, I copied the backed up files back to the new Prime95 folder created during the re-installation, reply 'Yes' to over-write any files. I have a dual-core processor and I'm running two instances of Prime95. One of them (M28556293) is running just fine. On the other one (M28266647) is having difficulty as follows:

Error opening results file to output this message
Unable to open log file
Error writing intermediate file:rS266647
Error unable to open log file
ERROR: Unable to open spool file
Unable to open log file
Cannot write to file worktodo.ini
--And so on--

All of the files appear to be in the Prime95 folder, at least in the sense that similar files exist for the instance that's having problems as compared to the instance that's not having problems.

I'm at a loss to figure out what the problem is.

Can any one help?
rx7350 is offline   Reply With Quote
Old 2006-02-14, 13:35   #2
BotXXX
 
BotXXX's Avatar
 
Aug 2003
Europe

2×97 Posts
Default

I am not sure how you have backed-up the files. But it seems or at least the first thought would be that the files are read-only (say copied from cd/dvd) and that Prime95 can not alter them. So change the properties of the files in the prime95 directory.

"Select all" -> "Properties" -> "Deselect read-only" -> "OK"

But i am not totally sure if it is this, since the other instance is working without problems.
BotXXX is offline   Reply With Quote
Old 2006-02-14, 18:49   #3
rx7350
 
rx7350's Avatar
 
Feb 2006
AR, US

100100002 Posts
Default

None of the files were read-only, but when I looked at the folder is was read-only. I de-selected that attribute, but the instance was still having problems.
I re-booted my pc, and only the one instance re-started. The one that was having problems did not start. I even tried re-starting it using the -A1 switch, but it will not start.

Any ideas?
rx7350 is offline   Reply With Quote
Old 2006-02-15, 08:56   #4
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

32×307 Posts
Default

Have you set "Start at Bootup" for both instances. If so and you are administrator, it is quite possible that both instances have installed as services and are overwriting each other.
garo is offline   Reply With Quote
Old 2006-02-15, 13:04   #5
rx7350
 
rx7350's Avatar
 
Feb 2006
AR, US

24·32 Posts
Default

I finally was able to get the 2nd instance running by going to a command prompt and starting Prime95 WITHOUT the -A1 switch. I suspect that for some reason, after my pc reload, that both instances were trying to write to the same set of files, and one was cutting the other off. When I re-loaded, I did set up an administrator password, so you're saying that may be causing some difficulty? When I log on (not often, since the machine runs all the time), I don't go in as administrator, just as myself (the only user that's set up).

Could it possibly be that the affinity is now reversed between the two, from what it was before the re-load?

And, here's another quirk - I'm able to get the second instance running by starting it manually thru the command line, but at re-boot it doesn't start up automatically, and the 'Start at Bootup' IS checked.

Both instances are at 90% complete, so they'll be finished in the next couple of days. I'm tempted to un-install Prime95 after they finish, and then re-install with a fresh set of files. I've already got another test scheduled for both instances, per the entries in the 'worktodo' files, so if I re-install can I just edit the files and manually type those assignments back in there. Since it's really not evident what this problem is, I'd prefer not to save any of the exisiting files (that's how all of this started), but rather get a freshly installed set, and then just edit the new 'worktodo' files.

How does that sound?
rx7350 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing FactorDB from Python shortcipher FactorDB 21 2018-12-03 17:03
Prime95 error accessing files (work, log, backup) C0REY Information & Answers 5 2017-07-19 05:56
Fatal errors on new Dell system davidm Hardware 2 2008-08-19 02:53
Accessing SMB shares from Windows Cruelty Linux 5 2007-11-17 23:15
Problems accessing the GIMPS source code timing pages ewmayer Software 1 2002-11-10 19:40

All times are UTC. The time now is 12:06.

Sat Apr 10 12:06:57 UTC 2021 up 2 days, 6:47, 1 user, load averages: 2.13, 2.00, 1.87

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.