mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > Factoring

Reply
 
Thread Tools
Old 2007-11-19, 17:40   #1
jasong
 
jasong's Avatar
 
"Jason Goatcher"
Mar 2005

350510 Posts
Default Continuing to Stage 2 p-1 with save file.

I've never been so frustrated with Google in my life!!!

Could someone please tell me how to continue to Stage 2 p-1 when the save files for Stage 1 are available?
jasong is offline   Reply With Quote
Old 2007-11-19, 18:14   #2
Andi47
 
Andi47's Avatar
 
Oct 2004
Austria

7·353 Posts
Default

Do you mean resuming with GMP-ECM?

Code:
ecm –resume savefile B1 B2 >>outputfile
Andi47 is offline   Reply With Quote
Old 2007-11-19, 20:22   #3
jasong
 
jasong's Avatar
 
"Jason Goatcher"
Mar 2005

66618 Posts
Default

Quote:
Originally Posted by Andi47 View Post
Do you mean resuming with GMP-ECM?

Code:
ecm –resume savefile B1 B2 >>outputfile
No, but it doesn't matter, because I've read the readme, and I'd never realized how little memory p-1 uses.
jasong is offline   Reply With Quote
Old 2007-11-20, 05:15   #4
jasong
 
jasong's Avatar
 
"Jason Goatcher"
Mar 2005

5·701 Posts
Default

Okay, apparently setting B2 to 0 DOESN'T stop Stage 2. All four of my cores want to run Stage 2, and except for core 0, they're all dogslow from fighting over bandwidth.

Please, someone post how to do Stage 2 separately from Stage 1. They're all going to use mprime for Stage 2, but because of the fact a quad-core is actually 2 Core2s glued together, I can only afford to have one core on each sub-die running Stage 2.

I'll be running something on the other 2 cores until somebody helps me out with this, I've given up on the search engines.
jasong is offline   Reply With Quote
Old 2007-11-20, 06:25   #5
philmoore
 
philmoore's Avatar
 
"Phil"
Sep 2002
Tracktown, U.S.A.

22·32·31 Posts
Default

Set B2 equal to 1 to skip stage 2. Setting it equal to 0 causes mprime to take B2=100*B1 in most cases (B2 must be < 4.29e9). Setting B2 to any positive value < the B1 limit will cause B2 to be skipped.

Last fiddled with by philmoore on 2007-11-20 at 06:26
philmoore is offline   Reply With Quote
Old 2007-11-20, 21:23   #6
jasong
 
jasong's Avatar
 
"Jason Goatcher"
Mar 2005

1101101100012 Posts
Default

Quote:
Originally Posted by philmoore View Post
Set B2 equal to 1 to skip stage 2. Setting it equal to 0 causes mprime to take B2=100*B1 in most cases (B2 must be < 4.29e9). Setting B2 to any positive value < the B1 limit will cause B2 to be skipped.
Thanks philmoore. I've copied and pasted your post to the p-1 reservation thread on PrimeGrid forums, the Sieving forum.

You rock.
jasong is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
P-1 Save File Compatability PageFault Software 10 2012-04-05 01:26
Failed to write a save file Joe O GMP-ECM 12 2010-02-18 01:38
Error reading P-1 save file? edorajh Software 4 2008-01-14 22:20
file magic for mprime save files geoff Linux 0 2004-03-21 02:34
p95 v2.34 not writing save files during P-1 stage 2 geoff Software 4 2003-06-11 08:33

All times are UTC. The time now is 20:26.

Tue Oct 20 20:26:03 UTC 2020 up 40 days, 17:37, 1 user, load averages: 2.04, 2.17, 2.12

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.