mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > GMP-ECM

Reply
 
Thread Tools
Old 2013-08-28, 13:13   #188
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

1,741 Posts
Default

I'm pretty sure there's one in here somewhere, though I don't remember exactly where.
wombatman is offline   Reply With Quote
Old 2013-08-30, 19:14   #189
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

110110011012 Posts
Default

Is there a simple way to only run, say, stage 1 of GPU-ECM? I'd like to run the stage 1 on my desktop's GPU and then run stage 2 on my laptop (64-bit processor). I can churn through 480 stage 1 curves at a time on my GPU, but then my (relatively) ancient processor takes an inordinately long amount of time to do the stage 2 work before the residues show up in the save file. So if at all possible, I'd like to cut out stage 2 and simply use "-resume" with the residues file.

Edit: And just like that, I seem to have answered my own question. Setting B2=0 appears to have done it.

Last fiddled with by wombatman on 2013-08-30 at 19:16
wombatman is offline   Reply With Quote
Old 2013-10-08, 16:45   #190
skan
 
skan's Avatar
 
Apr 2012

2·47 Posts
Default

Hello

Can this gpu-ecm.exe executable be used with yafu by just renaming it?
Or it's not compatible?
skan is offline   Reply With Quote
Old 2013-10-08, 16:48   #191
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

33158 Posts
Default

I imagine it would work fine by directing yafu to it, but you wouldn't be using the GPU to actually run the curves. As such, it would be simpler to use the standard GMP-ECM. In addition, there's a bug (at least in the versions I've compiled) where factors that should be found in Stage 2 are not found by the GPU version. So you'd likely miss factors if you tried to use the GPU-enabled version.
wombatman is offline   Reply With Quote
Old 2013-10-10, 00:55   #192
frmky
 
frmky's Avatar
 
Jul 2003
So Cal

22·11·47 Posts
Default

Has anyone gotten save/resume to work? Here's what I get:

Code:
./ecm -gpu -save c192.ecm 4e4 0 < C192
GMP-ECM 7.0-dev [configured with GMP 5.1.3, --enable-asm-redc, --enable-gpu, --enable-assert, --enable-openmp] [ECM]
Input number is 361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517 (192 digits)
Using B1=40000, B2=0, sigma=3:3642364246-3:3642365077 (832 curves)
Computing 832 Step 1 took 472ms of CPU time / 21426ms of GPU time
This gives a save file like
Code:
METHOD=ECM; PARAM=3; SIGMA=3642365077; B1=1; N=361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517; X=0x7cb7309ea2ec4ee5d88962fa7516f43385ad69f16e28b04b8beee48d15091cf009cd4119d57a505d6c062036b1d8a784d11d4d87873df12d62bc03b9f10e7a1671e666030d895d55d22d5da9743992e; CHECKSUM=3136759905; PROGRAM=GMP-ECM 7.0-dev; X0=0x0; Y0=0x0; WHO=cluster@compute-0-1.local; TIME=Wed Oct  9 17:49:08 2013;
Then on resume:
Code:
./ecm -resume c192.ecm 4e4
GMP-ECM 7.0-dev [configured with GMP 5.1.3, --enable-asm-redc, --enable-gpu, --enable-assert, --enable-openmp] [ECM]
Resuming ECM residue saved by cluster@compute-0-1.local with GMP-ECM 7.0-dev on Wed Oct  9 17:49:08 2013 
Input number is 361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517 (192 digits)
Error, x0 should be equal to 2 with this parametrization
Please report internal errors at <ecm-discuss@lists.gforge.inria.fr>.
Does this work for anyone? Thanks!
frmky is offline   Reply With Quote
Old 2013-10-10, 01:15   #193
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

6CD16 Posts
Default

Sorry to have edited so many times, but you're using the right command--it looks like the issue is with the B1 being wrong in the save file. I just ran with the GPU using the input number, and I have no issues using -resume. I don't remember what was done to fix the B1 save file issue though.

Last fiddled with by wombatman on 2013-10-10 at 01:26
wombatman is offline   Reply With Quote
Old 2013-10-10, 02:20   #194
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

1,741 Posts
Default

Here's a post that might have a fix for the B1=1 bug:

http://mersenneforum.org/showpost.ph...&postcount=174

Also, my version is 32-bit. Are you using a 32 or 64 bit build? I went ahead and ran 480 curves of your C192 at 4e4--no factors found.

Last fiddled with by wombatman on 2013-10-10 at 02:21
wombatman is offline   Reply With Quote
Old 2013-10-10, 05:53   #195
frmky
 
frmky's Avatar
 
Jul 2003
So Cal

22×11×47 Posts
Default

Quote:
Originally Posted by wombatman View Post
Here's a post that might have a fix for the B1=1 bug:

http://mersenneforum.org/showpost.ph...&postcount=174

Also, my version is 32-bit. Are you using a 32 or 64 bit build? I went ahead and ran 480 curves of your C192 at 4e4--no factors found.
Thanks for the link. That workaround seems to fix it. I'm using the 64-bit version.
frmky is offline   Reply With Quote
Old 2013-10-10, 06:59   #196
xilman
Bamboozled!
 
xilman's Avatar
 
"π’‰Ίπ’ŒŒπ’‡·π’†·π’€­"
May 2003
Down not across

3×3,529 Posts
Default

Quote:
Originally Posted by frmky View Post
Has anyone gotten save/resume to work? Here's what I get:

Code:
./ecm -gpu -save c192.ecm 4e4 0 < C192
GMP-ECM 7.0-dev [configured with GMP 5.1.3, --enable-asm-redc, --enable-gpu, --enable-assert, --enable-openmp] [ECM]
Input number is 361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517 (192 digits)
Using B1=40000, B2=0, sigma=3:3642364246-3:3642365077 (832 curves)
Computing 832 Step 1 took 472ms of CPU time / 21426ms of GPU time
This gives a save file like
Code:
METHOD=ECM; PARAM=3; SIGMA=3642365077; B1=1; N=361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517; X=0x7cb7309ea2ec4ee5d88962fa7516f43385ad69f16e28b04b8beee48d15091cf009cd4119d57a505d6c062036b1d8a784d11d4d87873df12d62bc03b9f10e7a1671e666030d895d55d22d5da9743992e; CHECKSUM=3136759905; PROGRAM=GMP-ECM 7.0-dev; X0=0x0; Y0=0x0; WHO=cluster@compute-0-1.local; TIME=Wed Oct  9 17:49:08 2013;
Then on resume:
Code:
./ecm -resume c192.ecm 4e4
GMP-ECM 7.0-dev [configured with GMP 5.1.3, --enable-asm-redc, --enable-gpu, --enable-assert, --enable-openmp] [ECM]
Resuming ECM residue saved by cluster@compute-0-1.local with GMP-ECM 7.0-dev on Wed Oct  9 17:49:08 2013 
Input number is 361867761627749619574674677769104106609222942556126375131641520128131226876942053491915389383216114202550615939995196059592933366284139274937165773815556682024285008268664983092158298987980517 (192 digits)
Error, x0 should be equal to 2 with this parametrization
Please report internal errors at <ecm-discuss@lists.gforge.inria.fr>.
Does this work for anyone? Thanks!
Bizarre! I've never seen the B1 bug which is why I've been plugging the workaround.

Has this been reported to the dev team?
xilman is offline   Reply With Quote
Old 2013-10-10, 13:21   #197
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

1,741 Posts
Default

No idea. I think the save/resume bug is known to at least one developer (Cyril?), but I don't know about the B1=1 bug.
wombatman is offline   Reply With Quote
Old 2013-10-10, 15:17   #198
xilman
Bamboozled!
 
xilman's Avatar
 
"π’‰Ίπ’ŒŒπ’‡·π’†·π’€­"
May 2003
Down not across

3×3,529 Posts
Default

Quote:
Originally Posted by wombatman View Post
No idea. I think the save/resume bug is known to at least one developer (Cyril?), but I don't know about the B1=1 bug.
Ho hum. Some times my style is just too oblique and a hint has to be hammered in with a length of two by four.

To state the bleedin' obvious: the bug should be reported to the GMP-ECM team, whether or not they've already heard of it.
xilman is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running CUDA on non-Nvidia GPUs Rodrigo GPU Computing 3 2016-05-17 05:43
Error in GMP-ECM 6.4.3 and latest svn ATH GMP-ECM 10 2012-07-29 17:15
latest SVN 1677 ATH GMP-ECM 7 2012-01-07 18:34
Has anyone seen my latest treatise? davieddy Lounge 0 2011-01-21 19:29
Latest version? [CZ]Pegas Software 3 2002-08-23 17:05

All times are UTC. The time now is 10:38.

Sat Feb 27 10:38:49 UTC 2021 up 86 days, 6:50, 0 users, load averages: 1.50, 1.41, 1.38

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.