mersenneforum.org  

Go Back   mersenneforum.org > Prime Search Projects > No Prime Left Behind

Reply
 
Thread Tools
Old 2012-02-20, 02:51   #23
Lennart
 
Lennart's Avatar
 
"Lennart"
Jun 2007

25×5×7 Posts
Default

Quote:
Originally Posted by vaughan View Post
@ Lennart: has anything changed in your windows 7z download package?

I have downloaded it a few times today and after I update the master_prpclient.ini config file with my ID details etc and put in the line containing the port 9000 stuff (server=G2000:100:1:noprimeleftbehind.net:2000) and //commenting out the other projects/ports the app fails with a Windows message (prpclient.exe is missing).

I have run the quad update batch file once (4-quad-update-prpclient.bat) and then try to run quad start (4-quad-start-prpclient.bat) and it says the prpclient.exe is missing. I also noticed that the 4 sub-directories that were created by the previous installation package are not made now with today's package (I guess that explains the missing prpclient.exe message).
No not the last 14 days.

When you run 4 core install script there shall be 4 prpclient-1-4.

If not there are something wrong.

I shall investigate..

Lennart
Lennart is offline   Reply With Quote
Old 2012-02-20, 02:57   #24
Lennart
 
Lennart's Avatar
 
"Lennart"
Jun 2007

25×5×7 Posts
Default

Quote:
Originally Posted by vaughan View Post
@ Lennart: has anything changed in your windows 7z download package?

I have downloaded it a few times today and after I update the master_prpclient.ini config file with my ID details etc and put in the line containing the port 9000 stuff (server=G2000:100:1:noprimeleftbehind.net:2000) and //commenting out the other projects/ports the app fails with a Windows message (prpclient.exe is missing).

I have run the quad update batch file once (4-quad-update-prpclient.bat) and then try to run quad start (4-quad-start-prpclient.bat) and it says the prpclient.exe is missing. I also noticed that the 4 sub-directories that were created by the previous installation package are not made now with today's package (I guess that explains the missing prpclient.exe message).
What OS Win7 ?

Check that you have permission to create directory.

The same in linux and check that all scripts and bin files have execution permission.

I dowloaded and run the install script for 4 core and got 4 new folders and the apps in them.


Lennart

EDIT: You do it in the uncompressed folder ? :)

Last fiddled with by Lennart on 2012-02-20 at 03:04
Lennart is offline   Reply With Quote
Old 2012-02-20, 05:04   #25
vaughan
 
vaughan's Avatar
 
Jan 2005
Sydney, Australia

5×67 Posts
Default

Thanks all sorted now. I failed to run the install batch file, silly mistake huh! Only did the master and the update before trying start - forgot the install.

Yeah Win7.
vaughan is offline   Reply With Quote
Old 2012-02-20, 12:45   #26
AMDave
 
AMDave's Avatar
 
Jan 2006
deep in a while-loop

29216 Posts
Default

I'm 'trying' to use prpclient-5.0.5-windows.7z
Used the PRPNet client link in the 1st post in this thread and ended up here: http://uwin.mine.nu/PRPNet/
Can't see the older versions you guys are talking about.
Downloaded the 5.0.5 client.
The readme instructions need to be updated

1. unzip the 7z
2. open that folder
3. modify the file master_prpnet.ini with your settings
4. run the X-xxxx-install-prpclient.bat which will create the number of folders and copy in the programs to each (NB - it does NOT copy the INI file)
5. run the X-xxxx-update-prpclient-ini.bat (NB - this does copy the INI file)
6. run the X-xxxx-start-prpclient.bat

That 'should' get you going.

On Win7 64 however I have a 'failure to fly' with prpclient-5.0.5-windows.7z:

"Fatal error at setup : Number sent to gwsetup is too large for the FFTs to handle."

10 cores idling.

Has someone got a link to a PRPNet client that works that I can use?
TIA

Last fiddled with by AMDave on 2012-02-20 at 12:49
AMDave is offline   Reply With Quote
Old 2012-02-20, 13:15   #27
Mini-Geek
Account Deleted
 
Mini-Geek's Avatar
 
"Tim Sorbera"
Aug 2006
San Antonio, TX USA

17·251 Posts
Default

Quote:
Originally Posted by AMDave View Post
On Win7 64 however I have a 'failure to fly' with prpclient-5.0.5-windows.7z:

"Fatal error at setup : Number sent to gwsetup is too large for the FFTs to handle."

10 cores idling.

Has someone got a link to a PRPNet client that works that I can use?
TIA
Without being familiar with those setup scripts, it sounds more like a problem with LLR or PFGW than PRPnet. There are some builds of the latest LLR (3.8.7) at http://www.primegrid.com/forum_thread.php?id=4016. Assuming you have a non-AVX CPU, you'll want this link.
If you do need the PRPnet client: (this doesn't include setup scripts)
http://home.roadrunner.com/~mrodenki...pnet_5.0.6.zip
Mini-Geek is online now   Reply With Quote
Old 2012-02-20, 13:20   #28
odicin
 
Sep 2011
Potsdam, Germany

1608 Posts
Default

The installation looks correct, maybe there is an issue with the master_prpclient.ini.

Which parameters you set as startoption, stopoption and stopasapoption?

Have you commented out the servers you did not want to run?

Have you set the right apps, depending on the system you run (x86, x64, AVX?)

I tried to send you mine via PM, but I looks like there too many characters to send.

Regards Odi
odicin is offline   Reply With Quote
Old 2012-02-20, 13:45   #29
rogue
 
rogue's Avatar
 
"Mark"
Apr 2003
Between here and the

10110110101002 Posts
Default

Quote:
Originally Posted by AMDave View Post
"Fatal error at setup : Number sent to gwsetup is too large for the FFTs to handle."
Definitely an issue with llr or pfgw, most likely llr since it is base 2. Try a different build of llr.
rogue is offline   Reply With Quote
Old 2012-02-20, 13:51   #30
AMDave
 
AMDave's Avatar
 
Jan 2006
deep in a while-loop

2·7·47 Posts
Default

Quote:
Originally Posted by Mini-Geek View Post
...it sounds more like a problem with LLR or PFGW than PRPnet...
Alternatives tried and failed with same error.

odicin. Thanks. Config is correct.

EDIT -
I found an old set of 32-bit PRPNet binaries in my archive that I used successfully April last year.
Runs slow but at least it is stable and will produce some results.
2 days down and I have 1 core working. yay. I'll try to bring my enthusiasm tomorrow. :p

Last fiddled with by AMDave on 2012-02-20 at 14:07
AMDave is offline   Reply With Quote
Old 2012-02-20, 14:19   #31
Lennart
 
Lennart's Avatar
 
"Lennart"
Jun 2007

21408 Posts
Default

There are 3 llr in the folders and it will use the one you have in master ini file.

llr.exe
llravx.exe
llrCUDA.exe

In master ini what do you use here ?

// LLR can be downloaded from http://jpenne.free.fr/index2.html
// If your CPU is AVX capable, comment out the llr.exe line
// and uncomment the llravx.exe line
llrexe=llr.exe
// llrexe=llravx.exe

Lennart
Lennart is offline   Reply With Quote
Old 2012-02-20, 14:42   #32
AMDave
 
AMDave's Avatar
 
Jan 2006
deep in a while-loop

12228 Posts
Default

llr.exe in master ini

the point is moot.
I don't have time to do elimination testing right now and I lost the mood for it.
Timezone not working in my favour atm.

I'm now using the 32-bit binaries from April 2011 for this run.
1 laptop now on 2 cores

I was going to bring in several other boxen but I have spent more time on this than planned.
Maybe a couple more cores tomorrow.
AMDave is offline   Reply With Quote
Old 2012-02-20, 22:26   #33
Lumiukko
 
Mar 2011
Finland

1910 Posts
Default

Quote:
Originally Posted by gd_barnes View Post
...It is also best to set the cache to something in the vicinity of 2 to 10 pairs....
What is the max cache (how many wu's I can get from the server at a time)?
What is the expiration time of these wu's?

I am asking because I want to do some work offline, and need to know how long offline periods I can have.

--
Lumiukko
Lumiukko is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
PRPnet rally Apr. 18th-25th gd_barnes No Prime Left Behind 17 2012-04-26 11:54
LLRnet/PRPnet rally Oct. 27th-Nov. 3rd mdettweiler No Prime Left Behind 33 2010-12-24 19:16
LLRnet/PRPnet rally June 4th-6th gd_barnes No Prime Left Behind 61 2010-07-30 17:28
Rally Jan. 23rd-25th gd_barnes No Prime Left Behind 89 2009-01-25 22:59
LLRnet server rally port 300 May 23rd-25th gd_barnes No Prime Left Behind 172 2008-06-04 19:21

All times are UTC. The time now is 14:48.

Tue Aug 4 14:48:14 UTC 2020 up 18 days, 10:35, 0 users, load averages: 1.40, 1.38, 1.49

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.