mersenneforum.org  

Go Back   mersenneforum.org > New To GIMPS? Start Here! > Information & Answers

Reply
 
Thread Tools
Old 2011-12-12, 17:17   #1
Rafael
 

141238 Posts
Default When I run PRIME95, my computer threatens to turn off

The CPU temperature gets high really fast and I am forced to turn prime95 off before the computer shuts down. Is there a way around it(software, make prime95 use less cpu) or hardware(cool the processor) ?

It´s a desktop AMD 64 dual x2 4400.

Thanks,

Rafael
  Reply With Quote
Old 2011-12-12, 18:35   #2
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

219216 Posts
Default

Quote:
Originally Posted by Rafael View Post
The CPU temperature gets high really fast and I am forced to turn prime95 off before the computer shuts down.
Can you post your temperatures? High temperatures are normal with Prime95, but most likely they won't be too high. Your machine will likely be able to handle the heat.

Prime95 can be throttled to make it generate less heat. Most of us leave it running 24/7 at full power though.
Uncwilly is online now   Reply With Quote
Old 2011-12-12, 19:56   #3
moebius
 
moebius's Avatar
 
Jul 2009
Germany

1010011112 Posts
Default

Try to undervolt your cpu!
moebius is offline   Reply With Quote
Old 2011-12-12, 20:16   #4
bcp19
 
bcp19's Avatar
 
Oct 2011

7×97 Posts
Default

Is your heatsink fan running? Have you ever removed your heatsink? Without thermal paste between the heatsink and the CPU the heat disappation properties are greatly reduced. Also you need to make sure your heatsink and fan are not clogged with dust.
bcp19 is offline   Reply With Quote
Old 2011-12-12, 21:55   #5
Unregistered
 

2×4,789 Posts
Default

Quote:
Originally Posted by Uncwilly View Post
Can you post your temperatures? High temperatures are normal with Prime95, but most likely they won't be too high. Your machine will likely be able to handle the heat.
Using speedfan 4.40:
Before prime95 runs:
Fan 3054 rpm
Temp1:39C
Core:49

After it runs:
10 mins
temp1:71C,
core: 56C

It begins to beep,that´s when I shut down. I suspect it has to with the fact that I began to use other software at the time. If I don´t do anything else, it doesn´t beep.

Quote:
Originally Posted by Uncwilly View Post
Prime95 can be throttled to make it generate less heat. Most of us leave it running 24/7 at full power though.
How ? Configuration, or changing the code ? Some variable in prime.ini ?

Rafael
  Reply With Quote
Old 2011-12-12, 22:07   #6
rafael
 
Dec 2011

38 Posts
Default

Quote:
Originally Posted by bcp19 View Post
Is your heatsink fan running?dust.
Yes.

Quote:
Originally Posted by bcp19 View Post
Have you ever removed your heatsink?
No.

Quote:
Originally Posted by bcp19 View Post
Without thermal paste between the heatsink and the CPU the heat disappation properties are greatly reduced.
Yeah I am thinking about putting some. Lots of sites recommend it, so I assume it is safe.

Quote:
Originally Posted by bcp19 View Post
Also you need to make sure your heatsink and fan are not clogged with dust.
That´s a real problem, the box has holes for ventilation, but a lot of dust gets in. I guess I should leave cpu-intensive processes for when the
air conditioning is on and the windows are closed.

Rafael
rafael is offline   Reply With Quote
Old 2011-12-13, 02:44   #7
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×29×83 Posts
Default

I don't know if this is true or not, but it seems to me that old thermal paste could lose some of its heat conductivity. It might be worth unmounting the heatsink, cleaning it and the fan for dust, and then use the opportunity to apply new thermal paste (which should always be done after removing a heatsink).

I can't speak to old AMD's, but the AMD Phenom II I had ran fine at 65C, and the Intel Sandy Bridge worked fine at 80-85C (that's borderline though) but I've also heard AMD's are less temperature tolerant. I would try Googling the thermal tolerance of the Athlon? of Phenom? what exactly?

As for throttling, you can put

Throttle=N

in prime.txt, where N is a percentage. Note that instead of running at N all the time, it will run at 100% and then run really low and then run at 100% and cycle that way so that the running average is N. You can look in Task Manager to see what I mean. The other option is to simply run one worker instead of two, which will leave the other core unloaded and open to whatever else you're doing.

Last fiddled with by Dubslow on 2011-12-13 at 02:45
Dubslow is offline   Reply With Quote
Old 2011-12-13, 05:27   #8
Christenson
 
Christenson's Avatar
 
Dec 2010
Monticello

5·359 Posts
Default

Yep, thermal grease can dry out...especially the cheap stuff if it's an unknown...

It is very important to be clean (and if you are nuts, lap flat) the surfaces to be joined with the thermal paste...you want just enough to fill the microscopic gaps, no more....

And get the dust out!
Christenson is offline   Reply With Quote
Old 2011-12-13, 05:35   #9
rafael
 
Dec 2011

3 Posts
Default

It´s an Athlon, this table shows the 4400 series have a maximum temperatures ranging from 65 to 72.

http://www.hardwaresecrets.com/artic...perature/143/9

I found this on undoc.txt

"If you are running on a laptop or in a hot room and you want to slow the
program down to reduce heat, then you can add this line to prime.ini:
Throttle=n
where n is the number of milliseconds to sleep after each iteration."

I´ve set to 200 got my temp to 40C and about 20%/50% use of cpu.I hope such slow calculation is of any help. When I put some thermal paste I may lower the ms experimentally.

Thanks,

Rafael
rafael is offline   Reply With Quote
Old 2011-12-13, 12:15   #10
KyleAskine
 
KyleAskine's Avatar
 
Oct 2011
Maryland

2×5×29 Posts
Default

ANY calculation is a help! Thanks for participating!
KyleAskine is offline   Reply With Quote
Old 2012-01-02, 17:07   #11
jonthomson
 
jonthomson's Avatar
 
May 2007

D16 Posts
Default

Quote:
Originally Posted by rafael View Post
It´s an Athlon, this table shows the 4400 series have a maximum temperatures ranging from 65 to 72.

http://www.hardwaresecrets.com/artic...perature/143/9

I found this on undoc.txt

"If you are running on a laptop or in a hot room and you want to slow the
program down to reduce heat, then you can add this line to prime.ini:
Throttle=n
where n is the number of milliseconds to sleep after each iteration."
was searching for something like this. is it actually the number of milliseconds, or is it the percentage of time you want the program active? my version of undoc is saying that n should be the percentage of time you want it running, have shoved in 50 on mine (phenom was running at high 80's so kind of wanted it cooling down a tad, shoving in 50 gives temps of 40-odd)
jonthomson is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off GCC sse-using optimizations? ewmayer Programming 3 2016-09-30 07:15
Prime95 slowed down after I restarted computer ixfd64 Software 13 2010-12-18 06:56
prime95 slows computer after I stop Raterus Software 7 2006-08-14 12:42
turn off your integrated Snd card in CMOS nngs Hardware 0 2005-05-20 01:31
computer seems to LAg when Prime95 is running Firedog18 Hardware 2 2003-07-25 22:03

All times are UTC. The time now is 14:01.

Sun Sep 20 14:01:36 UTC 2020 up 10 days, 11:12, 1 user, load averages: 1.39, 1.36, 1.39

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.