mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2008-11-04, 19:11   #12
trif
 
trif's Avatar
 
Aug 2002

2×101 Posts
Default

I can't pull up my assigned page any longer, it gets a CGI timeout error. Someone else mentioned that the length of time required to pull up the assigned page suggests that an index is missing. I have more on my results page than assigned, and the results pull up quite quickly, so a missing index could be the issue.
trif is offline   Reply With Quote
Old 2008-11-05, 12:52   #13
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

ACC16 Posts
Default

Can you email Scott about this?
garo is offline   Reply With Quote
Old 2008-11-06, 03:12   #14
Old man PrimeNet
 
Old man PrimeNet's Avatar
 
Jan 2003
Altitude>12,500 MSL

101 Posts
Default

Trif emailed me earlier today. This bug is now fixed.
Old man PrimeNet is offline   Reply With Quote
Old 2009-08-14, 17:04   #15
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

22·3·17·47 Posts
Default

I have noticed a problem with some server assignments.
Occasionally, I will register a TF assignment, then when I check my assignments, I will see it as a LL.
Recently I played with a particular expo. 332194939. It showed as being assigned as LL to Anonymous for several months, but the TF was at 70 only, with no progress. So, I added it to 71 to my worktodo. I must have left it at the end of the worktodo as well as moving it to the top. I only manual com on that machine, I was just going to do the level and report it. So, I completed the bit level and com'ed. The results were submitted, no factor. Then after a few more items, the same expo was given an assignment id for the same bit level, but logged as an LL. I noticed this when I went to remove the asignment (I wasn't trying to filtch the expo, just to hike the bit level.)

This is not the only expo that I have seen in the 100m digit range that have LL assignments that have been static for months (no moving up in bit level on the TF below 75, for 4 or more months). I have noticed that the number of expos in the range assigned to LL goes up and down, but it does seem like some expos are stuck. The expo status report does not show a "last reported activity" date, only the date assigned. Is that a likely feature that might be added?
Uncwilly is online now   Reply With Quote
Old 2009-09-01, 00:52   #16
stars10250
 
stars10250's Avatar
 
Jul 2008
San Francisco, CA

3·67 Posts
Default

I have a different problem with server assignments that maybe someone has advice for. I'm working to achieve certain percentages in the various categories, so I sometimes switch my 18 cores between LL, DC, and TF. The problem is that the server doesn't like to do what I (think I) tell it. For example, I recently switched one core of a quad system to DC for a few weeks. Now I want to switch it back to LL. When I do so, however, it keeps downloading new DC assignments. I've even edited the DC assignments out of my worktodo, closed prime95 and re-opened it, and of course I have my worker windows all set to LL. But it goes ahead and downloads new DC jobs anyway. I have this problem on all of my machines, and they are each running slightly different versions of prime95. What am I doing wrong?
stars10250 is offline   Reply With Quote
Old 2009-09-01, 07:12   #17
cheesehead
 
cheesehead's Avatar
 
"Richard B. Woods"
Aug 2002
Wisconsin USA

170148 Posts
Default

Quote:
Originally Posted by Uncwilly View Post
I have noticed a problem with some server assignments.
Occasionally, I will register a TF assignment, then when I check my assignments, I will see it as a LL.
This might be related to what stars10250 reported in post #16 -- see below:

Quote:
Originally Posted by stars10250 View Post
< snip >
I sometimes switch my 18 cores between LL, DC, and TF. The problem is that the server doesn't like to do what I (think I) tell it. For example, I recently switched one core of a quad system to DC for a few weeks. Now I want to switch it back to LL. When I do so, however, it keeps downloading new DC assignments. I've even edited the DC assignments out of my worktodo, closed prime95 and re-opened it, and of course I have my worker windows all set to LL. But it goes ahead and downloads new DC jobs anyway. I have this problem on all of my machines, and they are each running slightly different versions of prime95. What am I doing wrong?
I think I know what's happening, and it's not your fault.

I just remembered that a while (several months? a year?) ago I reported on the same sort of problem, and what I found that caused it in v25 prime95.

There are, since v25 (or maybe v25.something) started, TWO places where worktype assignment preferences are stored: BOTH local.txt and prime.txt !!

When you enter a worktype preference in PrimeNet, it goes in one of those (local.txt, IIRC), but when you enter a worktype preference in prime95, it goes in the other (prime.txt, IIRC).

Obviously, this dual storage setup has a potential for conflict.

When you first look at the files, you might not notice the duplication, because different keywords are used in the two files!

local.txt uses "SrvrPO1=".

prime.txt uses "WorkPreference=".

Both are followed by the worktype code numbers, such as 4 or 101, and the numbers mean the same in each file. (That is, "SrvrPO1=4" in local.txt means the same as "WorkPreference=4" in prime.txt.)

If the worktypes are specified in some (most?) circumstances, they apparently are synchronized, but if specified in another circumstance, they are not synchronized -- as you reported.

Those are all the details I recall. I'll try to find the thread where I posted them originally.

Edit: I've deleted my workaround recommendation in light of Jacob's warning and superior suggestions in post #18.

Last fiddled with by cheesehead on 2009-09-01 at 08:08 Reason: Thanks, Jacob!
cheesehead is offline   Reply With Quote
Old 2009-09-01, 07:42   #18
S485122
 
S485122's Avatar
 
Sep 2006
Brussels, Belgium

2·5·167 Posts
Default

Quote:
Originally Posted by cheesehead View Post
local.txt uses "SrvrPO1=".
George warned against editing the Srvrxxx lines in local.txt. "SrvrPxx means "don't mess with this setting"." Cfr http://www.mersenneforum.org/showpos...0&postcount=42

The locally set preferences (set using the Prime95 interface) SHOULD take precedence above the server set preferences (My Account / CPUs / ...)

Stars10250 : do your cores satisfy the assignment rules ? If they do, I would change worker preferences by changing them with the GUI interface of Prime95 (official version 25.9, latest version 25.11) Then I would communicate with the server by forcing a manual communication. Then I would check via the PrimeNet site if everything is OK. Then only I would UNRESERVE the offending workunits assigned (by bluntly removing them from your worktodo file, they will only expire after 90 days and this could upset some people that want to see the trailing edge cleared up ;-)

If the problem persists, send your configuration and log files to George for debugging.

Jacob
S485122 is offline   Reply With Quote
Old 2009-09-01, 15:23   #19
stars10250
 
stars10250's Avatar
 
Jul 2008
San Francisco, CA

3·67 Posts
Default

Quote:
Originally Posted by S485122 View Post
... do your cores satisfy the assignment rules ...
I suspect they do....my slowest system is a Q9550 quad at stock 2.8 GHz. (Where are the rules posted btw?) The system currently giving me a problem with downloading more and more DC assignments is an i7 running 25.9 build 4, 64 bit. However I've had this same thing happen on other computers running various versions of 32 bit prime95. I have done what you said...change worker preferences, force manual communication, watch for assignments. Sometimes it will immediately go out and get new DC assignments and put them in my worktodo and they will also then show in the status report. Other times it will leave things alone for a while and then sneak the DC assignments back in later (probably when it connects to the server sometime later). I reserve a fair amount of work, usually around 3 months, so it lists out several exponents. Currently when asking for world record LL, I got 3 LL and 12 DC for one of my cores on the i7 (this is the core I switched to DC for a while). All the other cores have LL assignments. My aggravating work-around has been to wait until the day it gets to the DC assignment, stop it, and then give it one of my other LL assignments. Once it gets started on an LL, it won't stop. This is complicated with so many assignments and cores however.
stars10250 is offline   Reply With Quote
Old 2009-09-01, 16:27   #20
CADavis
 
CADavis's Avatar
 
Jul 2005
Des Moines, Iowa, USA

101010102 Posts
Default

Quote:
Originally Posted by stars10250 View Post
(Where are the rules posted btw?)
On the left side of the mersenne.org site, under PrimeNet Summary > Assignment Rules. http://mersenne.org/thresholds/

Last fiddled with by CADavis on 2009-09-01 at 16:27 Reason: changed worder for better clarification
CADavis is offline   Reply With Quote
Old 2009-09-01, 16:30   #21
Mini-Geek
Account Deleted
 
Mini-Geek's Avatar
 
"Tim Sorbera"
Aug 2006
San Antonio, TX USA

102538 Posts
Default

One workaround to your problem would be to request candidates from the manual testing page.
http://www.mersenne.org/manual_assignment/
Quote:
Originally Posted by stars10250 View Post
(Where are the rules posted btw?)
http://www.mersenne.org/thresholds/
Mini-Geek is online now   Reply With Quote
Old 2009-09-01, 17:30   #22
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

22·1,873 Posts
Default

Check prime.log for error messages (in either the setting of the work preference or in the getting of assignments).

Also, after changing your work preference and doing a communication with the server, make sure the work preference as reported on the web pages agrees with the work preference reported by prime95. If they are not the same, something went wrong in the synching process.

Last fiddled with by Prime95 on 2009-09-01 at 17:32
Prime95 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Expired assignment kracker PrimeNet 23 2016-01-26 20:41
new assignment esakertt PrimeNet 6 2012-11-09 19:51
Assignment key Unregistered Information & Answers 4 2012-09-24 15:34
Want New Assignment Unregistered Information & Answers 1 2012-03-28 00:02
Old Assignment Primeinator PrimeNet 4 2009-06-04 22:35

All times are UTC. The time now is 00:36.

Wed May 19 00:36:12 UTC 2021 up 40 days, 19:17, 0 users, load averages: 1.79, 2.04, 2.00

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.