mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2018-05-23, 16:27   #1
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

11100111112 Posts
Question Run down the queue on MPRIME without quitting GIMPS

Prime95 has a setting under Options/Preferences where you can set the "Days of work to queue up" to a value of 0. This is useful if you want the PC to stop looking for new assignments but finish all current assignments, without having to unreserve exponents or quit GIMPS.

Is there a way to accomplish the same thing in MPRIME (Linux)? If I open the menu there and select item #14 (Options/Preferences), I cannot enter 0 as the value, it asks me to enter at least 1.

Nor can I set the queue to 0 by going to my GIMPS account at mersenne.org and changing the value there -- this, too, required me to enter at least 1.

Is there any way to do what I'm trying to do by changing some setting in MPRIME, or at least by fiddling with a configuration file?

Thanks.
Rodrigo is offline   Reply With Quote
Old 2018-05-23, 17:13   #2
GP2
 
GP2's Avatar
 
Sep 2003

29·89 Posts
Default

You can edit the file prime.txt and modify the DaysOfWork= line to set it to 0.

I have done this before. I don't remember whether or not this requires stopping the mprime process first, it might not be necessary.
GP2 is offline   Reply With Quote
Old 2018-05-23, 17:35   #3
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

32·103 Posts
Default

That did the trick, thanks!

I'll report back if MPRIME complains at some later point, but it's working for now at least.
Rodrigo is offline   Reply With Quote
Old 2018-05-23, 22:31   #4
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

23×359 Posts
Default

Quote:
Originally Posted by GP2 View Post
You can edit the file prime.txt and modify the DaysOfWork= line to set it to 0.

I have done this before. I don't remember whether or not this requires stopping the mprime process first, it might not be necessary.
Any change to prime.txt and local.txt requires that mprime be stopped.
Mark Rose is offline   Reply With Quote
Old 2018-05-24, 06:11   #5
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

32·103 Posts
Default

I can confirm that the new setting didn't stick when it was changed earlier today while MPRIME was running. I checked tonight and DaysOfWork was back at 1. Tonight I stopped the program (but did not close it) and edited Prime.txt, then resumed MPRIME.

We'll see what happens. Next try, if necessary, will be to exit MPRIME altogether and then change the setting.

Last fiddled with by Rodrigo on 2018-05-24 at 06:13
Rodrigo is offline   Reply With Quote
Old 2018-05-24, 16:24   #6
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×2,399 Posts
Default

For what it's worth, despite the menus being somewhat bombastic about it, all that is done by the "Quit GIMPS" options is that it adds NoMoreWork=1 to prime.txt. That's all. It doesn't delete account data or results or assignments or anything, it just stops acquiring work. Removing that line or changing it to 0 results in getting work again according to settings. So really the "Quit GIMPS" description is something of a misnomer, targeted at the broader distributed computing/home volunteers group who otherwise don't do much fiddling around on computers.
Dubslow is offline   Reply With Quote
Old 2018-05-24, 21:29   #7
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

32·103 Posts
Default

Huh, so "Quit GIMPS" sounds more drastic than it really is. Thank you. I did think that it meant that the PC's listing on PrimeNet would get wiped out. So I ignored that setting, since I was looking more for a "leave of absence" than for it to "quit" altogether.

BTW I can also confirm now that pausing MPRIME without closing the terminal window or shutting the program down, then editing "DaysOfWork" to 0, does yield the desired result: the remaining exponents are getting done and no new work is being received.

Thanks everyone for your help.
Rodrigo is offline   Reply With Quote
Old 2018-05-25, 13:26   #8
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

3·23·43 Posts
Default

There is even a 3rd options for prime.txt to not receive any work:
MaxExponents=0


This option is also useful to give finer control of how much work you receive:
MaxExponents=1
will only give you one work line no matter how long this takes, even if it is ECM CF that takes only maybe 30 min.
ATH is online now   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast Breeding (guru management) VictordeHolland NFS@Home 2466 2020-09-20 06:51
Improving the queue management. debrouxl NFS@Home 10 2018-05-06 21:05
split a prime95 queue & client installation joblack Information & Answers 1 2009-01-06 08:45
Accidentally Quitting GIMPS - Question fes016 PrimeNet 1 2008-05-10 16:32
Problem with mprime (Fixed with mprime -d) antiroach Software 2 2004-07-19 04:07

All times are UTC. The time now is 21:38.

Thu Oct 22 21:38:43 UTC 2020 up 42 days, 18:49, 0 users, load averages: 1.92, 1.96, 1.94

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.