mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2009-04-26, 14:13   #1
spaz
 
Apr 2009

248 Posts
Default mprime starting

I can install mprime successfully and run it the first time without a problem, and have trial factored, bench tested and stress tested without any errors. But when I do test/stop and then test/exit, or just test/exit, (stop the worker nicely) I can not restart mprime, as far as I can tell it is stuck somewhere in the reading of files. I usuually start mprime by;

$./mprime

but now when I do that it just puts out a newline and freezes, (two hours and nothing has changed, no process activity being done. I can however get mprime to start again by deleting all the backup files, logs, and worktodo. But when I do that I must reconnect to primenet as a new computer and recieve new assignments/enter the computer as a new computer. And I must not inturupt the thread to shut it down or restart computer until each assignment is done.

So I guess what am I doing wrong? mprime is not returning any errors, when there is no existing files it works fine, and I would like to keep running it, but this is kinda killing the point of constant running in the background If I must maintain it everytime I start the computer... If it helps I'm running Fedora Core 10, 2.6.27 kernel, mprime 25.9.
spaz is offline   Reply With Quote
Old 2009-04-26, 20:59   #2
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3·2,083 Posts
Default

The reason why it's not producing any screen output is because it's being run in silent mode. In order to make it output to the terminal, you need to run it as:

./mprime -d

To get a menu on the terminal (think phone menu type), run it as:

./mprime -m

From there, you can set various options, as well as choose a menu item that runs the client normally (with screen output enabled).

Your client has indeed been running exactly as it should; just without any screen output. The -d option is the simplest and easiest way to get that output; I usually run my clients with -d and only use -m when I need to configure options.

I agree that it is confusing--in fact, probably it should be changed so that -d is the default, and instead silent mode is produced by a command line flag. I'm not sure why it was ever done this way in the first place.

Hope this helps!
mdettweiler is offline   Reply With Quote
Old 2009-04-27, 02:54   #3
spaz
 
Apr 2009

22·5 Posts
Default

I apologize. I should have found that myself... I guess I read it wrong... Alright so I will add that to an alias or script so it appears as my default option.... Thank you very much.
spaz is offline   Reply With Quote
Old 2009-04-27, 06:37   #4
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3·2,083 Posts
Default

Quote:
Originally Posted by spaz View Post
I apologize. I should have found that myself... I guess I read it wrong... Alright so I will add that to an alias or script so it appears as my default option.... Thank you very much.
Ah, don't kick yourself too hard about it...most of us have made that same mistake when we were first getting set up with mprime.

BTW, does anyone around here know why mprime was originally designed to default to silent mode? I would think that the most logical configuration would be to have screen output enabled by default (since that's what most people use) and have quiet mode enabled with a command line flag (-q, maybe).
mdettweiler is offline   Reply With Quote
Old 2009-05-01, 02:51   #5
joblack
 
joblack's Avatar
 
Oct 2008
n00bville

72510 Posts
Default

Quote:
Originally Posted by mdettweiler View Post
Ah, don't kick yourself too hard about it...most of us have made that same mistake when we were first getting set up with mprime.

BTW, does anyone around here know why mprime was originally designed to default to silent mode? I would think that the most logical configuration would be to have screen output enabled by default (since that's what most people use) and have quiet mode enabled with a command line flag (-q, maybe).
I suppose its in silent mode because if it wouldn't be in it and working in the background it would dump your log files to the limit ...
joblack is offline   Reply With Quote
Old 2009-05-02, 08:23   #6
imwithid
 
imwithid's Avatar
 
Apr 2009
Venice, Chased by Jaws

1278 Posts
Default Ubuntu 9.04

I am running a dual boot (Ubuntu 9.04 x64 and XP-64) and I have tried to run mprime from the same folder as I have in XP. I have no problem accessing the folder. Rather I cannot get mprime to run. I receive the following error:

libcurl.so.4: cannot open shared object file: No such file or directory

This shortly after running ./mprime -m

I am a noob when it comes to linux. Is there an installation command that I am to run prior to running mprime?

Thanks in advance.
imwithid is offline   Reply With Quote
Old 2009-05-02, 08:31   #7
imwithid
 
imwithid's Avatar
 
Apr 2009
Venice, Chased by Jaws

3×29 Posts
Default Last post ....

After looking for the answer for about an hour, I guess I became impatient. Disregard the last question. I found it.

For those who were looking for it, simply install curl:

sudo apt-get install cur.

D
imwithid is offline   Reply With Quote
Old 2009-05-02, 11:14   #8
lfm
 
lfm's Avatar
 
Jul 2006
Calgary

52·17 Posts
Default

Quote:
Originally Posted by mdettweiler View Post
Ah, don't kick yourself too hard about it...most of us have made that same mistake when we were first getting set up with mprime.

BTW, does anyone around here know why mprime was originally designed to default to silent mode? I would think that the most logical configuration would be to have screen output enabled by default (since that's what most people use) and have quiet mode enabled with a command line flag (-q, maybe).
You really think most people run it with screen output all the time? I'd have thought most people would run it in the background without a terminal attached like I do.

It maybe depends on what you are used to. If you are used to a PC with Microsoft Windows you maybe expect to have a window for each of the things you do. If you come from a Unix background you are more comfortable with silent background processes.
lfm is offline   Reply With Quote
Old 2009-05-02, 17:40   #9
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

11000011010012 Posts
Default

Quote:
Originally Posted by lfm View Post
You really think most people run it with screen output all the time? I'd have thought most people would run it in the background without a terminal attached like I do.

It maybe depends on what you are used to. If you are used to a PC with Microsoft Windows you maybe expect to have a window for each of the things you do. If you come from a Unix background you are more comfortable with silent background processes.
Actually, if I was going to run it in the background, I would definitely want to run it *with* screen output so that I can redirect it to a file. (Maybe I'm just a sucker for checking on the progress of my distributed computing applications. )

(FYI: I used mainly Windows at first, though I've used Linux rather heavily for the last couple of years and am quite familiar with the ins and outs of it.)
mdettweiler is offline   Reply With Quote
Old 2009-05-03, 06:41   #10
imwithid
 
imwithid's Avatar
 
Apr 2009
Venice, Chased by Jaws

3×29 Posts
Default

Quote:
Originally Posted by lfm View Post
You really think most people run it with screen output all the time? I'd have thought most people would run it in the background without a terminal attached like I do.

It maybe depends on what you are used to. If you are used to a PC with Microsoft Windows you maybe expect to have a window for each of the things you do. If you come from a Unix background you are more comfortable with silent background processes.
How would you run it without the attachment to the terminal screen? If you wanted to refer to the application (terminating it later at will), how would this be accomplished?

I've been on and off with Linux but I'm trying to learn more about it so that I don't have to depend so much on Windows. Besides, I find that per iteration time is better on Ubuntu 9.04 x64 than on my XP-64 (between 1-3% - comparatively given a dual boot on the same hardware).
imwithid is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting mprime at boot daxmick PrimeNet 18 2019-03-17 01:12
mfaktc not starting in Mac OSX bayanne GPU Computing 0 2014-05-10 14:38
Disk starting to go Chuck Hardware 8 2013-05-20 06:40
starting mprime at boot time on a multicore pc tha Software 6 2008-10-15 23:38
Automatically starting mprime. xode Software 8 2004-10-20 14:47

All times are UTC. The time now is 13:19.

Sat Jul 4 13:19:02 UTC 2020 up 101 days, 10:52, 2 users, load averages: 2.07, 1.89, 1.76

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.