mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > GMP-ECM

Reply
 
Thread Tools
Old 2006-11-01, 22:46   #1
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

22×1,873 Posts
Default mac os x

Anyone try to compile gmp under OS X?

I tried

./configure
make
make check

and got several undefined symbols.

Note this is GMP, not GMP-ECM.
Prime95 is offline   Reply With Quote
Old 2006-11-01, 23:54   #2
rogue
 
rogue's Avatar
 
"Mark"
Apr 2003
Between here and the

32·701 Posts
Default

I have, but only on PPC. Have you checked the gmp-discuss mailing list? I believe that someone had worked out some of the issues with building GMP on MacIntel.
rogue is offline   Reply With Quote
Old 2006-11-11, 02:16   #3
Sushi
 

33×167 Posts
Default

I can built GMP-4.2.1 on MacIntel OS X (10.4.6, Xcode 2.3).

compiled with:

export CFLAGS="-arch i686"
./configure --host=none-apple-darwin --enable-cxx
make LDFLAGS="-arch i686"
make
make check
sudo make install
  Reply With Quote
Reply

Thread Tools


All times are UTC. The time now is 14:29.

Fri May 14 14:29:03 UTC 2021 up 36 days, 9:09, 0 users, load averages: 2.21, 2.07, 2.02

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.