mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2010-04-11, 19:03   #133
BarboneNet
 
Apr 2010
Italy

2 Posts
Default

hi guys, how can i test more ram with prime blend test??
i use 8gb of ram, and prime test only 2gb.....any solution?

can Prime95 resolve the bug of red tray icon, i the future release of 64bit version??

thanks
BarboneNet is offline   Reply With Quote
Old 2010-04-12, 05:35   #134
lfm
 
lfm's Avatar
 
Jul 2006
Calgary

52×17 Posts
Default

Quote:
Originally Posted by BarboneNet View Post
hi guys, how can i test more ram with prime blend test??
i use 8gb of ram, and prime test only 2gb.....any solution?

can Prime95 resolve the bug of red tray icon, i the future release of 64bit version??

thanks
To test ram don't use prime95, use memtest86.
lfm is offline   Reply With Quote
Old 2010-04-12, 18:14   #135
CADavis
 
CADavis's Avatar
 
Jul 2005
Des Moines, Iowa, USA

2·5·17 Posts
Default

first click on Blend and see the settings that are greyed out change to the Blend settings. Then click on Custom and the settings stay the same, and you can change the amount of memory to use.
Attached Thumbnails
Click image for larger version

Name:	blend_custom.png
Views:	109
Size:	35.1 KB
ID:	5013  
CADavis is offline   Reply With Quote
Old 2010-04-14, 11:55   #136
BarboneNet
 
Apr 2010
Italy

102 Posts
Default

Quote:
Originally Posted by CADavis View Post
first click on Blend and see the settings that are greyed out change to the Blend settings. Then click on Custom and the settings stay the same, and you can change the amount of memory to use.
yes, i already use this method;)

I open and edit prime.txt, then I save the file and i make it only readable.

there is a solution for the red tray icon bug, for Prime95 64bit???
BarboneNet is offline   Reply With Quote
Old 2010-04-14, 19:31   #137
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

6,833 Posts
Default

Quote:
Originally Posted by BarboneNet View Post
there is a solution for the red tray icon bug, for Prime95 64bit???
There is no known fix - I did try. If I use the same code that Prime95 32-bit uses there are occasional deadlocks. It has something to do with the main thread trying to change the icon color, but if a new thread is initializing the new thread hangs. I don't understand it all. Perhaps MSVC 2008 or MSVC 2010 would fix the problem.

The workaround doesn't "fix" the problem. It only eliminates the most common cause of the hang.
Prime95 is offline   Reply With Quote
Old 2010-04-14, 19:51   #138
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

22·5·401 Posts
Default

Quote:
Originally Posted by Prime95 View Post
There is no known fix - I did try. If I use the same code that Prime95 32-bit uses there are occasional deadlocks.

The workaround doesn't "fix" the problem. It only eliminates the most common cause of the hang.
I have had the icon be red when it should be green on occasion with the 32 bit code. Often a start and stop workers will fix it. IIRC it happens with manual communications.
Uncwilly is online now   Reply With Quote
Old 2010-04-15, 20:17   #139
harlee
 
harlee's Avatar
 
Sep 2006
Odenton, MD, USA

22×41 Posts
Default

I'm doing P-1 factoring on small Mersenne numbers, currently in the 5M range. I've noticed that lately that each time I find a factor, the client reports the results to the server then crashes, leaving the prime.spl file behind, so when the program starts back up to reports the same results to the server.
harlee is offline   Reply With Quote
Old 2010-04-15, 20:29   #140
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

2×2,143 Posts
Default

Quote:
Originally Posted by harlee View Post
I'm doing P-1 factoring on small Mersenne numbers, currently in the 5M range. I've noticed that lately that each time I find a factor, the client reports the results to the server then crashes, leaving the prime.spl file behind, so when the program starts back up to reports the same results to the server.
I have been getting that intermittently in the 50M range too....so far only on either of my E6550 Dual Cores.

See my note here: http://www.mersenneforum.org/showpos...&postcount=320
and the reply from sdbardwick

I have two pains with P-1
1. If it tries to report in a P-1 completion when the server is down; then when it comes back up it tells me "result not needed" and I do NOT get the points ... 6 so far in 2010 ... whether it finds a factor or not. George has been in touch with me over this one.

2. The one you mention here....though not ALL factors found cause a crash ... maybe 4 in the last couple years ... I still get the "result not needed" however in this case I DO get the points.

Last fiddled with by petrw1 on 2010-04-15 at 20:30
petrw1 is offline   Reply With Quote
Old 2010-04-15, 22:44   #141
amatheu
 

32·5·7·11 Posts
Default Prime95 show my Q9450 with 6mb L2 cache! WHY?

Hi, I run Prime95 in CPU settings and Information show my Q9450 as 32KB L1 and 6MB L2, I know thisproccessor is 12MB L2 why is this difference?

Thanks
  Reply With Quote
Old 2010-04-16, 10:14   #142
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

23·3·7·17 Posts
Default

from: http://en.wikipedia.org/wiki/Yorkfie...r%29#Yorkfield
Quote:
Yorkfield (codename for the Core 2 Quad Q9x5x series and Xeon X33x0 series) features a dual-die quad core design with two unified 6 MB L2 caches
You effectively have two dual-core CPUs in there with 6MB L2 cache each.
James Heinrich is online now   Reply With Quote
Old 2010-05-13, 00:53   #143
joblack
 
joblack's Avatar
 
Oct 2008
n00bville

72510 Posts
Default Bug in the mprime Linux 64 version?

The Linux version (64 Bit) has some performance problems. Here's my configuration:

joblack@tron:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU T4300 @ 2.10GHz
stepping : 10
cpu MHz : 2100.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm
bogomips : 4189.44
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU T4300 @ 2.10GHz
stepping : 10
cpu MHz : 2100.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm
bogomips : 4189.45
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual

------------------------
joblack@tron:~$ uname -a
Linux tron 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux
------------------------
top - 02:51:01 up 11 min, 3 users, load average: 1.11, 1.47, 0.88
Tasks: 162 total, 2 running, 160 sleeping, 0 stopped, 0 zombie
Cpu(s): 8.0%us, 6.4%sy, 55.9%ni, 21.5%id, 0.0%wa, 3.3%hi, 4.9%si, 0.0%st
Mem: 1923612k total, 1907840k used, 15772k free, 57272k buffers
Swap: 4891784k total, 0k used, 4891784k free, 1192140k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2298 joblack 30 10 173m 55m 1520 S 125 3.0 13:29.37 mprime
4025 root 20 0 26260 2064 1728 R 10 0.1 0:45.65 http
3723 joblack 20 0 887m 272m 37m S 7 14.5 3:06.73 xulrunner-stub
----------------------
The Linux mprime performance is half of the Windows performance. It might be a problem with the processor recognition or the processor affinity.
joblack is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prime95 version 27.3 Prime95 Software 148 2012-03-18 19:24
Prime95 version 26.3 Prime95 Software 76 2010-12-11 00:11
Prime95 version 25.5 Prime95 PrimeNet 369 2008-02-26 05:21
Prime95 version 25.4 Prime95 PrimeNet 143 2007-09-24 21:01
When the next prime95 version ? pacionet Software 74 2006-12-07 20:30

All times are UTC. The time now is 13:44.

Tue May 26 13:44:47 UTC 2020 up 62 days, 11:17, 1 user, load averages: 1.03, 1.53, 1.63

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.