mersenneforum.org  

Go Back   mersenneforum.org > Prime Search Projects > No Prime Left Behind

Reply
 
Thread Tools
Old 2010-09-02, 16:37   #1
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

186916 Posts
Exclamation Server outrages

I've created this thread so we don't keep cluttering up the News thread with various posts related to server outages. They don't exactly fit too well in the News thread, but until now that's been the best place to put them. I've also moved the conversations related to the last two outages here.

From now on, if the server goes offline, post about it here, NOT in the News thread.

Edit (5/4/11): if for some reason the noprimeleftbehind.net email services go down (they're hosted on Google Apps separately from our other services, but a DNS problem could still potentially take them down), you won't be able to email me at my usual contact address, max@noprimeleftbehind.net. If that happens, use max@noprimeleftbehind.net.test-google-a.com instead--it will get to the same place and is completely independent of our DNS records.

Max

Last fiddled with by mdettweiler on 2011-05-04 at 18:09
mdettweiler is offline   Reply With Quote
Old 2010-09-03, 07:09   #2
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default Server outages

Gary just sent me a text message informing that there's a power outage over on his end right now, and the internet is out as well. (Since his router equipment is on UPS backup along with the server machine, most likely the cable lines are down as well as power.)

I got that message about an hour ago, so it still hasn't been fixed yet. Hopefully it will be fixed by morning.
mdettweiler is offline   Reply With Quote
Old 2010-09-03, 07:39   #3
gd_barnes
 
gd_barnes's Avatar
 
May 2007
Kansas; USA

2×5,077 Posts
Default

Everything is back up and running.

I don't understand why every time that I have a power outage, the internet goes out also despite everything being plugged into a UPS backup with all of the router/modem still having lights flashing (although not the ones that are needed on the modem). Unfortunately the main power lines are above ground on the main street near me (which is usually where the problem is) although the lines to the houses are underground but all of the cable lines are underground. Something just doesn't seem quite right about what happens. It makes the UPS backup almost pointless other than a convienience to avoid having to jump through all of the hoops of restarting the server machine.

But...in this case, the outage was 1-1/2 hours and my backup was exhausted at 1-1/4 hours so I was completely black for about 15 mins. So we would have had an outage regardless of the UPS this time around.

The outages seem to be virtually unrelated to weather. Severe storms seem to rarely knock it out. Although it rained most of the day here today, it was virtually perfectly clear when it went out near 1 AM CDT (6 AM GMT). It's the longest outage I've had in nearly 2 years so the UPS backup is sufficient a large majority of the time. The problem is the loss in internet connection, which I can't quite get a handle on right now.


Gary
gd_barnes is offline   Reply With Quote
Old 2010-09-03, 07:49   #4
henryzz
Just call me Henry
 
henryzz's Avatar
 
"David"
Sep 2007
Cambridge (GMT)

13×19×23 Posts
Default

Quote:
Originally Posted by gd_barnes View Post
I don't understand why every time that I have a power outage, the internet goes out
It will be something that your ISP uses that is lacking in electricity. In England that would be the exchange or maybe the roadside box. It surprises me that they don't have some sort of UPS system.
henryzz is offline   Reply With Quote
Old 2010-09-03, 17:06   #5
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3·2,083 Posts
Default

Quote:
Originally Posted by henryzz View Post
It will be something that your ISP uses that is lacking in electricity. In England that would be the exchange or maybe the roadside box. It surprises me that they don't have some sort of UPS system.
My thought exactly--it's pretty much the same here in the US. I was going to mention the possibility of a roadside box running off the same electric line to Gary last night but didn't want to pack too much into a text message.

Another possibility that came to mind at Gary's mention of the outages being seemingly unrelated to weather: possibly farther down the line, the cable lines go above ground, traveling along with the power lines. They could, therefore, be readily knocked out together.

Or a combination of the two could be the case: perhaps the power is often knocked out farther down (in this case, since it had been raining all day but the storm had moved on by the outage, maybe it hit lines farther down in Gary's curcuit). That then could have taken out one of the cable company's boxes.

Gary, I'd suggest calling your ISP and asking them about the internet outages. Tell them that despite your having UPS protection on your router, modem, and computer (best not to complicate things too much for them ), the internet goes out whenever there's a power outage. Perhaps they'll know right off the bat whether there's something further down that depends on the power lines. It could be a roadside box, or possibly even some kind of transfer box at the entry point to your house--the latter case in which you'll want to ask them "how can I put a UPS on that too?"
mdettweiler is offline   Reply With Quote
Old 2010-09-05, 22:32   #6
Flatlander
I quite division it
 
Flatlander's Avatar
 
"Chris"
Feb 2005
England

31×67 Posts
Default

G3000 is not responding.
Flatlander is offline   Reply With Quote
Old 2010-09-05, 22:38   #7
kar_bon
 
kar_bon's Avatar
 
Mar 2006
Germany

52·113 Posts
Default

Quote:
Originally Posted by Flatlander View Post
G3000 is not responding.
Seems all servers are offline. I've PMed Max 10min ago and he's offline now, hope he fixes it.

Just got answer from Max: Seems a power outrage and tries to contact Gary.

Last fiddled with by kar_bon on 2010-09-05 at 22:44
kar_bon is offline   Reply With Quote
Old 2010-09-05, 22:44   #8
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

Quote:
Originally Posted by kar_bon View Post
Seems all servers are offline. I've PMed Max 10min ago and he's offline now, hope he fixes it.

Just got answer from Max: Seems a power outrage and tries to contact Gary.
Yes, everything is down--probably another power outage. I've text messaged Gary about the problem and will report back here when I get a response.

Edit: just got a reply. It is another power outage.

Last fiddled with by mdettweiler on 2010-09-05 at 22:45
mdettweiler is offline   Reply With Quote
Old 2010-09-05, 22:52   #9
kar_bon
 
kar_bon's Avatar
 
Mar 2006
Germany

52·113 Posts
Default

... and back again? Stats-pages online!
kar_bon is offline   Reply With Quote
Old 2010-09-05, 22:58   #10
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

186916 Posts
Default

Quote:
Originally Posted by kar_bon View Post
... and back again? Stats-pages online!
Yes, everything looks online here as well. That was fast...

Well, at least the UPS was able to do us some good this time: the power outage was brief enough that when everything (including the internet) came back on, the server was able to pick up right where it left off without Gary having to restart all of the servers manually.

Oh, and BTW: I moved all posts related to this outage (and the previous one) to a new thread here. The News thread really was a bad place for those, since they're not exactly news items in the traditional sense.

Last fiddled with by mdettweiler on 2010-09-05 at 22:59
mdettweiler is offline   Reply With Quote
Old 2010-09-05, 23:00   #11
Flatlander
I quite division it
 
Flatlander's Avatar
 
"Chris"
Feb 2005
England

31·67 Posts
Default

Quote:
Originally Posted by Flatlander View Post
G3000 is not responding.
When the clients try to send results and the server is down they give up after a few minutes and close the clients. How do I extend that time?

edit re. answers below
Okay I've changed op_connect to TRUE, also changed the cache from 5 to 30.

Last fiddled with by Flatlander on 2010-09-05 at 23:17 Reason: addition
Flatlander is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
What exactly is sent to the server? paul0 NFS@Home 2 2015-03-12 23:00
Server bug -- new? Christenson Information & Answers 5 2011-07-12 21:44
Server Down? Grant Information & Answers 13 2008-11-24 19:37
New ECM-server available andi314 Factoring 3 2003-08-31 11:22
New Server Hardware and price quotes, Funding the server Angular PrimeNet 32 2002-12-09 01:12

All times are UTC. The time now is 01:25.

Sun Jul 12 01:25:26 UTC 2020 up 108 days, 22:58, 0 users, load averages: 1.36, 1.39, 1.27

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.