mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2003-07-05, 18:44   #1
markhl
 
Apr 2003
California

22·23 Posts
Default Windows XP logoff sometimes kills Prime95

Sometimes logging off kills Prime95 under Windows XP Pro SP1! When that happens, I lose a few hours of CPU time thinking that Prime95 is running. I never saw this in 2 years under Windows 2000 Pro.

I have checked the option Start at Bootup.
I install & run as the default user, not Administrator, but I think that has the same privilege as Administrator. (This is the user under which I have done all my installs.)

This happened most recently July 4 after upgrading to 23.5. Don't think it's related to upgrade; I have seen it before in XP, not after an upgrade.

Work-around: on this isolated PC I can just stay logged in, but Prime95 runs a few % slower because more processes are running.
markhl is offline   Reply With Quote
Old 2003-07-05, 18:47   #2
Xyzzy
 
Xyzzy's Avatar
 
"Mike"
Aug 2002

8,039 Posts
Default

Are you logging off or switching users? If you switch users all of your processes stay active...

(But I'd run the service anyways if I were you!)
Xyzzy is offline   Reply With Quote
Old 2003-07-05, 18:49   #3
markhl
 
Apr 2003
California

22·23 Posts
Default

Logging off.
Yes, I noticed that switching users keeps Prime95 running.
However logging off kills more processes and makes Prime95 run a little faster, so I want to logoff if I am away for a while.
markhl is offline   Reply With Quote
Old 2003-07-05, 19:21   #4
xtreme2k
 
xtreme2k's Avatar
 
Aug 2002

2×3×29 Posts
Default

Similar to this problem?
http://www.mersenneforum.org/viewtopic.php?t=695
xtreme2k is offline   Reply With Quote
Old 2003-07-05, 20:56   #5
TTn
 

33·239 Posts
Default

Im not quite sure if this will help but did you try?


If you are running XP, you will also have to add prime95 to the start menu like so:
Click Windows start / settings / control panel / taskbar and start menu / start menu /
customize / add / browse, and point to prime95 in its directory/ OK / next /
startup / next / finish.

This is what LLR needs under XP.
  Reply With Quote
Old 2003-07-05, 22:34   #6
trif
 
trif's Avatar
 
Aug 2002

2·101 Posts
Default

Quote:
Originally Posted by TTn
Im not quite sure if this will help but did you try?


If you are running XP, you will also have to add prime95 to the start menu like so:
Click Windows start / settings / control panel / taskbar and start menu / start menu /
customize / add / browse, and point to prime95 in its directory/ OK / next /
startup / next / finish.

This is what LLR needs under XP.
You shouldn't have to do that. If the account has admin privileges, Prime95 installs as a service, otherwise it sets itself to run when the user logs in.

I would suggest that perhaps the account you are using doesn't have sufficient privileges to install services.
trif is offline   Reply With Quote
Old 2003-07-05, 23:26   #7
markhl
 
Apr 2003
California

22·23 Posts
Default

Thanks; Prime95 is installed as a service, so the account has enough privilege.

I checked some more things and could not reproduce the issue.
I tried exit or stop or (exit and restart) before EITHER logoff or reboot, and could not reproduce the problem.

So it is still an intermittent problem ...
markhl is offline   Reply With Quote
Old 2003-07-07, 13:50   #8
Reboot It
 
Reboot It's Avatar
 
Aug 2002
London, UK

7×13 Posts
Default

Something that I have found useful on odd occasions: while logged in as an Administrator (or equivalent) untick the Start at Bootup entry in the Options menu and then retick it. This has the effect of rewriting the necessary registry entry for you.

I have seen cases (IIRC) where the entry was ticked but the registry didn't have the relevant entry and Prime95 didn't start automatically. However I think this was when I had copied an installation including a skeleton Prime.INI onto a new PC for cloning purposes.

Incidentally if you untick the Start at Bootup entry and it is then greyed out, preventing you from reticking it, I would check your level of privileges...
Reboot It is offline   Reply With Quote
Old 2003-07-07, 16:00   #9
markhl
 
Apr 2003
California

22·23 Posts
Default

Thanks! Users and Passwords confirmed that my account is an administrator account. (That is not explicitly called Administrator, unlike Windows 2000.)

Yes, I unticked the Start at Bootup entry in the Options menu and then reticked it. Will see how that goes. It was greyed out after that; I exited and restarted, then it was not greyed out.

I may have found the problem: under XP and maybe under 2000, if I start Prime95 by double-clicking Prime95.exe, then Control Panel -> Administrative Tools -> Services tells me that the Prime95 service is not started! In future I will always start Prime95 from the Services window: right-click and choose Start. Maybe I should also Stop it from there.
markhl is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prime95 on Windows 7? ixfd64 Software 30 2010-07-27 10:06
Windows 7 Windows Update & Prime95 issue!!! Unregistered Information & Answers 14 2010-04-10 21:47
Prime 95 kills CPUs? BlackOmega Information & Answers 6 2010-03-01 07:32
How do I logoff without clearing the cookies? retina Forum Feedback 12 2006-11-12 07:53
kernel grsecurity kills mprime gue Software 0 2003-12-06 17:22

All times are UTC. The time now is 19:31.

Fri Apr 16 19:31:34 UTC 2021 up 8 days, 14:12, 1 user, load averages: 1.71, 1.89, 1.82

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.