mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2020-06-11, 01:16   #529
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

1011011100102 Posts
Default

Quote:
Originally Posted by pepi37 View Post
My CPU has 12 cores ( SMT is turned off)
Why?
James Heinrich is offline   Reply With Quote
Old 2020-06-11, 22:10   #530
Viliam Furik
 
Jul 2018
Martin, Slovakia

2·41 Posts
Default

Quote:
Originally Posted by pepi37 View Post
I become proud owner of AMD 3900X.
So I try to benchmark it with mprime and found one interesting bug.
My CPU has 12 cores ( SMT is turned off)
So I can have 1*12 2*6 3*4 *4*3 6*2 and 12*1 worker
When I start that to benchmark got next error


[Worker #1 Jun 11 01:41:36] Timing 240K all-complex FFT, 12 cores, 3 workers. [Jun 11 01:41:36] Error setting affinity to core #13. There are 12 cores.


Regardless this it looks like benchmark is done. On windows benchmark is not started just finished.
I have also experienced this. I have 3900X, too, and I was doing exactly the same worker count benchmark, however on higher FFTs, but that doesn't matter...

But I have also encountered this odd thing:

Timings for 5120K FFT length (12 cores, 6 workers): 69.64, 34.00, 69.30, 34.19, 22.20, 22.07 ms. Throughput: 177.79 iter/sec.

Two workers are running 70 ms/iter, other two 34 ms/iter, and the last two are at 22 ms/iter. That happens only on 6 workers setting.

But I have also dug out this from bench file:

Timings for 1024K FFT length (12 cores, 3 workers): 1.15, 1.13, 1.27 ms. Throughput: 2540.49 iter/sec.
Timings for 1120K FFT length (12 cores, 3 workers): 1.30, 1.30, 1.41 ms. Throughput: 2242.88 iter/sec.
Timings for 1152K FFT length (12 cores, 3 workers): 1.28, 1.24, 1.38 ms. Throughput: 2312.17 iter/sec.

The third worker was the one that requested extra core and was always noticeably slower. I stopped benchmark after these FFTs, so I would have to run it again to be able to compare for higher FFTs, but I am in the middle of running about 5-day lasting P-1 consuming 41 GB of memory, and that's a real pain to stop and rerun as I want to have it finished as soon as possible.
Viliam Furik is offline   Reply With Quote
Old 2020-06-12, 00:26   #531
pepi37
 
pepi37's Avatar
 
Dec 2011
After milion nines:)

2×653 Posts
Default

That is always case in this combination and must have connection with combination of L3 cache, and number of cores, and connection between cores and L3 cache modules


Timings for 480K all-complex FFT length (12 cores, 6 workers): 1.65, 0.85, 1.65, 0.86, 0.58, 0.58 ms. Throughput: 6990.51 iter/sec.



Timings for 240K all-complex FFT length (12 cores, 6 workers): 0.77, 0.42, 0.77, 0.42, 0.28, 0.29 ms. Throughput: 14412.90 iter/sec.
pepi37 is online now   Reply With Quote
Old 2020-06-12, 07:41   #532
pepi37
 
pepi37's Avatar
 
Dec 2011
After milion nines:)

2·653 Posts
Default

And one more thing: look at bench.txt


All cores has counted so there is 12 cores, but cores 3,7 and 11 is missing: instead bench text finished with core number 14: again maybe it is just way of counting cores...
Attached Files
File Type: txt bench.txt (2.5 KB, 7 views)
pepi37 is online now   Reply With Quote
Old 2020-06-12, 15:25   #533
Viliam Furik
 
Jul 2018
Martin, Slovakia

2×41 Posts
Default

Quote:
Originally Posted by pepi37 View Post
And one more thing: look at bench.txt


All cores has counted so there is 12 cores, but cores 3,7 and 11 is missing: instead bench text finished with core number 14: again maybe it is just way of counting cores...
Based on my not so good understanding of the hwloc library, I think it's some bug. PU numbers are good, the same as in HWinfo program, from 0 to n-1, but core numbers are just crazy.

Maybe George could know more...
Viliam Furik is offline   Reply With Quote
Old 2020-06-12, 15:38   #534
pepi37
 
pepi37's Avatar
 
Dec 2011
After milion nines:)

101000110102 Posts
Default

Quote:
Originally Posted by Viliam Furik View Post
Based on my not so good understanding of the hwloc library, I think it's some bug. PU numbers are good, the same as in HWinfo program, from 0 to n-1, but core numbers are just crazy.

Maybe George could know more...
Maybe we got some improvements if that is bug and bug is fixed? 😊
pepi37 is online now   Reply With Quote
Old 2020-06-12, 17:53   #535
storm5510
Random Account
 
storm5510's Avatar
 
Aug 2009
U.S.A.

133210 Posts
Default

I am currently running v29.8, Build 6. I am having to do something which I have never had to do before: Set the throttle value to 80. If I leave it at 100, the CPU temperature will climb into the upper 80's on the C scale. I am not comfortable allowing it to run like this, period. Running this throttle value, the temperature will briefly raise from 80°C to 82°C, then fall back as it should. The only major change to this system is the upgrade to Windows 10 v1909 which I did a few weeks ago. I do not run Prime95 much now as I mostly run Riesel's using LLR. I am in a waiting period so I thought I would run it to let the server know it was still here. I do not have a problem running it throttled even thought it takes more time to complete one assignment. This being P-1.
storm5510 is offline   Reply With Quote
Old 2020-06-16, 08:24   #536
kruoli
 
kruoli's Avatar
 
"Oliver"
Sep 2017
Porta Westfalica, DE

22·61 Posts
Default

Quote:
Originally Posted by kruoli View Post
The machine I am writing this on is running two workers (one ECM, one P-1). The interrupt is coming when the other worker's stage 2 is already running for a long time (in my case e. g. ten minutes in). Regarding your explanation, I totally get why the program would do that (and I also observed that previously), but in my case, there seems to be another trigger.
It occured to me that it is much worse for smaller exponents:
Code:
[Worker #2 Jun 16 08:51] Available memory is 14783MB.
[Worker #2 Jun 16 08:51] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
[Worker #8 Jun 16 08:52] Gerbicz error check passed at iteration 5000000.
[Worker #2 Jun 16 08:53] Available memory is 14783MB.
[Worker #2 Jun 16 08:53] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
[Worker #2 Jun 16 08:54] Available memory is 14783MB.
[Worker #2 Jun 16 08:54] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
[Worker #1 Jun 16 08:55] M215856353 stage 2 is 59.80% complete. Time: 292.179 sec.
[Worker #2 Jun 16 08:56] Available memory is 14783MB.
[Worker #2 Jun 16 08:56] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
[Worker #2 Jun 16 08:58] Available memory is 14783MB.
[Worker #2 Jun 16 08:58] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
[Worker #1 Jun 16 08:59] M215856353 stage 2 is 59.83% complete. Time: 292.265 sec.
[Worker #2 Jun 16 09:00] Available memory is 14783MB.
[Worker #2 Jun 16 09:00] Using 3MB of memory.  Processing 2400 relative primes (0 of 2400 already processed).
That's on a machine with 16 workers, only 2 are high memory. There are no lines of other workers missing. So I'd like to know why he is restarting ca. every two minutes! This is going on like this for a good while.
kruoli is online now   Reply With Quote
Old 2020-06-17, 01:11   #537
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

7,013 Posts
Default

Quote:
Originally Posted by kruoli View Post
It occured to me that it is much worse for smaller exponents

That's on a machine with 16 workers, only 2 are high memory. There are no lines of other workers missing. So I'd like to know why he is restarting ca. every two minutes! This is going on like this for a good while.
I do not know why that is happening. I do know that's some very complicated code that has given me plenty of trouble in the past.

Look at undoc.txt. I believe there is a way to set max memory usage for each worker. This could lead to a better way to control memory allocation for your usage.
Prime95 is offline   Reply With Quote
Old 2020-06-17, 02:13   #538
dcheuk
 
dcheuk's Avatar
 
Jan 2019
Pittsburgh, PA

3×7×11 Posts
Default

Quote:
Originally Posted by smonkie View Post
Hi Franz! And the others too. :)

I've read carefully your issue. I've been dealing with the same exact trouble with a 3950X. I first tried it in an Aorus Master X570, and for the love of god I couldn't manage to get it Prime95's small ffts stable at stock settings. I tried many BIOS version, I tried different fan configurations, I tried different RAM modules. I couldn't.

Yesterday I decided to try a new board (X570 Taichi) and even when Prime95 seems to cope a little bit better with UEFI defaults, one worker crashes within the first minutes.

So this is clearly something related with not just a particular brand, rather a general power delivery issue extended to Ryzen boards. It's really a boomer because I love to get all my systems Prime95 stable, it just feels right to have that kind of stability. But can't see how we are going to get over this...
I also have the 3950X on the Asrock x570m motherboard and have not experienced any issues you guys ran into. My bios is the latest version, win10 pro latest version, prime95 29.8 build 6. Both my ram kits worked for DC/PRP/P-1/PRP-CF/TF/benchmarks without any issues: HyperX Predator 3600mhz cl16 4x16gb (however I am only getting 3200mhz at cl16) and Corsair dominator 3600mhz cl16 4x16gb (setting to cl15 also worked, but throw Gerbiz errors).

I use the h115i pro aio cooler (placed at intake) and with 2 workers running at 6 cores each, temperature stabilizes at 65c to 75c after hours of running. It had no problem continuously running at this setup.

Hope that helps.

EDIT: My PSU is EVGA Supernova 1200P2 80+ Platinum, only the 8pin is connected to the mb, gpu is 2080super, no oveclock except ram.

Last fiddled with by dcheuk on 2020-06-17 at 02:25
dcheuk is offline   Reply With Quote
Old 2020-06-17, 09:28   #539
pepi37
 
pepi37's Avatar
 
Dec 2011
After milion nines:)

130610 Posts
Default

I buy 3900x: and now it runs 448K over few days on all 12 cores +HT without any problem on 3.9 Ghz with lowered voltage . Motherboard is Asrock Gaming 4 ( 570 chipset)
Compared to yours motherboard my motherboard is "little baby" but has any stability issue.
In few days current work will be done, so I will switch to 2 workers 3+3 and rest workers 1+1 and will inform you if I will have any issues with that setup
pepi37 is online now   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prime95 version 29.2 Prime95 Software 71 2017-09-16 16:55
Prime95 version 29.1 Prime95 Software 95 2017-08-22 22:46
Prime95 version 26.5 Prime95 Software 175 2011-04-04 22:35
Prime95 version 25.9 Prime95 Software 143 2010-01-05 22:53
Prime95 version 25.8 Prime95 Software 159 2009-09-21 16:30

All times are UTC. The time now is 13:02.

Fri Aug 7 13:02:34 UTC 2020 up 21 days, 8:49, 1 user, load averages: 1.95, 2.07, 2.21

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.