mersenneforum.org  

Go Back   mersenneforum.org > Extra Stuff > Linux

Reply
 
Thread Tools
Old 2015-12-11, 21:15   #1
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

92710 Posts
Default How to properly delete Linux on a multibot PC?

Ever since Microsoft took a wrong turn with Windows 8, I've been dipping my toes into the Linux world. My few experiments (mainly with Zorin OS and Netrunner) have by and large been successful, with the notable exception of the tiresome need to keep reinstalling the OS as a shiny new version comes out and support is dropped for the previous one.

Now Microsoft has compounded its Win8 errors with Windows 10 and I'm looking at End of Support for Windows 7 in 2020. Five years off still, I know, but I want to be ready to make the switch if necessary. Which leads me (finally) to my question for you Linux connoisseurs.

I had honed in on Netrunner 12.12 as an easy-to-use and visually stunning distro. But then they stopped issuing updates for it. When I downloaded Netrunner 16 and went to install it on my test PC, the installer program appeared to be much more obscure than I remember it from version 12: for the life of me, I could not figure out where exactly to tell it to put Netrunner 16. I had wanted to write over the existing Netrunner 12 installation, but the installer did not seem to want to offer me that option. (This was some months ago so I can't remember the exact details.)

Not wanting to take any chances (the test PC also has XP and Vista on it), eventually I had Netrunner 16 install on its own new, separate partition. So now I have four OSes on that machine.

Yesterday I went to update Netrunner 16 and wanted to install NVIDIA drivers for the graphics card. But the Synaptics Package Manager (or whatever it's called) would not finish downloading the driver. I canceled the operation and found an alternative way to do it, but now I keep getting cryptic messages about some "package" being "broken" and that I need to fix that first, without a hint of an explanation as to what exactly is broken or how to fix it. I found some function to fix broken packages, but it stops with some other oddslot error claiming that it couldn't do the fix.

So I'm sick and tired of this Netrunner 16 and want to UNinstall the d*mn thing. Here's my question for you: what is the proper way to uninstall a Linux OS, such that the bootloader gets adjusted accordingly (and automatically)? I don't want to simply nuke the partition and remain with a bootloader that thinks I still have Netrunner 16 on it -- I imagine that could cause problems at startup.

Any suggestions? Ultimately I would like to also delete Netrunner 12 and replace it with Linux Mint 17 to continue my dabbling in Linux.

Thanks in advance.
Rodrigo is offline   Reply With Quote
Old 2015-12-12, 06:50   #2
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×29×83 Posts
Default

Proprietary drivers and package managers don't tend to work well for the most part.

Nuking the partition followed by "sudo update-grub" in your Netrunner 12 installation should do the trick. I don't know if there's a "proper" way to do it, but that's how I know to do it off the top of my head. (Running "update-grub" from a live disc is also possible, though substantially harder since you have to fake the live OS into operating on the actual hard drive rather than itself [this is done via chroot if you know what that is].)

Linux Mint, like most other popular Linux distros, offers long term support. Mint 17 will be supported until 2019. I use Mint Debian myself.
Dubslow is offline   Reply With Quote
Old 2015-12-12, 16:45   #3
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

92710 Posts
Default

Hey Dubslow, long time no see!

Thanks for the tip. I will try that and see what happens.

BTW, this reviewer's experience installing a current version of Netrunner gives some idea of what I went through (scroll down to the section, "Installation - Prepare to suck", first paragraph). My experience wasn't nearly as bad as his, but the installer leaves a lot to be desired.
Rodrigo is offline   Reply With Quote
Old 2015-12-12, 16:57   #4
kladner
 
kladner's Avatar
 
"Kieren"
Jul 2011
In My Own Galaxy!

2·5,059 Posts
Default

If there is only one partition, and you have some alternate boot options, utilities like WD Data Lifeguard can be made to write zeros to the first and last million sectors on the drive. You can also write zeros to the whole drive, but that takes forever and doesn't accomplish anything more, IME.
kladner is offline   Reply With Quote
Old 2015-12-12, 23:47   #5
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

32·103 Posts
Default

Trouble is, there are three operating systems on that drive, even excluding Netrunner 16, plus an OEM partition.

XP is the first OS installed on the HDD, followed by Vista and then Netrunner 12.
Rodrigo is offline   Reply With Quote
Old 2015-12-13, 00:30   #6
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

249F16 Posts
Default

Quote:
Originally Posted by Rodrigo View Post
Trouble is, there are three operating systems on that drive, even excluding Netrunner 16, plus an OEM partition.

XP is the first OS installed on the HDD, followed by Vista and then Netrunner 12.
I don't really understand the problem. But, to remove the master boot record simply do:

Code:
dd if=/dev/zero of=/dev/sda bs=446 count=1
...as root (under Linux) on said machine. Replace "/dev/sda/" with whatever your harddrive shows up as. It could be "/dev/hda" etc instead.

Make sure you type this exactly correctly. The "dd" command can very dangerous.

To remove the different partitions, use the "fdisk" command. This can also be very dangerous.

I accept no liability if these commands cause you problems, but these are the tools I use at least once a month to do what you are wishing to do.

Last fiddled with by chalsall on 2015-12-13 at 00:32
chalsall is offline   Reply With Quote
Old 2015-12-13, 06:38   #7
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×29×83 Posts
Default

Quote:
Originally Posted by chalsall View Post
I don't really understand the problem. But, to remove the master boot record simply do:
That's not what he wants to do. He wants to remove one of four OSs and its partition, while leaving the other three intact, and updating the bootloader to remove the entry for the fourth. What I suggested is a way to do that; completely removing the bootloader is a good way to get yourself into endless trouble for no reason whatsoever.

Perhaps a more cautious variant on the theme I proposed is to, under Netscape 12, modify the grub config files to remove the entry for Netrunner 16, then run "update-grub", and reboot to verify that the booloader entry for Netrunner 16 no longer exists. Then its partition may be safely removed via however method (I would suggest a live disc).

Last fiddled with by Dubslow on 2015-12-13 at 06:42
Dubslow is offline   Reply With Quote
Old 2015-12-13, 15:22   #8
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

249F16 Posts
Default

Quote:
Originally Posted by Dubslow View Post
That's not what he wants to do. He wants to remove one of four OSs and its partition, while leaving the other three intact, and updating the bootloader to remove the entry for the fourth.
Ah, thanks. I misunderstood the desire. Doing what I showed definitely won't achieve this....
chalsall is offline   Reply With Quote
Old 2015-12-13, 23:22   #9
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

32×103 Posts
Default

Quote:
Originally Posted by Dubslow View Post
Perhaps a more cautious variant on the theme I proposed is to, under Netscape 12, modify the grub config files to remove the entry for Netrunner 16, then run "update-grub", and reboot to verify that the booloader entry for Netrunner 16 no longer exists. Then its partition may be safely removed via however method (I would suggest a live disc).
Sounds like a plan. I'll try that method first. If you hear desperate wailing off in the distance, you'll know I screwed it up.
Rodrigo is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Submission not Properly Registered a1call FactorDB 5 2016-04-17 16:59
How to properly put a MacBook to Rust in Pieces ewmayer Hardware 25 2012-08-04 05:00
worker window settings not updating properly? ixfd64 Software 0 2011-01-24 04:36
need help - assignments did not transfer properly ixfd64 Software 4 2011-01-01 18:58
How to delete a benchmark? Brain PrimeNet 8 2010-11-22 03:20

All times are UTC. The time now is 05:14.

Thu Dec 3 05:14:39 UTC 2020 up 1:25, 0 users, load averages: 1.31, 1.29, 1.28

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.