Go Back > Factoring Projects > YAFU

Thread Tools
Old 2016-02-04, 21:41   #12
swellman's Avatar
Jun 2012

23×353 Posts

No it is not an especially slow time for my computer but definitely on the high side for a SNFS ~240. Lots of scatter in the ETA vs. SNFS curve though.

Your results show that performance in Linux is better than in Windows. I don't disagree, but I eventually left Linux as I got tired of arm wrestling my machines everytime I wanted to use them...
swellman is online now   Reply With Quote
Old 2016-02-24, 09:54   #13
Dan Ee
Mar 2013

7 Posts

I am unable to reproduce the failure. Need more details on how to reproduce.

I tried
D:\Factoring\lasieve4_ivybridge>gnfs-lasieve4I14e.exe -v -a -f 24000000 -c 2000 c189_147_41.txt
gnfs-lasieve4I14e (with asm64): L1_BITS=15, SVN $Revision$
Warning:  lowering FB_bound to 23999999.
FBsize 1506969+0 (deg 6), 2888143+0 (deg 1)
total yield: 3071, q=24002051 (0.09361 sec/rel) ETA 0h00m)
124 Special q, 762 reduction iterations
reports: 34229068->499577->448037->350947->293902->293567
Number of relations with k rational and l algebraic primes for (k,l)=:

Total yield: 3071
0/0 mpqs failures, 2240/2604 vain mpqs
milliseconds total: Sieve 107431 Sched 0 medsched 41680
TD 19527 (Init 77, MPQS 2316) Sieve-Change 118852
TD side 0: init/small/medium/large/search: 2660 217 1398 3785 301
sieve: init/small/medium/large/search: 1248 15476 1039 35173 220
TD side 1: init/small/medium/large/search: 3041 393 1166 3743 383
sieve: init/small/medium/large/search: 1564 16673 942 32846 2250
Content of c189_147_41.txt
n: 205451388964856467807686090421078666750691138189010020165236543387336128283211048921251478839880150378554118455189058228045898855699277369470472121604743428745579798048420314101101241961387
# 147^41+41^147, difficulty: 237.08, anorm: 6.37e+39, rnorm: -1.95e+45
# scaled difficulty: 237.08, suggest sieving algebraic side
# size = 2.485e-12, alpha = -0.188, combined = 2.415e-13, rroots = 0
type: snfs
size: 237
skew: 14.7100
c6: 1
c0: 10131387
Y1: -509111094534718962173411120845918138561
Y0: 1483273860320763
m: 44008401100288010210378427144625977757864842683924464711360809690583398911228987316128214321844953723667341332495287889981170421945600498539914605816457803581780075658984410989729763013655
alim: 48000000
rlim: 48000000
lpba: 31
lpbr: 31
mfba: 62
mfbr: 62
alambda: 2.5
rlambda: 2.5
I also tried running nfs(the number) in yafu and sieving seems to make progress.
Dan Ee is offline   Reply With Quote
Old 2016-02-24, 14:42   #14
swellman's Avatar
Jun 2012

23·353 Posts

Are you running on a Windows machine? The bug does not seem to occur in Linux.
swellman is online now   Reply With Quote
Old 2016-02-24, 19:02   #15
Basketry That Evening!
Dubslow's Avatar
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

722110 Posts

D:\Factoring\lasieve4_ivybridge>gnfs-lasieve4I14e.exe would certainly seem to indicate Windows
Dubslow is offline   Reply With Quote
Old 2016-02-25, 00:38   #16
Batalov's Avatar
Mar 2008

5×23×79 Posts

Unsure about the Windoze port, but the original sievers long ago in the past had the childhood disease of sieving quite poorly when some unwritten rules were violated by a poly. (And it did happen with the automatically generated xyyx polys because of the specificity of the construction.) These unwritten rules were:
1. Y1 > 0
2. |Y1| <= |Y0|
These are easily accommodated for -- one by negating the rat'nl poly, and the other, by flipping both polyns on their heads (i.e. swap all poly indices cj, Yi :: i,j for deg side-i). You may want to try that.

EDIT: another, unrelated hunch to try in parallel. Because 147 happens to be 3*72, one can try to lower the skew by leaving 74 out (that is do over-multiply the algebraic poly by 3 but not by 72; leave coeffs as 7^4*x^6 + 3*41^3*y^6, and m=x/y (or y/x as the case may be, I haven't pulled out a napkin to play; this, here, is the napkin ...and its margins are too narrow). Or 3^5*x^6 + 41^3*7^2*y^6 (less likely to be useful)

Last fiddled with by Batalov on 2016-02-25 at 00:50
Batalov is offline   Reply With Quote

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspect result stebbo PrimeNet 23 2017-06-03 11:14
What does my result mean? Unregistered Information & Answers 6 2013-04-16 21:52
Odd result 1997rj7 PrimeNet 2 2009-12-04 08:48
strange GMP-ECM result yoyo GMP-ECM 1 2009-08-08 07:09
New Result R.D. Silverman NFSNET Discussion 1 2005-04-19 23:45

All times are UTC. The time now is 18:53.

Wed Aug 12 18:53:25 UTC 2020 up 26 days, 14:40, 0 users, load averages: 2.39, 2.29, 2.32

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.