mersenneforum.org  

Go Back   mersenneforum.org > Prime Search Projects > No Prime Left Behind

Reply
 
Thread Tools
Old 2008-05-25, 19:42   #1
tnerual
 
tnerual's Avatar
 
Oct 2006

1000000112 Posts
Default llrnet and linux 64 bits ...

hello, i'm using ubuntu 64 bits on my amd X2-4200 ...

i have a problem with llrnet timings:

athlon xp 2500+ : 800 sec.
PIV-1600 : 1600 sec.
athlon X2 : 1200 sec.

how is it possible for the x2 to be slower than the athlon xp ?
before using linux i was using win 2000 and the timings were better than on the athlon.

anon (i know you use ubuntu): do you have any idea ?
tnerual is offline   Reply With Quote
Old 2008-05-25, 20:01   #2
em99010pepe
 
em99010pepe's Avatar
 
Sep 2004

2×5×283 Posts
Default

When I installed Ubuntu I notice a thread/service running behind eating all the CPU time...now I can't remember the name of it.

Last fiddled with by em99010pepe on 2008-05-25 at 20:03
em99010pepe is offline   Reply With Quote
Old 2008-05-25, 20:04   #3
tnerual
 
tnerual's Avatar
 
Oct 2006

7·37 Posts
Default

100% for llr1 and 100% for llr2

no hidden process :(
tnerual is offline   Reply With Quote
Old 2008-05-25, 20:32   #4
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

Are you by any chance using Ubuntu 8.04? I noticed that when I upgraded to 8.04, suddenly everything was slower. I found out that for some reason, the OS insisted on keeping the CPU in lower-clock idle mode (in my case, 1.2Ghz instead of the default 2.2Ghz). The solution: to put two CPU Frequency Scaling Monitor applets on my taskbar, one for each core, and to use them to force the CPU into "performance" mode, i.e. don't clock down the CPU at all.

You might notice that the clock speed adjustment settings are grayed out at first; if you see that, run the command "sudo dpkg-reconfigure gnome-applets", enter your password when prompted, and answer "yes" when it asks whether the cpufreq-scalingmonitor applet should have root privileges (or something like that).

Hope this helps!

Anon
mdettweiler is offline   Reply With Quote
Old 2008-05-25, 21:07   #5
tnerual
 
tnerual's Avatar
 
Oct 2006

7×37 Posts
Default

ubuntu 7.1 ...and cpu throttling is not allowed (i unchecked it in the bios )

i suspect something with the 64 bits ... but i don't know what ...
tnerual is offline   Reply With Quote
Old 2008-05-25, 21:11   #6
IronBits
I ♥ BOINC!
 
IronBits's Avatar
 
Oct 2002
Glendale, AZ. (USA)

3·7·53 Posts
Default

Go into the BIOS and disable all throttling options.
SpeedStep(Intel) or Cool&Quit(AMD) features of the CPU
All DC crunchers and overclocking friends should have this disabled by default.

Take a look here for more:
http://www.google.com/search?hl=en&l...le&btnG=Search

Last fiddled with by IronBits on 2008-05-25 at 21:12
IronBits is offline   Reply With Quote
Old 2008-05-25, 21:21   #7
tnerual
 
tnerual's Avatar
 
Oct 2006

7×37 Posts
Default

Quote:
Originally Posted by IronBits View Post
Go into the BIOS and disable all throttling options.
SpeedStep(Intel) or Cool&Quit(AMD) features of the CPU
All DC crunchers and overclocking friends should have this disabled by default.

Take a look here for more:
http://www.google.com/search?hl=en&l...le&btnG=Search
it's ubuntu 7.1 and cpu throttling is disabled in bios ...
tnerual is offline   Reply With Quote
Old 2008-05-25, 22:32   #8
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

186916 Posts
Default

Maybe you should try the Ubuntu forums or IRC channels?
mdettweiler is offline   Reply With Quote
Old 2008-05-26, 05:18   #9
IronBits
I ♥ BOINC!
 
IronBits's Avatar
 
Oct 2002
Glendale, AZ. (USA)

100010110012 Posts
Default

Upgrade to the latest version, or, find the Frequency Scaling Monitor 'widget' and adjust it to full speed, and reboot...
The following has some ideas you can mull over
http://ubuntu.wordpress.com/2005/11/...uency-scaling/
and then there is always this
http://www.google.com/search?hl=en&l...22&btnG=Search

Last fiddled with by IronBits on 2008-05-26 at 05:20
IronBits is offline   Reply With Quote
Old 2008-05-26, 05:22   #10
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

Quote:
Originally Posted by IronBits View Post
Upgrade to the latest version, or, find the Frequency Scaling Monitor 'widget' and adjust it to full speed, and reboot...
The following has some ideas you can mull over
http://ubuntu.wordpress.com/2005/11/...uency-scaling/
and then there is always this
http://www.google.com/search?hl=en&l...22&btnG=Search
Oooh...actually you shouldn't reboot right after adjusting the CPU to full speed. At least for me, it resets to "Ondemand" mode (i.e. the mode that refuses to clock up for prime search apps) every time I reboot the computer.

I need to just go in the BIOS and disable CPU frequency scaling, and thus save myself the trouble of having to set it to "Performance" mode every time I boot up.

Edit: or I could just use the tips in the first link that IronBits posted.

Last fiddled with by mdettweiler on 2008-05-26 at 05:23
mdettweiler is offline   Reply With Quote
Old 2008-05-26, 05:32   #11
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

A quick Google search turned up this page, which documents all the different "governors" (i.e modes) that you can set the CPU frequency scaling thing to.

Here's a quote regarding the behavior of "ondemand" mode (please pardon the line numbers, they were in there on the original page and would be too big a hassle to remove):

Code:
109    2.4 Ondemand
110    ------------
111    
112    The CPUfreq governor "ondemand" sets the CPU depending on the
113    current usage. To do this the CPU must have the capability to
114    switch the frequency very quickly.  There are a number of sysfs file
115    accessible parameters:
116    
117    sampling_rate: measured in uS (10^-6 seconds), this is how often you
118    want the kernel to look at the CPU usage and to make decisions on
119    what to do about the frequency.  Typically this is set to values of
120    around '10000' or more.
121    
122    show_sampling_rate_(min|max): the minimum and maximum sampling rates
123    available that you may set 'sampling_rate' to.
124    
125    up_threshold: defines what the average CPU usaged between the samplings
126    of 'sampling_rate' needs to be for the kernel to make a decision on
127    whether it should increase the frequency.  For example when it is set
128    to its default value of '80' it means that between the checking
129    intervals the CPU needs to be on average more than 80% in use to then
130    decide that the CPU frequency needs to be increased.  
131    
132    sampling_down_factor: this parameter controls the rate that the CPU
133    makes a decision on when to decrease the frequency.  When set to its
134    default value of '5' it means that at 1/5 the sampling_rate the kernel
135    makes a decision to lower the frequency.  Five "lower rate" decisions
136    have to be made in a row before the CPU frequency is actually lower.
137    If set to '1' then the frequency decreases as quickly as it increases,
138    if set to '2' it decreases at half the rate of the increase.
139    
140    ignore_nice_load: this parameter takes a value of '0' or '1'. When
141    set to '0' (its default), all processes are counted towards the
142    'cpu utilisation' value.  When set to '1', the processes that are
143    run with a 'nice' value will not count (and thus be ignored) in the
144    overall usage calculation.  This is useful if you are running a CPU
145    intensive calculation on your laptop that you do not care how long it
146    takes to complete as you can 'nice' it and prevent it from taking part
147    in the deciding process of whether to increase your CPU frequency.
Notice especially the part about "ignore_nice_load" (at the end of the quote). I guess we know why Ubuntu 8.04 suddenly refuses to let processes with a "nice" value (such as prime-searching and other distributed computing apps) force the CPU to be clocked up, whereas in Ubuntu 7.10 they did.

Now if only I could figure out a way to change that setting back to "0"...
mdettweiler is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
LLRNet linux unable to resolve hostnames nuggetprime No Prime Left Behind 16 2008-12-23 07:46
Linux build for LLRNet client available! axn Sierpinski/Riesel Base 5 9 2008-11-26 03:47
64 bits versus 32 bits Windows S485122 Software 2 2006-10-31 19:14
Linux llrnet questions PhilF Prime Sierpinski Project 1 2005-12-16 08:36
35-35.2 to 62 bits, cont from 61 bits Khemikal796 Lone Mersenne Hunters 12 2005-12-01 21:35

All times are UTC. The time now is 22:48.

Sat Sep 19 22:48:29 UTC 2020 up 9 days, 19:59, 0 users, load averages: 1.72, 1.39, 1.30

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.