mersenneforum.org  

Go Back   mersenneforum.org > Extra Stuff > Linux

Reply
 
Thread Tools
Old 2018-04-10, 18:25   #1
VictordeHolland
 
VictordeHolland's Avatar
 
"Victor de Hollander"
Aug 2011
the Netherlands

23·3·72 Posts
Default Can't get OpenCL to work on HD7950 Ubuntu 14.04.5 LTS

Ubuntu 14.04.5 has dropped support for the fglrx driver for AMD/ATI GPUs.

While the newer AMDGPU-PRO drivers don't support my card (HD7950).

How can I get OpenCL to work ?? Do I really need to downgrade to 14.04.1 to get fglrx to work??

Quote:
fglrx and the 14.04.5 HWE stack

With 14.04.5, 14.04.2 through 14.04.4 have gone EOL. End-users may have previously used the proprietary fglrx driver, but as documented here fglrx will not work with the 14.04.5 kernel/X stack.
AMDGPU-PRO supported cards:
https://support.amd.com/en-us/kb-art...ase-Notes.aspx
VictordeHolland is offline   Reply With Quote
Old 2018-04-11, 01:32   #2
VictordeHolland
 
VictordeHolland's Avatar
 
"Victor de Hollander"
Aug 2011
the Netherlands

117610 Posts
Default

I downgraded to Ubuntu 14.04.2 and succesfully installed the debian fglrx packages from the AMD Linux drivers download page.

clinfo now lists the card again :).

It is a shame AMD doesn't support the HD7900 series and the 280X series in their new AMDGPU-PRO driver , they still have very good Doube Precision performance (800 GFLOPS) without a hefty price.

If somebody knows how to get OpenCL support for this card with 14.04.5 or 16.04 working than I'm all ears
VictordeHolland is offline   Reply With Quote
Old 2018-04-11, 02:46   #3
airsquirrels
 
airsquirrels's Avatar
 
"David"
Jul 2015
Ohio

11·47 Posts
Default

Quote:
Originally Posted by VictordeHolland View Post
I downgraded to Ubuntu 14.04.2 and succesfully installed the debian fglrx packages from the AMD Linux drivers download page.

clinfo now lists the card again :).

It is a shame AMD doesn't support the HD7900 series and the 280X series in their new AMDGPU-PRO driver , they still have very good Doube Precision performance (800 GFLOPS) without a hefty price.

If somebody knows how to get OpenCL support for this card with 14.04.5 or 16.04 working than I'm all ears
I’ve been able to get S9000 (Tahiti) and S7000 cards working, but the FirePro driver may have been supported longer in 16.04. Is the 7950 Tahiti?
airsquirrels is offline   Reply With Quote
Old 2018-04-11, 12:26   #4
VictordeHolland
 
VictordeHolland's Avatar
 
"Victor de Hollander"
Aug 2011
the Netherlands

23·3·72 Posts
Default

Quote:
Originally Posted by airsquirrels View Post
I’ve been able to get S9000 (Tahiti) and S7000 cards working, but the FirePro driver may have been supported longer in 16.04. Is the 7950 Tahiti?
Yes it is Tahiti Pro (that is what lspci reports):
Code:
lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti Pro [Radeon HD 7950/8950 OEM / R9 280]
VictordeHolland is offline   Reply With Quote
Old 2018-04-11, 13:44   #5
airsquirrels
 
airsquirrels's Avatar
 
"David"
Jul 2015
Ohio

51710 Posts
Default

https://support.amd.com/en-us/downlo...ux+x86_64#beta

This is the driver I use for the Tahiti S9000, although I don’t know if it will support the consumer Tahiti cards. It is essentially AMD-GPU-Pro 17.50
airsquirrels is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
LL with OpenCL msft GPU Computing 433 2019-06-23 21:11
OpenCL accellerated lattice siever pstach Factoring 1 2014-05-23 01:03
OpenCL for FPGAs TObject GPU Computing 2 2013-10-12 21:09
Lucas–Lehmer on on ATI's GPUs (OpenCl or Stream) sanzo GPU Computing 17 2011-06-06 16:17
How Do I Make Mprime Work In Ubuntu?? hesdeadjim Software 4 2010-01-01 19:03

All times are UTC. The time now is 05:53.


Tue Dec 7 05:53:23 UTC 2021 up 137 days, 22 mins, 0 users, load averages: 1.20, 1.29, 1.43

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.