View Single Post
Old 2011-04-02, 16:48   #5
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

C7B16 Posts
Default

How are you compiling GMP 4.3.2 for 64bit?

I get this error:
Quote:
configure: error: Oops, mp_limb_t is 32 bits, but the assembler code
in this configuration expects 64 bits.
You appear to have set $CFLAGS, perhaps you also need to tell GMP the
intended ABI, see "ABI and ISA" in the manual.
I compile in Mingw64 with:
./configure CC=gcc CFLAGS="-O2 -pedantic -m64 -std=gnu99 -mtune=core2 -march=core2" ABI=64 --build=x86_64-w64-mingw32
I also tried just:
./configure ABI=64
and variations.

I read on GMP website: "Gcc 4.3.2 miscompiles GMP on 64-bit machines", but I'm using gcc 4.6.0.

Last fiddled with by ATH on 2011-04-02 at 16:49
ATH is offline   Reply With Quote