View Single Post
Old 2010-12-11, 00:58   #7
Mini-Geek
Account Deleted
 
Mini-Geek's Avatar
 
"Tim Sorbera"
Aug 2006
San Antonio, TX USA

17·251 Posts
Default

Maybe you should try re-enabling hyper-threading, run 4 workers on 1 thread each, and set the affinities using this option:
Code:
You can arbitrarily change how the program assigns affinity to CPUs.
The program makes its best guess at assigning workers and helper threads
to CPUs for optimal speed.  However, new architectures or situations we
haven't considered may make different affinity setting desirable.  In
local.txt set
	AffinityScramble=string
Where the string "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz()"
is the 64-core "make no changes" string.  For example, let's say you have a system
with 8 logical cores with 4 workers each using a helper thread.  The program would
ordinarily assign the worker and helper threads to [0,1], [2,3], [4,5], [6,7].
However, if you think [0,2], [1,3], [4,6], [5,7] would give better performance,
you would set AffinityScramble=02134657 to test out your theory.
I think this would be what you want:
Code:
AffinityScramble=0246
Quote:
Originally Posted by Uncwilly View Post
Is it thermal throttling?
Good point. Another "obvious" thing we haven't asked (and maybe you haven't fully checked out): is anything else using large amounts of CPU, RAM, or hard drive access that might be interfering? Do you see similar slowdowns if you boot into safe mode?
Quote:
Originally Posted by ixfd64 View Post
I am using Windows 7, and I never changed the priority of Prime95 (either through the task manager or Prime95 itself). Interestingly, the CPU usage was around 50% the whole time. Does anyone know what might be happening?
Windows thinks of the HT cores the same as the physical ones (for that purpose anyway), so when it sees that they aren't being used, it thinks the CPU usage is 50% when it's really at max capacity for Prime95. Showing 50% usage is normal for HT-enabled machines.

Last fiddled with by Mini-Geek on 2010-12-11 at 01:01
Mini-Geek is offline   Reply With Quote