View Single Post
Old 2019-12-07, 19:09   #2
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

3,617 Posts
Default

Quote:
Originally Posted by lavalamp View Post
So, my machine had been running linear algebra for six and a half hours, with only 5 minutes to go I think, "It's close enough, I'll play some counter-strike while it finishes." I load the game and ... of course I get a blue screen.

No worries, there are checkpoints right? So I run msieve -s test.dat -l test.log -i test.ini -nf test.fb -t 4 -nc2 again and:
Code:
commencing linear algebra
read 3880716 cycles
cycles contain 12919660 unique relations
read 0 relations
error: cannot locate relation 44290431
Oh.

And it wipes the test.dat.mat file for good measure. Luckily I'd made a backup of everything first.

Then I see there are TWO checkpoint files, test.dat.chk and test.dat.bak.chk. So I try using the second checkpoint file and get the same error.

Is there anything I can do to rescue the process at this point without running the entire linear algebra step again?
If you have a backup of everything, try running -ncr instead of -nc2. That is the resume command for an interrupted process. -nc2 tells it to start nc2 over from the beginning.
EdH is offline   Reply With Quote