View Single Post
Old 2021-05-25, 20:53   #27
"Simon Josefsson"
Jan 2020

25 Posts
Default Success report

Hi! I did a clean install of Ubuntu 20.04.2 LTS on a Gigabyte Aorus X570 I Pro Wifi with a AMD Ryzen 5950x CPU and a Radeon VII card. The instructions worked fine, except for diff below, and it is now churning its first PRP's (both gpuowl and mprime).

Originally Posted by ewmayer View Post
o sudo apt install -y gcc gdb python libgmp-dev git ssh openssh-server clinfo libncurses5 libnuma-dev
Please add 'make' here -- as it is not installed by default or anything else.

Originally Posted by ewmayer View Post
o Add yourself to the video group. There are 2 options for doing this:
1. The AMD rocm installation guide suggests using the command 'sudo usermod -a -G video $LOGNAME'
Option 1 worked fine, after logout/login (or reboot).

However, after following all those instructions above, and building gpuowl fine, 'clinfo' would not find the GPU. I read some instructions here:

And indeed after doing the following, everything worked:

sudo apt install rocm-dkms

I'm using -maxAlloc 16GB since I'm only using one runner, is this pushing anything or is this fine?


Last fiddled with by jas on 2021-05-25 at 20:54
jas is offline   Reply With Quote