View Single Post
Old 2004-07-05, 01:40   #1
optim
 
optim's Avatar
 
Nov 2003
European Union

23·13 Posts
Unhappy corrupt tar.gz file

Hello, I performed some upgrades to a computer recently and I backed up my whole MPrime 23.5.2 directory in a tar.gz file. (I use Linux Suse 9,1). Then, I uploaded my backup to my yahoo mail and performed the system upgrade (changed disks from ata to sata, new case, new dvd, reinstalled suse on new disk etc etc).

I just finished reinstalling suse an hour ago. Downloaded my mprime backup from yahoo mail and tried to gunzip and tar-x it (that is, uncompress it!). Something went wrong, tar was refusing to terminate or output anything. Checked the downloaded tar.gz file: 6MB. But I am pretty sure my backup tar.gz was only 4-4.5MB. how is it possible?

Tried Ark, a graphical archiver. It said it is corrupt and impossible to uncompress. Damn. I managed to uncompress individual files however, and recovered the files I needeed to resume my M33 crunching. Now I just downloaded again mprime from mersenne.org

The question is: Should I trust these recovered files from a corrupt tar.gz archive?

local.ini mY011451 prime.ini prime.log results.txt worktodo.ini

is there any possibility to encounter errors in mprime because of this? maybe it would be better to start crunching another number from the begginning?
optim is offline