View Single Post
Old 2017-06-16, 12:07   #2
ET_
Banned
 
ET_'s Avatar
 
"Luigi"
Aug 2002
Team Italia

483410 Posts
Default

Tried to compile on Odroid-C2 (Version 14.1 worked on Raspberry PI 3 32 bit).

Obviously I did not USE SSE2 or other Intel optimizations, but even using either the
Code:
gcc -c -O3 -DUSE_THREADS ../*.c >& build.log
or the
Code:
gcc -c -O3 ../*.c >& build.log
option, I had errors (see attachments).

I assumed the version was targeted to Intel/AMD platforms, and I know that optimization for ARM processors is next on your to-do list, so I'm not complaining .
I had some spare time and decided to give the code a try on my platform, that's all.

From a quick look I see that on line 783 of platform.h you ask
Code:
/* ARMv8 64 bit processors support native 64 bit types */
#elif(defined(__aarch64__))
but a quick grep can't locate where the symbol should be defined (this line didn't appear on version 14.1, as the condition was driven by ARM_EABI). I guess it's a placeholder for a next version.

Anyway I also tried to compile the source on my Intel G2030 following the readme, with no success (see attached build_Intel-log).

Again,
Code:
../platform.h:1462:3: error: #else after #else
I feel sorry and inapt for this job as it looks it's something related to myself and my computers, and not to the code.

Luigi
Attached Files
File Type: gz system.txt.tar.gz (848 Bytes, 284 views)
File Type: gz build.log.tar.gz (6.3 KB, 285 views)
File Type: zip build_Intel.log.zip (4.1 KB, 278 views)

Last fiddled with by ET_ on 2017-06-16 at 12:08
ET_ is offline   Reply With Quote