View Single Post
Old 2020-06-08, 12:48   #49
charybdis
 
Apr 2020

3·5·7 Posts
Default

Quote:
Originally Posted by Madpoo View Post
Hi Charybdis - I tried running this on a system with Xeon E5649 processors (Nehalem generation, Westmere EP class).

I can run it and do a simple test factor like "yafu 121" and get basic factors.

Then I tried to run a tune() and it crashed. Is this compiled with any options that wouldn't work on that CPU?

James and I have been testing things out in regards to odd things that the 1.34 version is doing on the Primenet server and hoping this newer build works around it, so hopefully we can get a Nehalem (or even just Xeon "Core") build with those options.

Nehalem does have SSE 4.1 (and 4.2) so I don't think that would be it...

Here's a link to the details for that CPU:
Nehalem / Westmere EP info

FYI, when I run this on my own laptop, with i7-7700, it seems just fine.
Whoops, I used GMP-ECM and msieve libraries that I compiled a few months ago on the same machine, and of course those might be incompatible with older CPUs - I suspect the binary I posted won't work on anything older than Skylake.

Might try again when I've got a bit of time...
charybdis is offline   Reply With Quote