View Single Post
Old 2011-09-20, 20:12   #1
patrik
 
patrik's Avatar
 
"Patrik Johansson"
Aug 2002
Uppsala, Sweden

52·17 Posts
Default CUDA Toolkit for OpenSUSE 11.2--gcc 4.5 and up are not supported

I'm trying to compile mfaktc for my new graphics card. I'm using OpenSUSE Linux 11.4, so I tried to install CUDA Toolkit for OpenSUSE 11.2. But when I compile mfaktc I get:
Code:
pjoh@linux-j6ed:~/mfaktc-0.17/src> make
/usr/local/cuda/bin/nvcc -I/usr/local/cuda/include/ --ptxas-options=-v --generate-code arch=compute_11,code=sm_11 --generate-code arch=compute_20,code=sm_20 --compiler-options=-Wall -c tf_72bit.cu -o tf_72bit.o
In file included from /usr/local/cuda/include/cuda_runtime.h:59:0,
                 from <command-line>:0:
/usr/local/cuda/include/host_config.h:82:2: error: #error -- unsupported GNU version! gcc 4.5 and up are not supported!
make: *** [tf_72bit.o] Fel 1
pjoh@linux-j6ed:~/mfaktc-0.17/src> gcc --version
gcc (SUSE Linux) 4.5.1 20101208 [gcc-4_5-branch revision 167585]
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
What is the best way to resolve this? Downgrading to OpenSUSE 11.2? Or install a CUDA toolkit for a different Linux distribution on my OpenSUSE computer?

If I downgrade, is there a risk that my hardware won't be supported? I'm using a Core i5 2500K on an ASUS P8P67 LE and graphics card ASUS Geforce GTX 560 DC 1GB.
patrik is offline   Reply With Quote