View Single Post
Old 2004-05-04, 01:20   #15
nevillednz
 
May 2004

32 Posts
Thumbs up Good news???

I manually entered the URL (produced by debug) into Galeon (A modern/nice web browser):
http://mersenne.org/cgi-bin/pnHttp.e...DD1ADB296E68AA

And got as a reply:
pnResult=0

It seems like a very small result for such alot of CPU cycles. I hope there is some kind of parity/CRC check in it.

Then I checked my primenet_report:
http://www.mersenne.org/cgi-bin/primenet_report.pl

And got:
------- Exponents Cleared since last Synchronization -------

prime fact Lucas-Lehmer residue or factor
exponent bits [residues partially masked] date returned computer ID
-------- ---- -- -------------------------------- --------------- ------------
18080627 67 0xE0DD1ADB296E68__ 03-May-04 23:42 romeo

I think this is good news???

Also:
Mersenne PrimeNet Server 4.0 (Build 4.0.031)
Cleared Exponents Report 04 May 2004 00:00 (May 3 2004 5:00PM Pacific)
prime fact Lucas-Lehmer residue or factor
exponent bits [residues partially masked] date returned account ID computer ID
-------- ---- -- -------------------------------- --------------- -------------- ------------
18080627 67 0xE0DD1ADB296E68__ 03-May-04 23:42 nevillednz romeo

Also:
Mersenne PrimeNet Server 4.0 (Build 4.0.031)
Assigned Exponents Report 04 May 2004 00:00 (May 3 2004 5:00PM Pacific)
prime fact current days
exponent bits iteration run / to go / exp date updated date assigned account ID computer ID
-------- -- ---- --------- ----------------- --------------- --------------- -------------- ------------

18079903 66 76.8 -54.8 5.2 18-Feb-04 05:08 17-Feb-04 06:17 dado55 yoo
18080747 67 288522 278.5 6.3 66.3 01-May-04 07:31 30-Jul-03 12:59 S118086 C5C77BD48
18081691 67 2264485 49.8 -9.7 50.3 12-Apr-04 08:55 15-Mar-04 06:21 S154512 C295725BE

romeo with 18080627 nolonger appears. So... I think I am done.

It seems that the URL generated by mprime can be entered directly into any other web browser to affect the mprime server update. I this is so, then this means the problem is in the mprime client software. Maybe something as simple as a carriage return being sent when a linefeed is expected??? When I do my next job I will try the static linked version of mprime. This eliminates other permutations as we can be sure that some local library call isn't messing around with the URL stream.

posted by: Pablo the Duck's Avatar
> I've been using Mprime 2.35 on Libranet 2.7, 2.8 and Slackware 9.0 - kernel versions
> 2.4.20 and 2.6.4 (which I abandoned because it ran slightly slower) - since last
> September without any connection problems.

In case other linux clients encounter a similar problem with connecting to mprime server:
I am using Mprime 2.35 on Redhat9 kernel 2.4.20-28.9.
And rpm glibc-2.3.2-27.9.7 for /lib/ld-linux.so.2 libm.so.6 libc.so.6 (as demanded by mprime client)

Im done. Time for my next job...

Thanx
NevilleD
nevillednz is offline