View Single Post
Old 2021-02-15, 21:58   #4
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
Rep├║blica de California

2×5×1,163 Posts
Default

Quote:
Originally Posted by Dylan14 View Post
I've updated the PKGBUILD for Arch Linux to v19.1, which follows the procedure as described in the readme document.

The fp-link patch is no longer needed, however, the sysctl-missing patch is still needed.
Thanks - the latter is the sysctl-deprecated warnings? Handling those is on my v20 to-do list - it's not as simple as blanket-removing the includes from platform.h, because I always try to support older platforms within reason, so that needs proper preprocessor #ifdef wrapping to retain the include on older distros of Linux and MacOS where that header is needed.

You're getting warnings, or your version of GCC is treating those "deprecated"s as errors?
ewmayer is offline   Reply With Quote