View Single Post
Old 2012-02-22, 08:41   #52
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

Quote:
Originally Posted by AMDave View Post
Your thoughts gave me a hunch, so I just redeployed the prpnetclient 5.0.5 bundle, but this time I set the INI to use llravx.exe instead of llr.exe (which is counter intuitive for this CPU but bear with me...)

It worked.

So, methinks the 2 filenames of llr.exe and llravx.exe are the wrong way around in the 5.0.5 bundle.

rogue / Lennart is there any way you can verify this?

ITMT I'll redeploy the clients to the T4500s in this configuration and see if I can pull back some ground.

Thanks for the hunch, Max.
Hmm...quite interestingly, there was somebody else at PrimeGrid who had it work exactly that way: he had an eminently "ordinary", non-AVX CPU that failed with regular LLR but worked with llrAVX. I don't recall what CPU he had, but given that you're experiencing basically the same thing, I would hazard a guess that the LLRs are indeed labeled correctly, and llrAVX (for some unknown reason) can handle your non-AVX CPU better.

Incidentally, the non-AVX llr.exe should be on the order of 25 MB, and llrAVX.exe around 35 MB (since it includes most, if not all, of the code for handling pre-AVX CPUs present in earlier versions, plus new code for AVX). If your copies match that, they're probably labeled correctly.

Edit: Aha, found it! The issue was reported here in a cross-post from the PrimeGrid forums. In this case the CPU was an AMD E350--one of the somewhat-recent AMD CPUs (non-Bulldozer) that is sold as an "APU"--a processor and graphics card wrapped up in one unit, AMD's counterpart to the on-die GPUs in Intel Sandy Bridges. Though it isn't a Bulldozer, it would make sense that the older LLR (more precisely, the older gwnum math library compiled into LLR--the AVX and non-AVX binaries currently provided are both LLR 3.8.7 but compiled with the development and stable gwnum releases respectively) might not be able to handle it since it's a newer and more "oddball" CPU type; but it doesn't explain why your much more common Pentium Dual-Core (C2D based) T4500 is experiencing the same issue.

I have personally used LLR (pre-AVX, in fact an older version, probably the same one you got from the 3.1.7 package) on a laptop Pentium Dual-Core Txxxx (not 4500 but close, a 2.0GHz model) and it worked fine--just like yours did with the older LLR. Unfortunately that laptop belongs to a family member 300 miles away and I can't readily test it with the latest LLR AVX and non-AVX builds to verify your results, but I am quite curious how that would turn out...

Last fiddled with by mdettweiler on 2012-02-22 at 09:00
mdettweiler is offline   Reply With Quote