View Single Post
Old 2016-12-25, 21:34   #5
ATH
Einyen
 
ATH's Avatar
 
Dec 2003
Denmark

60768 Posts
Default

I got Linux installed on my old Core2Quad computer and tried to compile it.

Here is a 64bit version you can try: gmpecm-svn3013-core2-linux.tar.gz

GMP 6.1.2 is compiled with:
./configure ABI=64 CFLAGS="-O3 -m64 -march=core2 -mtune=core2" --enable-static --disable-shared
make
make install
make check

GMPECM svn 3013 compiled with:
autoreconf -i
./configure ABI=64 CFLAGS="-O3 -m64 -march=core2 -mtune=core2" CPPFLAGS="-I/usr/local/include" LDFLAGS="-static -static-libgcc -static-libstdc++" --disable-assert --enable-static --disable-shared
(added stack options, see below)
make
make ecm-params
make check
sudo make install

It would not accept the stack options the normal way in the LDFLAGS, so I opened the Makefile after the configure step. I searched for the line LIBECM_LDFLAGS and replaced the line it was in with:
LIBECM_LDFLAGS = -Wl,--stack,16777216,65536

I tried to add it to the normal LDFLAGS in the line about LIBECM_LDFLAGS in the Makefile, but it would not accept the "--stack" option in that line, I have no idea why.
ATH is online now   Reply With Quote