View Single Post
Old 2021-01-19, 23:41   #5
Dylan14
 
Dylan14's Avatar
 
"Dylan"
Mar 2017

2·293 Posts
Default mfaktc

There is a package for this program, developed by me here. This requires two dependencies: nvidia (the NVIDIA driver) and cuda (CUDA build environment), for the building of the program.

There is a patch needed to make the program build with the correct CC versions. This is contained in the file makeandparams.patch. The current version of CUDA at the time of this post (11.2) supports CC's 3.5-8.6. As new versions come out the NVCCFLAGS included in this patch file will need to be updated.
Also, the location of the CUDA toolkit has to be specified to be /opt/cuda/, instead of /usr/local/cuda/.

In addition, I changed the params.h file to allow the GPU_SIEVE_SIZE to go up to 2047.

Also provided is a default mfaktc.ini file, which is installed to /etc/mfaktc/mfaktc.ini. The user is advised to copy this into the directory in which he wants to run mfaktc in.

On occasion, a maximum CUDA version has to be specified since the driver may lag behind the CUDA toolkit. When this happens the user has 2 options: 1. Either downgrade CUDA and add cuda to the IgnorePkg line in /etc/pacman.conf until the driver catches up, or 2. Install the nvidia-beta driver from the AUR.
Dylan14 is offline