View Single Post
Old 2021-01-19, 23:26   #4
Dylan14
 
Dylan14's Avatar
 
"Dylan"
Mar 2017

11128 Posts
Default gpuowl

There is a package for this program, developed by me here. This program requires two dependencies: gmp and ocl-icd (both of which are available on the main Arch repos).

The file uses the stable tag version of the program and not the latest git commit. Otherwise, it is a straightforward build process.

A git version of this package could also be developed, however, this would require several changes to the PKGBUILD. Namely, the source would have to change from the current archive link to git+https://github.com/preda/gpuowl, checksums would have to be skipped, a pkgver() function would be needed to get the correct version, and possibly other changes. Also, I am not sure if the current git version is that much different from the stable 7.2 version.
Dylan14 is offline