View Single Post
Old 2020-03-26, 16:21   #77
RedGolpe
 
RedGolpe's Avatar
 
Aug 2006
Monza, Italy

2316 Posts
Default

I tried again but I can't manage "make" to work, apparently with any combination of the flags NFS=1 SKYLAKEX=1 USE_BMI2=1 USE_AVX2=1. At least, all tries with various flags seem to produce the same error:
Code:
redgolpe@c2018:~/yafu$ make NFS=1 SKYLAKEX=1 USE_BMI2=1 USE_AVX2=1
gcc -g -DUSE_BMI2 -DUSE_AVX2 -DUSE_AVX512F -DUSE_AVX512BW -march=skylake-avx512  -mbmi2 -mbmi -DUSE_BMI2 -DUSE_AVX2 -DUSE_SSE41  -mavx2  -DUSE_SSE41 -m64 -msse4.1 -DUSE_NFS -O2 -fomit-frame-pointer -Wall  -I. -Iinclude -Itop/aprcl -Itop/ -I../msieve/zlib -I../gmp/include -I../gmp-ecm/include/ -c -o factor/qs/msieve/lanczos.o factor/qs/msieve/lanczos.c
In file included from include/qs.h:30:0,
                 from factor/qs/msieve/lanczos.c:20:
include/cofactorize.h:1:1: error: version control conflict marker in file
 <<<<<<< .mine
 ^~~~~~~
include/cofactorize.h:228:1: error: expected identifier or ‘(’ before ‘||’ token
 ||||||| .r0
 ^~
In file included from factor/qs/msieve/lanczos.c:20:0:
include/qs.h:182:3: warning: data definition has no type or storage class
 } qs_params;
   ^~~~~~~~~
include/qs.h:182:3: warning: type defaults to ‘int’ in declaration of ‘qs_params’ [-Wimplicit-int]
include/qs.h:824:1: error: unknown type name ‘qs_params’; did you mean ‘tiny_qs_params’?
 qs_params sieve_params;
 ^~~~~~~~~
 tiny_qs_params
factor/qs/msieve/lanczos.c: In function ‘yafu_block_lanczos_core’:
factor/qs/msieve/lanczos.c:1245:5: warning: null argument where non-null required (argument 1) [-Wnonnull]
     fprintf(NULL, "linear algebra completed %u "
     ^~~~~~~
factor/qs/msieve/lanczos.c: In function ‘yafu_read_lanczos_state’:
factor/qs/msieve/lanczos.c:854:2: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Wunused-result]
  fread(&read_n, sizeof(uint32), (size_t)1, dump_fp);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Makefile:369: recipe for target 'factor/qs/msieve/lanczos.o' failed
make: *** [factor/qs/msieve/lanczos.o] Error 1

Last fiddled with by RedGolpe on 2020-03-26 at 16:21
RedGolpe is offline   Reply With Quote