View Single Post
Old 2009-03-03, 07:22   #2
10metreh's Avatar
Nov 2008

44228 Posts

Originally Posted by mdettweiler View Post
Just today I was using msieve to postprocess a GNFS job on a C101 which, by accident, had been very, very oversieved. During the filtering stage it kept giving me a "too many merge attempts" error; here's the sequence of events of how I encountered this error message and attempted to fix it:

-Sieving had collected almost 7 million relations, compared to about 5.5 million which was required for this job. I started msieve v1.34 (why I was using such an antiquated version is a somewhat long story) and it ran until it gave the "too many merge attempts" error after attempting to improve the matrix a number of times. The log file from this attempt is included in the attached archive as "msieve.log.134".

-I then tried re-running the job with msieve v1.40 beta. This also failed; by my admittedly quite limited understanding of how all this works, it appeared to do a little better in its attempts to improve the matrix, but still ultimately failed. The log file from this attempt is included as "msieve.log.140".

-Remembering a thread a while back that discussed problems that cropped up with humongously oversieved jobs in postprocessing, I tried whacking the # of relations down to about 6.5 million and ran it with v1.40. I couldn't tell whether this improved things much (though my later results indicated that this probably did help at least to some extent), and didn't save a log file from this attempt.

-I cut the # of relations down even more, to 5.75 million, and ran postprocessing with v1.40. This time it worked (somewhat fitfully, it appeared, though again my knowledge of how this stuff works is still somewhat limited and thus I could be dead wrong on this ) and produced factors. The log from this attempt is included as "".

It appears that the problem lies in the sheer amount of oversieving that was done on this number. I'm pretty sure that msieve's behavior in circumstances like this has been reported at least once before, but I figured I'd report this occurrence in case it ends up being helpful to improve the program.

One other, somewhat unrelated bug(?) that I noticed during the final and successful attempt to run the postprocessing was that despite the fact that I ran msieve with the "-t 2" command line flag to run on both cores of my computer, it only ran single-threaded during the linear algebra stage. I'm not sure if this is a bug, or if this is somehow this was due to the earlier wonkiness due to all the extra relations.

Anyway, just figured I'd post the logs from this somewhat difficult job in case it proves enlightening to anyone.


Last fiddled with by 10metreh on 2009-03-03 at 07:29
10metreh is offline   Reply With Quote