View Single Post
Old 2020-12-30, 15:19   #2
kriesel
 
kriesel's Avatar
 
"TF79LL86GIMPS96gpu17"
Mar 2017
US midwest

32×13×43 Posts
Default Installation

The 7120A device is a dual-slot PCIe card requiring up to 300W; 75W from the PCIe socket, 75W from a 6-pin power connector, and 150W from an 8pin power connector. At idle, the 7120A PCIe coprocessor draws around 100 watts. So don't physically install the coprocessor until you're ready to also spend the time to install supporting software and get it working, unless you want another 100W of continuous electrical space heating.
Power connectors are at the forward end. There is a high pressure low volume blower with cast body at the forward end. The air flow discharges out the opposite end. The device is a heavily, solidly constructed brick. It has a partial metal back plate and a nearly complete cover. It is full length, with a stout chrome plated extension at the forward end. The size limits which PCIe slots can be used on many motherboards. Removal of the forward bracket may help in some cases. The forward bracket when installed makes connecting power there awkward.
Physical installation is like that of a large gpu.

The coprocessor requires a host system with a BIOS that supports >4GB PCI/PCIe addressing. Enable that before proceeding to physical installation of the coprocessor.
It also requires a 64-bit host operating system, compatible with MPSS installation.
https://software.intel.com/content/w...pss.html#about lists officially supported host OSes:
Code:
The "IntelĀ® Manycore Platform Software Stack" is necessary to run the 
IntelĀ® Xeon Phi Coprocessor. Users often call this stack "MPSS" for short. 
It is dependent on Linux kernels 2.6.34 or later, and it has been tested to 
work with specific versions of 64-bit Operating Systems:

Red Hat Enterprise 6.0, 6.1, 6.2, 6.3, 6.4 and 6.5 (for MPSS 3.2 and 
earlier releases); versions 6.3, 6.4, 6.5, 6.6 and 7.0 (MPSS 3.3 and 3.4), 
versions 6.4, 6.5, 6.6 and 7.1 (MPSS 3.5), versions 6.7, version 7.2
(MPSS 3.6 and 3.7) and version 7.3 (MPSS 3.8)

SuSE Linux Enterprise Server (SLES) 11 SP1 and SP2 (MPSS 2.1),  
SuSE Linux Enterprise Server (SLES) 11 SP2 and SP3 (MPSS 3.3), 
SuSE 11 SP2 and SP3, SuSE 12 (MPSS 3.4), SuSE 11 SP3 and SuSE 12 (MPSS 3.5), 
SuSE 11 SP4, SuSE 12 SP1 (MPSS 3.6 and 3.7), SuSE 12 SP2 (MPSS 3.8)

Microsoft* Windows 7 Enterprise SP1, Windows 8/8.1 Enterprise, Windows 10, 
Windows Server 2008 R2 SP1, Windows Server 2012 and Windows Server 2012 R2
Upon power up after the physical installation, there is a ~3 Hz blinking blue LED visible through the dual-slot back bracket openings, which are large to vent lots of cooling air from the blower.

After physical installation and restart, Windows 10 Pro x64 Device Manager identifies the 7120A as a coprocessor. Windows has no idea where to find suitable drivers. That's ok. Loading its coprocessor drivers is part of the job of Intel's MPSS.


Top of reference tree: https://www.mersenneforum.org/showpo...22&postcount=1
Attached Thumbnails
Click image for larger version

Name:	xeon phi 7120a unknown to windows 10.png
Views:	33
Size:	27.1 KB
ID:	24077  

Last fiddled with by kriesel on 2020-12-30 at 16:03
kriesel is offline   Reply With Quote