View Single Post
Old 2020-04-13, 12:28   #492
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

3·372 Posts
Default Revisions >3076 of Dev No Longer Work With Cuda 10.x Due To "unnamed structs/unions" in cuda.h

It was recently reported to me that my GMP-ECM-GPU branch instructions for a Colab session no longer work. In verifying the trouble, I too, received the following, during compilation:
Code:
configure: Using cuda.h from /usr/local/cuda-10.0/targets/x86_64-linux/include
checking cuda.h usability... no
checking cuda.h presence... yes
configure: WARNING: cuda.h: present but cannot be compiled
configure: WARNING: cuda.h:     check for missing prerequisite headers?
configure: WARNING: cuda.h: see the Autoconf documentation
configure: WARNING: cuda.h:     section "Present But Cannot Be Compiled"
configure: WARNING: cuda.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------------------ ##
configure: WARNING:     ## Report this to ecm-discuss@lists.gforge.inria.fr ##
configure: WARNING:     ## ------------------------------------------------ ##
checking for cuda.h... no
configure: error: required header file missing
Makefile:807: recipe for target 'config.status' failed
make: *** [config.status] Error 1
Further research per ECM Team request showed the following from config.log:
Code:
In file included from conftest.c:127:0:
/usr/local/cuda-10.0/targets/x86_64-linux/include/cuda.h:432:10:  warning: ISO C99 doesn't support unnamed structs/unions [-Wpedantic]
         };
          ^
/usr/local/cuda-10.0/targets/x86_64-linux/include/cuda.h:442:10:  warning: ISO C99 doesn't support unnamed structs/unions [-Wpedantic]
         };
          ^
configure:15232: $? = 0
configure: failed program was:
| /* confdefs.h */
EdH is offline   Reply With Quote